summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornot_anonymous2016-12-18 13:05:53 -0700
committernot_anonymous2016-12-18 13:05:53 -0700
commitb1a24fc40d0e357422caf747236ab947858a6989 (patch)
tree82f924677421dca0a15ed88a48f6f5fa992e1601
parent19d9c566a7477608e1dde5b9a6e2e83f0d8073e6 (diff)
downloadaur-b1a24fc40d0e357422caf747236ab947858a6989.tar.gz
Updated
-rw-r--r--.SRCINFO10
-rw-r--r--LICENSE16
-rw-r--r--PKGBUILD28
3 files changed, 32 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 19f081d99809..9fd5c55a0c1c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
pkgbase = owx
- pkgdesc = A CLI tool for programming KG669V (Wouxun) HTs.
- pkgver = r17
+ pkgdesc = A CLI tool for programming Wouxun (KG669V,UVD1-3,UV1A, et al) HTs.
+ pkgver = r21
pkgrel = 1
url = http://owx.chmurka.net
arch = i686
arch = x86_64
license = Apache
license = custom:beerware
- makedepends = subversion
+ makedepends = git
depends = gcc-libs
replaces = wouxun
- source = owx-svn::svn+http://svn.chmurka.net/owx/trunk
+ source = owx-git::git://git.chmurka.net/owx
source = LICENSE
md5sums = SKIP
- md5sums = 04c8deadd6984048760870d0fb397f25
+ md5sums = 02ecf727fd7a0948393044fc17fc6f11
pkgname = owx
diff --git a/LICENSE b/LICENSE
index ccdeb6d8ccc9..01113bfe1a32 100644
--- a/LICENSE
+++ b/LICENSE
@@ -1,8 +1,10 @@
-Code is licensed on beerware license. You are encouraged to experiment and do
-anything you want as long as you keep README intact when distributing and if
-you feel that this code has been useful for you, you can send us some beer.
+Program is licensed under beer-ware license. We're HAMs and not lawyers,
+so no law hell applies here (nobody really reads licenses anyways), just
+pure HAM spirit. You are free to do with this program whatever you like,
+just be nice and don't remove the original authorship - that would be a
+bit shitty. If you feel that this code is worth this, you can just shout
+us some beer or donate some doges to this DogeCoin address:
+D8bVcncife3w1LAvurTdYknnmNBzkWuQwk
-Authors
-
-SP5GOF gof (at) chmurka.net - coding
-SQ5LWN baseciq (at) baseciq.org - reverse-enginnering and procotol information
+If you don't like the beer-ware license, like, if you prefer fruity
+drinks or something, you can use the Apache 2.0 license instead.
diff --git a/PKGBUILD b/PKGBUILD
index a911feeabb47..d3d752d024d6 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,33 +3,41 @@
# Contributor: Vitaliy Berdinskikh, aka UR6LAD <ur6lad@archlinux.org.ua>
pkgname=owx
-pkgver=r17
+pkgver=r21
+#.266923b
pkgrel=1
-pkgdesc="A CLI tool for programming KG669V (Wouxun) HTs."
+pkgdesc="A CLI tool for programming Wouxun (KG669V,UVD1-3,UV1A, et al) HTs."
arch=('i686' 'x86_64')
url="http://owx.chmurka.net"
license=('Apache' 'custom:beerware')
depends=('gcc-libs')
-makedepends=('subversion')
+makedepends=('git')
replaces=('wouxun')
-source=("$pkgname-svn::svn+http://svn.chmurka.net/$pkgname/trunk"
+source=("$pkgname-git::git://git.chmurka.net/$pkgname"
LICENSE)
md5sums=('SKIP'
- '04c8deadd6984048760870d0fb397f25')
+ '02ecf727fd7a0948393044fc17fc6f11')
pkgver() {
- cd "$srcdir/$pkgname-svn/$pkgname"
- printf "r%s" "$(svnversion | tr -d 'A-z')"
+ cd "$srcdir/$pkgname-git/"
+
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
}
prepare() {
- cd "$srcdir/$pkgname-svn/$pkgname"
+ cd "$srcdir/$pkgname-git/"
sed -i -e s:SVN:${pkgver}: src/version.h
sed -i -e s:' help':' README': src/cmds.cc
+
+ sed -i -e s:'local/':'': docs/README
+ sed -i -e s:'libexec':'lib/owx': docs/README
}
build() {
- cd "$srcdir/$pkgname-svn/$pkgname"
+ cd "$srcdir/$pkgname-git/"
make
}
@@ -40,7 +48,7 @@ package() {
cd $srcdir
install -m 644 LICENSE $pkgdir/usr/share/licenses/$pkgname
- cd "$srcdir/$pkgname-svn/$pkgname/docs"
+ cd "$srcdir/$pkgname-git/docs"
install -m 644 * $pkgdir/usr/share/doc/$pkgname
rm $pkgdir/usr/share/doc/$pkgname/LICENSE