summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMax Resch2015-08-05 14:34:21 +0200
committerMax Resch2015-08-05 14:34:21 +0200
commitf3b0be684d745c33c81be7236d29ca6ad1f69987 (patch)
treee8db6d7c92b9c44c8a439e05d5bb468c77cc5883
downloadaur-f3b0be684d745c33c81be7236d29ca6ad1f69987.tar.gz
Initial import from old AUR
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD33
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ad53c4a70bfa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = ox
+ pkgdesc = An Attribute Grammar Compiling System based on Yacc, Lex, and COx
+ pkgver = G1.04
+ pkgrel = 2
+ url = http://www.complang.tuwien.ac.at/ubvl/tools/ox/
+ arch = x86_64
+ arch = i686
+ license = OX
+ depends = flex
+ depends = bison
+ options = !makeflags
+ source = http://www.complang.tuwien.ac.at/ubvl/tools/ox/oxDistG1.04.sh.Z
+ source = http://www.complang.tuwien.ac.at/ubvl/tools/ox/ox-flex-new-gcc4.patch
+ md5sums = c5817fa2033cdf16fd8b554fbf227461
+ md5sums = 83420f31399244f7ba4e07f1aee670d5
+
+pkgname = ox
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f87b385f7381
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# Maintainer: Max Resch <resch.max@gmail.com>
+pkgname=ox
+pkgver=G1.04
+pkgrel=2
+pkgdesc="An Attribute Grammar Compiling System based on Yacc, Lex, and COx"
+url="http://www.complang.tuwien.ac.at/ubvl/tools/ox/"
+arch=('x86_64' 'i686')
+license=('OX')
+depends=('flex' 'bison')
+source=('http://www.complang.tuwien.ac.at/ubvl/tools/ox/oxDistG1.04.sh.Z'
+ 'http://www.complang.tuwien.ac.at/ubvl/tools/ox/ox-flex-new-gcc4.patch')
+md5sums=('c5817fa2033cdf16fd8b554fbf227461'
+ '83420f31399244f7ba4e07f1aee670d5')
+options=(!makeflags)
+
+build() {
+ cd "${srcdir}"
+ uncompress -c oxDistG1.04.sh.Z > oxDistG1.04.sh
+ chmod u+x oxDistG1.04.sh
+ rm -rf "oxDistG1.04"
+ ./oxDistG1.04.sh
+ cd "oxDistG1.04"
+ patch -p1 -i "${srcdir}/ox-flex-new-gcc4.patch"
+ cd "source"
+ make
+}
+
+package() {
+ cd "${srcdir}/oxDistG1.04"
+ install -Dm644 COPYRIGHT "$pkgdir/usr/share/licenses/$pkgname/COPYING"
+ install -Dm755 "source/ox" "$pkgdir/usr/bin/ox"
+ install -Dm644 "docs/ox.1" "$pkgdir/usr/share/man/man1/ox.1"
+}