summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEugene 'Vindex' Stulin2023-02-17 20:01:30 +0300
committerEugene 'Vindex' Stulin2023-02-17 20:01:30 +0300
commit11af74158b3d90554efbe3c6b0309260d69586d3 (patch)
tree38ddd1b3ed80c4cdc196aae4ce49bcb14ea38f96
downloadaur-11af74158b3d90554efbe3c6b0309260d69586d3.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD29
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b36032516dae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = oxfuse-ldc2
+ pkgdesc = High-level binding to libfuse3 for the D programming language, version for LDC2
+ pkgver = 0.1.0
+ pkgrel = 0
+ url = https://gitlab.com/os-18/oxfuse
+ arch = x86_64
+ license = Boost or LGPL3
+ makedepends = bash
+ makedepends = chrpath
+ makedepends = lsb-release
+ makedepends = fuse3
+ makedepends = pkgconf
+ makedepends = ldc
+ depends = fuse3
+ depends = ldc
+ source = oxfuse-ldc2-0.1.0.tar.gz::https://gitlab.com/os-18/oxfuse/-/archive/v0.1.0/oxfuse-v0.1.0.tar.gz
+ sha256sums = 87e0fdb48bf8c19c7f95f36ebac02947bbb441f739cacf8345db1f031da05222
+
+pkgname = oxfuse-ldc2 \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..db9557a23fd6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Eugene 'Vindex' Stulin <tech.vindex@gmail.com>
+
+PROJECT=oxfuse
+DESCR="High-level binding to libfuse3 for the D programming language"
+DC=ldc2
+DC_PKG=ldc
+makedepends=("bash" "chrpath" "lsb-release" "fuse3" "pkgconf" "ldc")
+depends=("fuse3" "ldc")
+pkgver=0.1.0
+pkgrel=0
+license=("Boost or LGPL3")
+
+pkgname=${PROJECT}-${DC}
+pkgdesc="${DESCR}, version for ${DC^^}"
+arch=("x86_64")
+url="https://gitlab.com/os-18/${PROJECT}"
+TARBALL=$pkgname-$pkgver.tar.gz
+source=("$TARBALL::$url/-/archive/v$pkgver/${PROJECT}-v$pkgver.tar.gz")
+sha256sums=("87e0fdb48bf8c19c7f95f36ebac02947bbb441f739cacf8345db1f031da05222")
+
+build() {
+ cd "${PROJECT}-v$pkgver"
+ make DC=${DC} || return 1
+}
+
+package() {
+ cd "${PROJECT}-v$pkgver"
+ make DESTDIR=$pkgdir install DC=${DC} || return 1
+}