summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRelwi2022-10-31 18:00:07 +0100
committerRelwi2022-10-31 18:00:07 +0100
commit394f83b46db258651c72323019b79de5502da34f (patch)
tree94dc576069858df6950edcb26a1748126cbd9422
downloadaur-394f83b46db258651c72323019b79de5502da34f.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD15
2 files changed, 28 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a11e2345aefb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = oxidizebot-bin
+ pkgdesc = High performance Twitch bot in Rust
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://github.com/udoprog/OxidizeBot
+ arch = x86_64
+ license = Apache
+ makedepends = cargo
+ makedepends = git
+ source = https://github.com/udoprog/OxidizeBot/releases/download/1.1.0/oxidize-1.1.0-linux-x86_64.zip
+ sha256sums = 133349e6a18510fc14c3010b5fbf2619d51f3a819342bc401f1ed1a820f5da4b
+
+pkgname = oxidizebot-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4159e27ae97b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,15 @@
+# Maintainer: Relwi <theofficialdork@hotmail.com>
+pkgname=oxidizebot-bin
+pkgver=1.1.0
+pkgrel=1
+pkgdesc='High performance Twitch bot in Rust'
+url='https://github.com/udoprog/OxidizeBot'
+source=("https://github.com/udoprog/OxidizeBot/releases/download/$pkgver/oxidize-$pkgver-linux-x86_64.zip")
+arch=(x86_64)
+license=(Apache)
+sha256sums=('133349e6a18510fc14c3010b5fbf2619d51f3a819342bc401f1ed1a820f5da4b')
+
+package() {
+ cd "$srcdir"
+ install -Dm755 oxidize "${pkgdir}/usr/bin/oxidize"
+}