summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12020-05-16 20:42:01 +0800
committerChocobo12020-05-16 20:45:27 +0800
commit319cbba6340ccc516767c289cb675a1fcfcbf8c6 (patch)
tree9c05de00ba13149dd94f28f740b2f54c772b9f5b
downloadaur-319cbba6340ccc516767c289cb675a1fcfcbf8c6.tar.gz
newpkg: oxipng-git 3.0.0.r3.ge4d4c93-1
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD42
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2e4232bf798c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = oxipng-git
+ pkgdesc = Multithreaded PNG optimizer
+ pkgver = 3.0.0.r3.ge4d4c93
+ pkgrel = 1
+ url = https://github.com/shssoichiro/oxipng
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = rust
+ depends = gcc-libs
+ provides = oxipng
+ conflicts = oxipng
+ source = git+https://github.com/shssoichiro/oxipng.git
+ sha256sums = SKIP
+
+pkgname = oxipng-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0e0413415d93
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=oxipng-git
+pkgver=3.0.0.r3.ge4d4c93
+pkgrel=1
+pkgdesc="Multithreaded PNG optimizer"
+arch=('i686' 'x86_64')
+url="https://github.com/shssoichiro/oxipng"
+license=('MIT')
+depends=('gcc-libs')
+makedepends=('git' 'rust')
+provides=('oxipng')
+conflicts=('oxipng')
+source=("git+https://github.com/shssoichiro/oxipng.git")
+sha256sums=('SKIP')
+
+
+pkgver() {
+ cd "oxipng"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+check() {
+ cd "oxipng"
+
+ #cargo test \
+ # --locked \
+ # --release
+}
+
+package() {
+ cd "oxipng"
+
+ cargo install \
+ --no-track \
+ --locked \
+ --root "$pkgdir/usr" \
+ --path "$srcdir/oxipng"
+
+ install -Dm644 "LICENSE" -t "$pkgdir/usr/share/licenses/oxipng"
+}