summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJean Lucas2018-06-25 12:29:18 -0400
committerJean Lucas2018-06-25 12:29:18 -0400
commit15e75efbd7981703f48fbf17471cddf77faa7bb3 (patch)
treefe2dd78b1aad8ad1bb955d948da625b7d18d3a82
downloadaur-15e75efbd7981703f48fbf17471cddf77faa7bb3.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD25
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bebc122a81fd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+# Generated by mksrcinfo v8
+# Mon Jun 25 16:29:11 UTC 2018
+pkgbase = oxy-git
+ pkgdesc = A secure remote access tool (Git)
+ pkgver = 2.0.1+1+g6fd7e30
+ pkgrel = 1
+ url = https://oxy-secure.app
+ arch = i686
+ arch = x86_64
+ license = BSD
+ makedepends = git
+ makedepends = cargo
+ conflicts = oxy
+ source = git+https://github.com/oxy-secure/oxy#branch=master
+ sha512sums = SKIP
+
+pkgname = oxy-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..151d353a24a6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Jean Lucas <jean@4ray.co>
+
+pkgname=oxy-git
+pkgver=2.0.1+1+g6fd7e30
+pkgrel=1
+pkgdesc='A secure remote access tool (Git)'
+arch=(i686 x86_64)
+url=https://oxy-secure.app
+license=(BSD)
+makedepends=(git cargo)
+conflicts=(oxy)
+source=(git+https://github.com/oxy-secure/oxy#branch=master)
+sha512sums=(SKIP)
+
+pkgver() {
+ cd $srcdir/oxy
+ git describe --tags | sed 's/v//;s/-/+/g'
+}
+
+package() {
+ cd $srcdir/oxy
+ cargo build --release
+ install -Dm 755 target/release/oxy $pkgdir/usr/bin/oxy
+ install -Dm 644 LICENSE $pkgdir/usr/share/licenses/oxy/LICENSE
+}