summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXavion2015-08-23 07:49:01 +1000
committerXavion2015-08-23 07:49:01 +1000
commita9ef4a802450c89cf3d00dc0eaf530bffe09acf8 (patch)
tree37f9e78350d37d38b2850b565168c1fd0f5132d2
parente5d518766fad2d68bdb3d13dbf58fb9fb0465b91 (diff)
downloadaur-a9ef4a802450c89cf3d00dc0eaf530bffe09acf8.tar.gz
Update to 5.3.2-1
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD22
2 files changed, 17 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2d413b3eab0b..2f8015434aa2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,19 @@
pkgbase = oxygen-cursors-extra
pkgdesc = KDE's Oxygen mouse cursor theme - the extra flavours
- pkgver = 4.11.14
+ pkgver = 5.3.2
pkgrel = 1
- url = http://www.kde.org
+ url = https://projects.kde.org/projects/kde/workspace/oxygen
arch = any
- license = GPL3
- makedepends = pkgconfig
+ license = LGPL
makedepends = cmake
makedepends = automoc4
makedepends = inkscape
makedepends = libltdl
makedepends = xorg-xcursorgen
+ optdepends = oxygen-cursors: contains the default Oxygen cursor colours
options = !emptydirs
- source = http://download.kde.org/stable/4.14.3/src/kde-workspace-4.11.14.tar.xz
- sha1sums = ec79a5d638a93b1abbb99b22a7bea52d9a2c26eb
+ source = http://download.kde.org/stable/plasma/5.3.2/oxygen-5.3.2.tar.xz
+ sha1sums = 86cd76b3eafaf3fd5664f2dadac43b76a54c6e29
pkgname = oxygen-cursors-extra
diff --git a/PKGBUILD b/PKGBUILD
index ca8afee14300..26673cbe5892 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,17 @@
# Maintainer: Xavion <Xavion (dot) 0 (at) Gmail (dot) com>
-pkgname=oxygen-cursors-extra
-_kdever_=4.14.3
-pkgver=4.11.14
+_pkgbase_=oxygen
+pkgname=${_pkgbase_}-cursors-extra
+pkgver=5.3.2
pkgrel=1
pkgdesc="KDE's Oxygen mouse cursor theme - the extra flavours"
arch=("any")
-url="http://www.kde.org"
-license=("GPL3")
-makedepends=('pkgconfig' 'cmake' 'automoc4' 'inkscape' 'libltdl' 'xorg-xcursorgen')
-#optdepends=("kdebase-workspace: contains the default cursor colours")
+url="https://projects.kde.org/projects/kde/workspace/oxygen"
+license=("LGPL")
+makedepends=('cmake' 'automoc4' 'inkscape' 'libltdl' 'xorg-xcursorgen')
+optdepends=("oxygen-cursors: contains the default Oxygen cursor colours")
options=(!emptydirs)
-source=("http://download.kde.org/stable/${_kdever_}/src/kde-workspace-${pkgver}.tar.xz")
+source=("http://download.kde.org/stable/plasma/${pkgver}/${_pkgbase_}-${pkgver}.tar.xz")
# Cursor size
_cursorsize_=""
@@ -22,7 +22,7 @@ _themelist_="bluecurve brown cherry chrome desert emerald green grey honeycomb h
#_themelist_="${_themelist_} black blue white yellow zion"
build() {
- cd "${srcdir}"/kde-workspace-${pkgver}/cursors/src
+ cd "${srcdir}"/${_pkgbase_}-${pkgver}/cursors/src
cmake .
@@ -32,7 +32,7 @@ build() {
}
package() {
- cd "${srcdir}"/kde-workspace-${pkgver}/cursors/src
+ cd "${srcdir}"/${_pkgbase_}-${pkgver}/cursors/src
# Directories
install -d "${pkgdir}"/usr/share/icons/
@@ -44,4 +44,4 @@ package() {
done
}
-sha1sums=('ec79a5d638a93b1abbb99b22a7bea52d9a2c26eb')
+sha1sums=('86cd76b3eafaf3fd5664f2dadac43b76a54c6e29')