summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorXavion2015-06-09 09:42:44 +1000
committerXavion2015-06-09 09:42:44 +1000
commite5d518766fad2d68bdb3d13dbf58fb9fb0465b91 (patch)
tree477ea1c93f55f5050d22b1972093ee087c388266
downloadaur-e5d518766fad2d68bdb3d13dbf58fb9fb0465b91.tar.gz
Initial AUR v4 importation
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD47
2 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2d413b3eab0b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = oxygen-cursors-extra
+ pkgdesc = KDE's Oxygen mouse cursor theme - the extra flavours
+ pkgver = 4.11.14
+ pkgrel = 1
+ url = http://www.kde.org
+ arch = any
+ license = GPL3
+ makedepends = pkgconfig
+ makedepends = cmake
+ makedepends = automoc4
+ makedepends = inkscape
+ makedepends = libltdl
+ makedepends = xorg-xcursorgen
+ options = !emptydirs
+ source = http://download.kde.org/stable/4.14.3/src/kde-workspace-4.11.14.tar.xz
+ sha1sums = ec79a5d638a93b1abbb99b22a7bea52d9a2c26eb
+
+pkgname = oxygen-cursors-extra
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ca8afee14300
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Xavion <Xavion (dot) 0 (at) Gmail (dot) com>
+
+pkgname=oxygen-cursors-extra
+_kdever_=4.14.3
+pkgver=4.11.14
+pkgrel=1
+pkgdesc="KDE's Oxygen mouse cursor theme - the extra flavours"
+arch=("any")
+url="http://www.kde.org"
+license=("GPL3")
+makedepends=('pkgconfig' 'cmake' 'automoc4' 'inkscape' 'libltdl' 'xorg-xcursorgen')
+#optdepends=("kdebase-workspace: contains the default cursor colours")
+options=(!emptydirs)
+source=("http://download.kde.org/stable/${_kdever_}/src/kde-workspace-${pkgver}.tar.xz")
+
+# Cursor size
+_cursorsize_=""
+#_cursorsize_="-big"
+
+# Theme list
+_themelist_="bluecurve brown cherry chrome desert emerald green grey honeycomb hot_orange lilac midnight_meadow navy norway obsidian obsidian-hc olympus olympus-inv orchid oxygen peach purple red red-argentina sea_blue steel terra terra_green violet viorange whitewater wonton"
+#_themelist_="${_themelist_} black blue white yellow zion"
+
+build() {
+ cd "${srcdir}"/kde-workspace-${pkgver}/cursors/src
+
+ cmake .
+
+ for theme in ${_themelist_}; do
+ make theme-${theme}${_cursorsize_}
+ done
+}
+
+package() {
+ cd "${srcdir}"/kde-workspace-${pkgver}/cursors/src
+
+ # Directories
+ install -d "${pkgdir}"/usr/share/icons/
+
+ # Files
+ for theme in ${_themelist_}; do
+ cp -r --parents "oxy-${theme}${_cursorsize_}/cursors" "${pkgdir}"/usr/share/icons/
+ cp "theme-${theme}/index.theme" "${pkgdir}"/usr/share/icons/oxy-${theme}${_cursorsize_}/
+ done
+}
+
+sha1sums=('ec79a5d638a93b1abbb99b22a7bea52d9a2c26eb')