summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCezary Drożak2022-05-24 09:42:59 +0200
committerCezary Drożak2022-05-24 09:42:59 +0200
commit9be472f5c68ab5173c3fde25e0b9f9d26b3024e1 (patch)
treeb484c3d1773634adb3a7eb79c1571bbc10214501
parentd1caccc16d62c60ac8e7e229bf9a0f95db782a52 (diff)
downloadaur-9be472f5c68ab5173c3fde25e0b9f9d26b3024e1.tar.gz
feat: use pkgver based on the Arch Wiki one
https://wiki.archlinux.org/title/VCS_package_guidelines#The_pkgver()_function
-rw-r--r--PKGBUILD2
1 files changed, 1 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 17b0b62133f5..8ff805e7466f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -22,7 +22,7 @@ _gitname="oxygen-gtk"
pkgver() {
cd "$srcdir/$_gitname"
- echo "$(LANG=C date '+%Y%m%d')_$(git describe --tags --always --abbrev=5 | sed 's/-/_/g')"
+ git describe --long | sed 's/vgtk3-//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {