summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLoui Chang2015-11-30 19:28:24 -0500
committerLoui Chang2015-11-30 19:39:45 -0500
commit252a90547fa3085045c837cc267d3ec8449ca68b (patch)
tree26295ae167d3fcb22445827499ebc8481636d83b
downloadaur-252a90547fa3085045c837cc267d3ec8449ca68b.tar.gz
Initial Commit
Signed-off-by: Loui Chang <louipc.ist@gmail.com>
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD21
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eb32765a7918
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = oysttyer-git
+ pkgdesc = interactive command-line Twitter client
+ pkgver = 134.c6ff39e
+ pkgrel = 1
+ url = https://github.com/oysttyer/oysttyer
+ arch = any
+ depends = perl
+ source = oysttyer-git::git+https://github.com/oysttyer/oysttyer.git
+ sha1sums = SKIP
+
+pkgname = oysttyer-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b0444cb9cab8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+pkgname="oysttyer-git"
+pkgver=134.c6ff39e
+pkgrel=1
+pkgdesc="interactive command-line Twitter client"
+url="https://github.com/oysttyer/oysttyer"
+arch=('any')
+depends=('perl')
+source=("$pkgname::git+https://github.com/oysttyer/oysttyer.git")
+sha1sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${pkgname}"
+ echo "$(git rev-list --count HEAD).$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/${pkgname}"
+ install -Dm755 oysttyer.pl "$pkgdir/usr/bin/oysttyer"
+ install -Dm644 README.markdown "$pkgdir/usr/share/doc/$pkgname/README"
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}