summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPellegrino Prevete2023-06-29 19:55:41 +0200
committerPellegrino Prevete2023-06-29 19:55:41 +0200
commit642fb6ab0d3864f79d2ade63974de1985c25cc18 (patch)
treeeed1e8ad043f2a36aef3600ae5a48ab3d5dd17c5
parente3843d5cdc3d3b1d193ffc8cd527310f94d9da62 (diff)
downloadaur-642fb6ab0d3864f79d2ade63974de1985c25cc18.tar.gz
update pkgver
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
2 files changed, 10 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b909fbb7d7f3..e4340b840c42 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = p11-kit-git
pkgdesc = Loads and enumerates PKCS#11 modules
- pkgver = 0.24.1
+ pkgver = 0.25.0+1+g76be1cf
pkgrel = 1
url = https://p11-glue.freedesktop.org
arch = x86_64
@@ -16,7 +16,7 @@ pkgbase = p11-kit-git
pkgname = p11-kit-git
install = p11-kit.install
- depends = libp11-kit=0.24.1-1
+ depends = libp11-kit=0.25.0+1+g76be1cf-1
depends = coreutils
depends = libp11-kit.so
depends = libsystemd.so
diff --git a/PKGBUILD b/PKGBUILD
index a5b519b63f1c..c1b02d278894 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@ pkgbase="${_pkgbase}-git"
pkgname=(
"${pkgbase}"
"lib${pkgbase}")
-pkgver=0.24.1
+pkgver=0.25.0+1+g76be1cf
pkgrel=1
pkgdesc="Loads and enumerates PKCS#11 modules"
_ns="${_base}-glue"
@@ -27,6 +27,11 @@ source=(
"git+${_repo_url}")
sha256sums=('SKIP')
+pkgver() {
+ cd "${_pkgbase}"
+ git describe --tags | sed 's/-/+/g'
+}
+
prepare() {
cd "${_pkgbase}"
}
@@ -38,7 +43,7 @@ build() {
arch-meson "${_pkgbase}" build \
-D gtk_doc=true \
-D man=true \
- -D trust_paths="${_etc_ns}:${_share_ns}"
+ -D trust_paths="${_etc_tp}:${_share_tp}"
meson compile -C build
}
@@ -89,7 +94,7 @@ package_libp11-kit-git() {
mv lib/* "${pkgdir}"
install -Dt "${pkgdir}/usr/share/licenses/${pkgname}" \
- -m644 "${_pkgbase}-$pkgver/COPYING"
+ -m644 "${_pkgbase}/COPYING"
}
# vim:set sw=2 et: