summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoel Shapiro2019-10-16 17:43:44 -0500
committerJoel Shapiro2019-10-16 17:43:44 -0500
commitba8d879ff5b20946831cebd6cbc63d9d5450b3a3 (patch)
treebdf858cee00808c9684092960121bbc91303d4de
parentcfc1c66687c5ea679b048c521726244f0f1b188e (diff)
downloadaur-ba8d879ff5b20946831cebd6cbc63d9d5450b3a3.tar.gz
all your base belong to me (i took over the package). added dynamic file renaming because that's been driving me nuts.
-rw-r--r--.SRCINFO8
-rw-r--r--.gitignore7
-rw-r--r--[-rwxr-xr-x]LICENSE0
-rw-r--r--[-rwxr-xr-x]PKGBUILD26
4 files changed, 26 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8f232c4500da..480f3b373855 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,12 +11,12 @@ pkgbase = p4
validpgpkeys = 7123CB760FF18869
validpgpkeys = E58131C0AEA7B082C6DC4C937123CB760FF18869
sha256sums = c4ed3aef62b1bbf2d16ce4cceb65dc49ab9635b38e2fed0a595fe259283a9f32
- source_i686 = http://www.perforce.com/downloads/perforce/r19.1/bin.linux26x86/p4
- source_i686 = http://www.perforce.com/downloads/perforce/r19.1/bin.linux26x86/p4.asc
+ source_i686 = 2019.1.1845410-p4::http://www.perforce.com/downloads/perforce/r19.1/bin.linux26x86/p4
+ source_i686 = 2019.1.1845410-p4.asc::http://www.perforce.com/downloads/perforce/r19.1/bin.linux26x86/p4.asc
sha256sums_i686 = SKIP
sha256sums_i686 = SKIP
- source_x86_64 = http://www.perforce.com/downloads/perforce/r19.1/bin.linux26x86_64/p4
- source_x86_64 = http://www.perforce.com/downloads/perforce/r19.1/bin.linux26x86_64/p4.asc
+ source_x86_64 = 2019.1.1845410-p4::http://www.perforce.com/downloads/perforce/r19.1/bin.linux26x86_64/p4
+ source_x86_64 = 2019.1.1845410-p4.asc::http://www.perforce.com/downloads/perforce/r19.1/bin.linux26x86_64/p4.asc
sha256sums_x86_64 = SKIP
sha256sums_x86_64 = SKIP
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..252ddef12c55
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+*p4
+*p4.asc
+
+src/
+pkg
+
+p4-*.tar.*
diff --git a/LICENSE b/LICENSE
index 35153b94dc6b..35153b94dc6b 100755..100644
--- a/LICENSE
+++ b/LICENSE
diff --git a/PKGBUILD b/PKGBUILD
index 4ebf52e7b6d7..055ffb5f08f7 100755..100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,25 @@
-# Maintainer: Aaron Miller <aaronm@cldtk.com>
-# Contributor: Adam Brenner <adam@aeb.io>
-# Contributor: Marq Schneider <queueRAM@gmail.com>
-# Contributor: Jonathan Arnold <jarnold@buddydog.org>
+# Maintainer: Joel Shapiro <jshapiro at nvidia dot com>
pkgname=p4
pkgver=2019.1.1845410
pkgrel=2
+
pkgdesc="Perforce command line client"
depends=('glibc')
arch=('i686' 'x86_64')
url="http://www.perforce.com"
license=('custom:p4')
+
+_url="${url}/downloads/perforce"
+_filename="${pkgver}-${pkgname}"
+
source=(LICENSE)
-source_x86_64=("http://www.perforce.com/downloads/perforce/r${pkgver:2:4}/bin.linux26x86_64/${pkgname}"{,.asc})
-source_i686=("http://www.perforce.com/downloads/perforce/r${pkgver:2:4}/bin.linux26x86/${pkgname}"{,.asc})
+source_x86_64=("${_filename}"::"${_url}/r${pkgver:2:4}/bin.linux26x86_64/${pkgname}"
+ "${_filename}.asc"::"${_url}/r${pkgver:2:4}/bin.linux26x86_64/${pkgname}.asc")
+source_i686=("${_filename}"::"${_url}/r${pkgver:2:4}/bin.linux26x86/${pkgname}"
+ "${_filename}.asc"::"${_url}/r${pkgver:2:4}/bin.linux26x86/${pkgname}.asc")
+
+
sha256sums=('c4ed3aef62b1bbf2d16ce4cceb65dc49ab9635b38e2fed0a595fe259283a9f32')
sha256sums_i686=('SKIP' 'SKIP')
sha256sums_x86_64=('SKIP' 'SKIP')
@@ -22,11 +28,9 @@ sha256sums_x86_64=('SKIP' 'SKIP')
validpgpkeys=('7123CB760FF18869'
'E58131C0AEA7B082C6DC4C937123CB760FF18869')
-build() {
- return 0
-}
-
package() {
install -D -m 644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/license.txt"
- install -D -m 755 "${srcdir}/${pkgname}" "${pkgdir}/usr/bin/${pkgname}"
+ install -D -m 755 "${_filename}" "${pkgdir}/usr/bin/${pkgname}"
}
+
+# vim:set ts=2 sw=2 et: