summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichal S2022-09-13 14:10:04 +0100
committerMichal S2022-09-13 14:10:04 +0100
commita5e9bfc2a0d2674f563905a09375da3375a12045 (patch)
treed789eb16b938b1a17ae08a65642ba882b648c7b2
downloadaur-a5e9bfc2a0d2674f563905a09375da3375a12045.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD37
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d300628ceb58
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = pa-rs-e
+ pkgdesc = A rusty password manager that'll blow your arse off
+ pkgver = 1.0.1
+ pkgrel = 1
+ url = https://gitlab.com/mchal_/parse
+ arch = x86_64
+ arch = aarch64
+ license = MIT
+ makedepends = cargo-nightly
+ makedepends = git
+ source = git+https://gitlab.com/mchal_/parse#tag=v1.0.1
+ sha256sums = SKIP
+
+pkgname = pa-rs-e
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ee2a6a9de6e9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Maintainer: echo -n 'TWljaGFsIFMuIDxtaWNoYWxAdGFyLmJsYWNrPg==' | base64 -d
+# Contributor: echo -n 'TWljaGFsIFMuIDxtaWNoYWxAdGFyLmJsYWNrPg==' | base64 -d
+
+pkgname=pa-rs-e
+_pkgname=parse
+pkgver=1.0.1
+pkgrel=1
+pkgdesc="A rusty password manager that'll blow your arse off"
+arch=('x86_64' 'aarch64')
+url="https://gitlab.com/mchal_/$_pkgname"
+license=('MIT')
+source=("git+$url#tag=v$pkgver")
+sha256sums=('SKIP')
+makedepends=('cargo-nightly' 'git')
+
+prepare() {
+ cd "$srcdir/$_pkgname"
+ export RUSTUP_TOOLCHAIN=nightly
+ export CARGO_TARGET_DIR=target
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
+build() {
+ cd "$srcdir/$_pkgname"
+ export RUSTUP_TOOLCHAIN=nightly
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release
+}
+
+package() {
+ cd "$srcdir/$_pkgname"
+ find target/release \
+ -maxdepth 1 \
+ -executable \
+ -type f \
+ -exec install -Dm0755 -t "$pkgdir/usr/bin/" {} +
+}