aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRicardo Band2017-01-15 01:35:41 +0100
committerRicardo Band2017-01-15 01:35:41 +0100
commitf3c088fe3ff4afb4fa6cd9718de3fafa6439522d (patch)
treeecf8219a6750d31ed32b829ee29ffa0239b9a1f2
parentd839e1716e7785f91e96097852869fc161545bf9 (diff)
downloadaur-f3c088fe3ff4afb4fa6cd9718de3fafa6439522d.tar.gz
fixed a bug with python syntax
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD4
-rwxr-xr-xpac4
3 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 2604d6cbdbf6..94474d3ffd44 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Sun Jan 15 00:27:05 UTC 2017
+# Sun Jan 15 00:35:22 UTC 2017
pkgbase = pac
pkgdesc = Small wrapper around pacaur to mimic yaourts search feature
- pkgver = 1.0.1
+ pkgver = 1.0.2
pkgrel = 1
epoch = 1
url = https://github.com/XenGi/pac
@@ -11,7 +11,7 @@ pkgbase = pac
depends = python>=3.6.0
noextract = pac
source = pac
- sha256sums = 287f1bbd32f17cdb7778454000593005a473a6a37dabf570b6c9cbfed94c8eef
+ sha256sums = 0cf1061fff3d312748c3c1c6dda475b2f3e48c24e9979b192570fe9ec2362d28
pkgname = pac
diff --git a/PKGBUILD b/PKGBUILD
index ed1550e7615c..ad8ecb8d56b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
# Maintainer: Ricardo Band <email@ricardo.band>
pkgname=pac
-pkgver=1.0.1
+pkgver=1.0.2
pkgrel=1
epoch=1
pkgdesc="Small wrapper around pacaur to mimic yaourts search feature"
@@ -10,7 +10,7 @@ license=('MIT')
depends=('python>=3.6.0')
source=('pac')
noextract=('pac')
-sha256sums=('287f1bbd32f17cdb7778454000593005a473a6a37dabf570b6c9cbfed94c8eef')
+sha256sums=('0cf1061fff3d312748c3c1c6dda475b2f3e48c24e9979b192570fe9ec2362d28')
package() {
install -dm 755 "$pkgdir"/usr/bin/
diff --git a/pac b/pac
index d3fc3eb3a73e..7149d6f58976 100755
--- a/pac
+++ b/pac
@@ -12,7 +12,7 @@ __author__ = 'Ricardo Band'
__copyright__ = 'Copyright 2017, Ricardo band'
__credits__ = ['Ricardo Band']
__license__ = 'MIT'
-__version__ = '1.0.1'
+__version__ = '1.0.2'
__maintainer__ = 'Ricardo Band'
__email__ = 'email@ricardo.band'
@@ -131,7 +131,7 @@ def parse_num(numbers: str):
for n in numbers.split(' '):
if '-' in n:
start, end = n.split('-')
- if !(start.isdecimal() and end.isdecimal()):
+ if not (start.isdecimal() and end.isdecimal()):
sys.exit(f'{start} or {end} is not a number')
# TODO: I'm pretty sure this can be optimized
for i in list(range(int(start) - 1, int(end))):