summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhaled Eldoheiri2019-02-19 21:41:00 +0100
committerKhaled Eldoheiri2019-02-19 21:41:00 +0100
commit9d0694fa871e8d32d3b8027523eb4aa2a34ecb5e (patch)
tree5fff5a79dbd68a10cbd2332d4c807d0c13010855
parent43635e40e64dbffc8a07304f49e4b986167720f5 (diff)
downloadaur-9d0694fa871e8d32d3b8027523eb4aa2a34ecb5e.tar.gz
Add tld dependency
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 12 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index facd4f97f796..0235e4ca2e38 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pac4cli-git
pkgdesc = Proxy-auto-discovery for command line applications
- pkgver = 0.2.38.g38c80d2
+ pkgver = v0.2.40.gc7a0623
pkgrel = 3
url = https://github.com/tkluck/pac4cli
install = pac4cli.install
@@ -29,10 +29,12 @@ pkgbase = pac4cli-git
source = https://github.com/pacparser/pacparser/archive/1.3.7.tar.gz
source = https://pypi.io/packages/source/t/txdbus/txdbus-1.1.0.tar.gz
source = https://files.pythonhosted.org/packages/source/s/service_identity/service_identity-17.0.0.tar.gz
+ source = https://github.com/barseghyanartur/tld/archive/0.9.2.tar.gz
md5sums = SKIP
md5sums = 6ea7f2bf2e93eb7e8e58f75b77885c22
md5sums = f17c9204c7f56365c297ba68e6840900
md5sums = f509cb41ca2f8420bd8496291136d6cc
+ md5sums = SKIP
pkgname = pac4cli-git
diff --git a/PKGBUILD b/PKGBUILD
index 973242b3c1af..aa570f3692c1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,9 +3,10 @@ _pacparser_pkgver=1.3.7
_txdbus_pkgver=1.1.0
_systemd_pkgver=0.9.5
_service_identity_pkgver=17.0.0
+_tld_pkgver=0.9.2
pkgname=pac4cli-git
-pkgver=0.2.38.g38c80d2
+pkgver=v0.2.40.gc7a0623
pkgrel=3
pkgdesc="Proxy-auto-discovery for command line applications"
arch=('i686' 'x86_64')
@@ -21,8 +22,9 @@ install=${pkgname%-git}.install
source=("${pkgname%-git}::git+https://github.com/tkluck/pac4cli.git"
"https://github.com/pacparser/pacparser/archive/${_pacparser_pkgver}.tar.gz"
"https://pypi.io/packages/source/t/txdbus/txdbus-${_txdbus_pkgver}.tar.gz"
- "https://files.pythonhosted.org/packages/source/s/service_identity/service_identity-${_service_identity_pkgver}.tar.gz")
-md5sums=('SKIP' '6ea7f2bf2e93eb7e8e58f75b77885c22' 'f17c9204c7f56365c297ba68e6840900' 'f509cb41ca2f8420bd8496291136d6cc')
+ "https://files.pythonhosted.org/packages/source/s/service_identity/service_identity-${_service_identity_pkgver}.tar.gz"
+ "https://github.com/barseghyanartur/tld/archive/${_tld_pkgver}.tar.gz")
+md5sums=('SKIP' '6ea7f2bf2e93eb7e8e58f75b77885c22' 'f17c9204c7f56365c297ba68e6840900' 'f509cb41ca2f8420bd8496291136d6cc' 'SKIP')
pkgver() {
cd "$srcdir/${pkgname%-git}"
@@ -52,6 +54,10 @@ package() {
cd "${srcdir}/service_identity-${_service_identity_pkgver}"
python setup.py install --root="${pkgdir}/" --prefix=/usr --optimize=1 --skip-build
+ #tld
+ cd "${srcdir}/tld-${_tld_pkgver}"
+ python setup.py install --root="${pkgdir}/" --prefix=/usr --optimize=1
+
#package pac4cli
cd "${srcdir}/${pkgname%-git}"
make DESTDIR="${pkgdir}" prefix=/usr install