summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2017-05-19 08:17:45 -0600
committerBrian Bidulock2017-05-19 08:17:45 -0600
commita3673c1518cec00d2dea61f8499cbe4ad1577869 (patch)
tree723a1602e84b00f5e616acac42e29c26fe402db6
parent8175bba38b1aabcde5640f42e9e89437edc367ee (diff)
downloadaur-a3673c1518cec00d2dea61f8499cbe4ad1577869.tar.gz
establish sysusers and tmpfiles
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD75
-rw-r--r--crm_report.in24
-rw-r--r--pacemaker.sysusers3
-rw-r--r--pacemaker.tmpfiles5
5 files changed, 91 insertions, 26 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 580c9662c002..b725107bbbea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pacemaker-git
pkgdesc = advanced, scalable high-availability cluster resource manager
- pkgver = 1.1.16.r34.gefb87a0
+ pkgver = 1.1.17.rc1.r20.g49eb595ab
pkgrel = 1
url = https://github.com/ClusterLabs/pacemaker/
arch = i686
@@ -9,7 +9,6 @@ pkgbase = pacemaker-git
makedepends = git
makedepends = libxml2
makedepends = inkscape
- makedepends = libqb-git
depends = gnutls
depends = glib2
depends = pam
@@ -18,10 +17,17 @@ pkgbase = pacemaker-git
depends = libxslt
depends = corosync-git
depends = libesmtp
+ depends = libqb-git
provides = pacemaker
conflicts = pacemaker
source = pacemaker-git::git+https://github.com/ClusterLabs/pacemaker.git
+ source = pacemaker.sysusers
+ source = pacemaker.tmpfiles
+ source = crm_report.in
md5sums = SKIP
+ md5sums = f21b93a2bb62d54b69b9bd4427201707
+ md5sums = 3339ef9d5124e722800b0aeda16f464c
+ md5sums = 07f26ba3fff0749cc5bc5b4da154611d
pkgname = pacemaker-git
diff --git a/PKGBUILD b/PKGBUILD
index ded8c9e933ba..7be838d1ac20 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,18 +5,24 @@
pkgname=pacemaker-git
_pkgname=pacemaker
-pkgver=1.1.16.r34.gefb87a0
+pkgver=1.1.17.rc1.r20.g49eb595ab
pkgrel=1
pkgdesc="advanced, scalable high-availability cluster resource manager"
arch=('i686' 'x86_64')
url="https://github.com/ClusterLabs/${_pkgname}/"
license=('GPL2')
-makedepends=('git' 'libxml2' 'inkscape' 'libqb-git')
-depends=('gnutls' 'glib2' 'pam' 'libtool' 'python' 'libxslt' 'corosync-git' 'libesmtp')
+makedepends=('git' 'libxml2' 'inkscape')
+depends=('gnutls' 'glib2' 'pam' 'libtool' 'python' 'libxslt' 'corosync-git' 'libesmtp' 'libqb-git')
provides=(${_pkgname})
conflicts=(${_pkgname})
-source=("$pkgname::git+https://github.com/ClusterLabs/${_pkgname}.git")
-md5sums=('SKIP')
+source=("$pkgname::git+https://github.com/ClusterLabs/${_pkgname}.git"
+ 'pacemaker.sysusers'
+ 'pacemaker.tmpfiles'
+ 'crm_report.in')
+md5sums=('SKIP'
+ 'f21b93a2bb62d54b69b9bd4427201707'
+ '3339ef9d5124e722800b0aeda16f464c'
+ '07f26ba3fff0749cc5bc5b4da154611d')
pkgver() {
cd $pkgname
@@ -25,35 +31,56 @@ pkgver() {
prepare() {
cd $pkgname
- ./autogen.sh
+ autoreconf -fiv
+# ./autogen.sh
}
build() {
cd $pkgname
- CPPFLAGS=-D_FORTIFY_SOURCE=0 \
- ./configure --sbindir=/usr/bin \
- --sysconfdir=/etc \
- --libdir=/usr/lib \
- --libexecdir=/usr/lib \
- --localstatedir=/var \
- --enable-systemd \
- --disable-upstart \
- --with-ais \
- --with-corosync \
- --with-cman \
- --with-cs-quorum \
- --with-nagios \
- --with-snmp \
- --with-esmtp \
- --with-acl
-# --with-nagios-plugin-dir=DIR
-# --with-nagios-metadata-dir=DIR
+ ./configure \
+ --sbindir=/usr/bin \
+ --sysconfdir=/etc \
+ --libdir=/usr/lib \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --disable-static \
+ --disable-fatal-warnings \
+ --with-version=$pkgver-$pkgrel \
+ --enable-systemd \
+ --disable-upstart \
+ --with-ais \
+ --with-corosync \
+ --without-heartbeat \
+ --without-cman \
+ --with-cs-quorum \
+ --with-nagios \
+ --with-snmp \
+ --with-esmtp \
+ --with-acl \
+ --with-cibsecrets \
+ --without-profiling \
+ --without-coverage \
+ --with-configdir=/etc/pacemaker
+# --with-nagios-plugin-dir=DIR
+# --with-nagios-metadata-dir=DIR
make V=0
}
package() {
cd $pkgname
make DESTDIR="${pkgdir}" install
+ cd "$srcdir"
+ install -dm755 "$pkgdir"/usr/lib/{tmpfiles.d,sysusers.d}
+ install -Dm644 $_pkgname.tmpfiles "$pkgdir/usr/lib/tmpfiles.d/$_pkgname.conf"
+ install -Dm644 $_pkgname.sysusers "$pkgdir/usr/lib/sysusers.d/$_pkgname.conf"
+ rm -fr "$pkgdir/var"
+ chmod a+x "$pkgdir/usr/share/pacemaker/tests/cts/CTSlab.py"
+ find "$pkgdir" -name '*.xml' -type f -print0 | xargs -0 chmod a-x
+ find "$pkgdir" -type f -name '*.la' -delete -print
+ rm -fr "$pkgdir/etc/init.d"
+ rm -f "$pkgdir/usr/bin/fence_pcmk"
+ mv "$pkgdir/usr/bin/crm_report" "$pkgdir/usr/bin/crm_report.pacemaker"
+ install -Dm755 crm_report.in "$pkgdir/usr/bin/crm_report"
}
# vim: set sw=2 et:
diff --git a/crm_report.in b/crm_report.in
new file mode 100644
index 000000000000..c5dff3bdd4ae
--- /dev/null
+++ b/crm_report.in
@@ -0,0 +1,24 @@
+#!/bin/sh
+#
+# Copyright (C) 2007 Dejan Muhamedagic <dmuhamedagic@suse.com>
+# Copyright (C) 2015 Kristoffer Gronlund <kgronlund@suse.com>
+# Copyright (C) 2015 Gao,Yan <ygao@suse.com>
+#
+# Replaced with crm report
+PARENT_COMMAND="$(ps -o comm= $PPID)"
+PROG="$(basename "$0")"
+
+die() {
+ echo "$PROG: $*"
+ exit 1
+}
+[ "$(basename "$PARENT_COMMAND")" = "crm" ] && die "called itself in a loop, aborting"
+if which crm > /dev/null 2>&1; then
+ crm report "$@"
+elif [ -x /usr/sbin/crm ]; then
+ /usr/sbin/crm report "$@"
+else
+ #die "crm_report has been deprecated: Please install crmsh, which replaces it"
+ /usr/sbin/crm_report.pacemaker "$@"
+fi
+
diff --git a/pacemaker.sysusers b/pacemaker.sysusers
new file mode 100644
index 000000000000..7ef9892f4309
--- /dev/null
+++ b/pacemaker.sysusers
@@ -0,0 +1,3 @@
+u hacluster - "Cluster User"
+g haclient - -
+m hacluster haclient
diff --git a/pacemaker.tmpfiles b/pacemaker.tmpfiles
new file mode 100644
index 000000000000..d3c062831b26
--- /dev/null
+++ b/pacemaker.tmpfiles
@@ -0,0 +1,5 @@
+d /var/lib/pacemaker 0750 hacluster haclient
+d /var/lib/pacemaker/blackbox 0750 hacluster haclient
+d /var/lib/pacemaker/cib 0750 hacluster haclient
+d /var/lib/pacemaker/cores 0750 hacluster haclient
+d /var/lib/pacemaker/pengine 0750 hacluster haclient