summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2016-12-05 09:46:48 -0700
committerBrian Bidulock2016-12-05 09:46:48 -0700
commite28d556debe4a8ae922109a09ba8e20e54405c9c (patch)
tree5ecb3e4ec0609c5786c796c711f2d75ea9ca6fa1
downloadaur-e28d556debe4a8ae922109a09ba8e20e54405c9c.tar.gz
initial version
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD59
2 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a91dbca67b14
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = pacemaker-git
+ pkgdesc = pacemaker stable package, contains the latest stable version
+ pkgver = 1.1.16.r26.g4ed1507
+ pkgrel = 2
+ url = https://github.com/ClusterLabs/pacemaker/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = libxml2
+ makedepends = inkscape
+ makedepends = libqb-git
+ depends = gnutls
+ depends = glib2
+ depends = pam
+ depends = libtool
+ depends = python
+ depends = libxslt
+ depends = corosync-git
+ depends = libesmtp
+ provides = pacemaker
+ conflicts = pacemaker
+ source = pacemaker-git::git+https://github.com/ClusterLabs/pacemaker.git
+ md5sums = SKIP
+
+pkgname = pacemaker-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..12292cd63539
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer: Brian Bidulock <bidulock@openss7.org>
+# Contributor: gls <ghostlovescorebg at gmail dot com>
+# Contributor: Thermi <noel at familie-kuntze dot de>
+# Contributor: Tim Meusel <tim@bastelfreak.de>
+
+pkgname=pacemaker-git
+pkgver=1.1.16.r26.g4ed1507
+pkgrel=2
+pkgdesc="pacemaker stable package, contains the latest stable version"
+arch=('i686' 'x86_64')
+url="https://github.com/ClusterLabs/pacemaker/"
+license=('GPL2')
+makedepends=('libxml2' 'inkscape' 'libqb-git')
+depends=('gnutls' 'glib2' 'pam' 'libtool' 'python' 'libxslt' 'corosync-git' 'libesmtp')
+provides=('pacemaker')
+conflicts=('pacemaker')
+source=("$pkgname::git+https://github.com/ClusterLabs/pacemaker.git")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ git describe --long --tags | sed -E 's/^[^0-9]*//;s/([^-]*-g)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd $pkgname
+ mkdir -p m4
+ autoreconf -fiv
+}
+
+build() {
+ cd $pkgname
+ CPPFLAGS=-D_FORTIFY_SOURCE=0
+ ./configure --sbindir=/usr/bin \
+ --sysconfdir=/etc \
+ --libdir=/usr/lib \
+ --libexecdir=/usr/lib \
+ --localstatedir=/var \
+ --enable-systemd \
+ --disable-upstart \
+ --with-ais \
+ --with-corosync \
+ --with-cman \
+ --with-cs-quorum \
+ --with-nagios \
+ --with-snmp \
+ --with-esmtp \
+ --with-acl
+# --with-nagios-plugin-dir=DIR
+# --with-nagios-metadata-dir=DIR
+ make V=0
+}
+
+package() {
+ cd $pkgname
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim: set sw=2 et: