summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2021-12-13 22:44:55 -0700
committerBrian Bidulock2021-12-13 22:44:55 -0700
commitfa6a6d14ac353e961fbe472cdd050b8a639a6ebd (patch)
treedb3863939b4eb0f97d117b52dc3572d51bdc8a79
parent4a0122cba45c79da2d26d3438086f6c02ee37fb8 (diff)
downloadaur-fa6a6d14ac353e961fbe472cdd050b8a639a6ebd.tar.gz
uppkg
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD13
2 files changed, 11 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a5a72a2f9a55..550f5bee5f2e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pacemaker-git
pkgdesc = advanced, scalable high-availability cluster resource manager
- pkgver = 2.0.5.r0.gba59be712
+ pkgver = 2.1.2.r0.gada5c3b36
pkgrel = 1
url = https://github.com/ClusterLabs/pacemaker/
arch = i686
@@ -27,12 +27,11 @@ pkgbase = pacemaker-git
optdepends = pdsh: for use with some tools
optdepends = crmsh-git: for use with crm_report
optdepends = booth-git: for geo-clustering
- provides = pacemaker=2.0.5-1
+ provides = pacemaker=2.1.2-1
conflicts = pacemaker
- source = pacemaker-git::git+https://github.com/ClusterLabs/pacemaker.git#branch=2.0
+ source = pacemaker-git::git+https://github.com/ClusterLabs/pacemaker.git#branch=2.1
source = crm_report.in
md5sums = SKIP
md5sums = 07f26ba3fff0749cc5bc5b4da154611d
pkgname = pacemaker-git
-
diff --git a/PKGBUILD b/PKGBUILD
index dc28dc4d4825..b67a06d71453 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
pkgname=pacemaker-git
_pkgname=pacemaker
-pkgver=2.0.5.r0.gba59be712
+pkgver=2.1.2.r0.gada5c3b36
pkgrel=1
pkgdesc="advanced, scalable high-availability cluster resource manager"
arch=('i686' 'x86_64')
@@ -21,7 +21,7 @@ optdepends=('pssh: for use with some tools'
'booth-git: for geo-clustering')
provides=("${_pkgname}=${pkgver%%.r*}-${pkgrel}")
conflicts=("${_pkgname}")
-source=("$pkgname::git+https://github.com/ClusterLabs/${_pkgname}.git#branch=2.0"
+source=("$pkgname::git+https://github.com/ClusterLabs/${_pkgname}.git#branch=2.1"
'crm_report.in')
md5sums=('SKIP'
'07f26ba3fff0749cc5bc5b4da154611d')
@@ -33,8 +33,7 @@ pkgver() {
prepare() {
cd $pkgname
- autoreconf -fiv
-# ./autogen.sh
+ ./autogen.sh
}
build() {
@@ -57,7 +56,8 @@ build() {
--with-cibsecrets \
--without-profiling \
--without-coverage \
- --with-configdir=/etc/pacemaker
+ --with-configdir=/etc/pacemaker \
+ --with-initdir=/etc/init.d
# --with-nagios-plugin-dir=DIR
# --with-nagios-metadata-dir=DIR
# Fight unused direct deps
@@ -68,9 +68,12 @@ build() {
package() {
cd $pkgname
make DESTDIR="${pkgdir}" install
+ chown root.root "${pkgdir}"/etc/pacemaker
+ chmod 0755 "${pkgdir}"/etc/pacemaker
cd "$srcdir"
install -Dm644 /dev/null "$pkgdir/usr/lib/tmpfiles.d/$_pkgname.conf"
cat>"$pkgdir/usr/lib/tmpfiles.d/$_pkgname.conf"<<-EOF
+ d /etc/pacemaker 0750 root haclient
d /var/log/pacemaker 0755 hacluster haclient
d /var/lib/pacemaker 0770 hacluster haclient
d /var/lib/pacemaker/blackbox 0770 hacluster haclient