summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMd Jahidul Hamid2017-08-22 03:08:49 +0600
committerMd Jahidul Hamid2017-08-22 03:08:49 +0600
commitaf9a3d53df9fb06f7252e43d602cb1c87fab4f12 (patch)
treefd05a45cccf459a21f7f45451278288925a325b1
parentd068896d4586b60bdf083ab83930f4894e76cdf1 (diff)
downloadaur-af9a3d53df9fb06f7252e43d602cb1c87fab4f12.tar.gz
initial release
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD63
-rw-r--r--pacget.install14
3 files changed, 46 insertions, 52 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6c910957a588..5845ed009b2f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,13 @@
pkgbase = pacget
- pkgdesc = A script using the mirrors from /etc/pacman.d/mirrorlist for speeding up pacman
- pkgver = 0.1.0
- pkgrel = 0
- url = https://wiki.archlinux.org/index.php/Improve_pacman_performance
- install = pacget.install
+ pkgdesc = A wrapper around pacaur to mimic yaourt's search feature
+ pkgver = 1.0.3
+ pkgrel = 1
arch = any
- license = FREE
- depends = aria2
- depends = pacman
- options = !emptydirs
- source = improve_pacman_performance.wiki::https://wiki.archlinux.org/index.php/Improve_pacman_performance?action=raw
- source = pacget.install
- md5sums = eff13d58f819ccc5ff1a428c6db7062a
- md5sums = 3eafc809dc489595c5afa03a12d1ef09
+ license = GPL
+ depends = pacaur
+ optdepends = pkgfile: support for package search by file name
+ source = https://github.com/neurobin/pacget/archive/1.0.3.tar.gz
+ md5sums = SKIP
pkgname = pacget
diff --git a/PKGBUILD b/PKGBUILD
index 5215ca83ef7d..ecaeb1254681 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,33 +1,46 @@
-# Maintainer: Artem Bezsmertnyi <artem.bezsmertny@gmail.com>
+# Maintainer: Md. Jahidul Hamid <jahidulhamid@yahoo.com>
pkgname=pacget
-pkgver=0.1.0
-pkgrel=0
-pkgdesc="A script using the mirrors from /etc/pacman.d/mirrorlist for speeding up pacman"
-arch=(any)
-url="https://wiki.archlinux.org/index.php/Improve_pacman_performance"
-license=('FREE')
-depends=('aria2' 'pacman')
-options=(!emptydirs)
-install="pacget.install"
-source=("improve_pacman_performance.wiki::https://wiki.archlinux.org/index.php/Improve_pacman_performance?action=raw"
- "pacget.install")
-md5sums=('eff13d58f819ccc5ff1a428c6db7062a'
- '3eafc809dc489595c5afa03a12d1ef09')
+pkgver=1.0.3
+pkgrel=1
+epoch=
+pkgdesc="A wrapper around pacaur to mimic yaourt's search feature"
+arch=('any')
+url=""
+license=('GPL')
+groups=()
+depends=('pacaur')
+makedepends=()
+checkdepends=()
+optdepends=('pkgfile: support for package search by file name')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("https://github.com/neurobin/$pkgname/archive/$pkgver.tar.gz")
+noextract=()
+md5sums=('SKIP')
+validpgpkeys=()
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ #patch -p1 -i "$srcdir/$pkgname-$pkgver.patch"
+}
build() {
- cd "${srcdir}"
+ cd "$pkgname-$pkgver"
+ #./configure --prefix=/usr
+ #make
+}
- # Get all lines between {{hc|/usr/bin/pacget|<nowiki> and the following </nowiki>}}
- grep -ozP '(?s)\{\{hc\|\/usr\/bin\/pacget\|<nowiki>\n\K.*?(?=\n<\/nowiki>)' improve_pacman_performance.wiki > "${srcdir}/pacget"
- # Get all lines between {{hc|/etc/pacget.conf|<nowiki> and the following </nowiki>}}A
- grep -ozP '(?s)\{\{hc\|\/etc\/pacget.conf\|<nowiki>\n\K.*?(?=\n<\/nowiki>)' improve_pacman_performance.wiki > "${srcdir}/pacget.conf"
+check() {
+ cd "$pkgname-$pkgver"
+ #make -k check
}
package() {
- mkdir -p "${pkgdir}/usr/bin"
- mkdir -p "${pkgdir}/etc"
-
- install -D -m 755 "${srcdir}/pacget" "${pkgdir}/usr/bin/pacget"
- install -D -m 644 "${srcdir}/pacget.conf" "${pkgdir}/etc/pacget.conf"
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" install
}
-# vim:set ts=2 sw=2 et:
diff --git a/pacget.install b/pacget.install
deleted file mode 100644
index 15989c3757a0..000000000000
--- a/pacget.install
+++ /dev/null
@@ -1,14 +0,0 @@
-xfercommand() {
-cat <<EOM
---> To use pacget, modify your /etc/pacman.conf with
---> XferCommand = exec /usr/bin/pacget %u %o
-EOM
-}
-
-post_install() {
- xfercommand
-}
-
-post_upgrade() {
- xfercommand
-}