summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraksr2016-02-06 13:17:26 +0100
committeraksr2016-02-06 13:17:26 +0100
commitccf27fb662a4e95e051e60b2108044fbedf18c67 (patch)
tree50a7a05da573cb8b7f0545ec3018fd0f44c2fc76
downloadaur-ccf27fb662a4e95e051e60b2108044fbedf18c67.tar.gz
Start.
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD44
-rw-r--r--pachi-git.install23
3 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..957c5987df0c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sat Feb 6 12:17:25 UTC 2016
+pkgbase = pachi-git
+ pkgdesc = A fairly strong Go/Baduk/Weiqi playing program.
+ pkgver = 11.00.retsugen.r37.g4eb631e
+ pkgrel = 1
+ url = http://pachi.or.cz/
+ install = pachi-git.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ provides = pachi
+ conflicts = pachi
+ conflicts = pachi-go
+ source = pachi-git::git+https://github.com/pasky/pachi.git
+ md5sums = SKIP
+
+pkgname = pachi-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..74130ee29cd2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: aksr <aksr at t-com dot me>
+pkgname=pachi-git
+pkgver=11.00.retsugen.r37.g4eb631e
+pkgrel=1
+epoch=
+pkgdesc="A fairly strong Go/Baduk/Weiqi playing program."
+arch=('i686' 'x86_64')
+url="https://github.com/pasky/pachi"
+url="http://pachi.or.cz/"
+license=('GPL')
+groups=()
+depends=('')
+makedepends=('git')
+optdepends=()
+checkdepends=()
+provides=('pachi')
+conflicts=('pachi' 'pachi-go')
+replaces=()
+backup=()
+options=()
+changelog=
+install=${pkgname}.install
+source=("$pkgname::git+https://github.com/pasky/pachi.git")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ git describe --tags | sed -E 's/([^-]*-g)/r\1/;s/-/./g;s/^pachi\.//'
+}
+
+build() {
+ cd "$srcdir/$pkgname"
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname"
+ mkdir -p $pkgdir/usr/bin
+ make DESTDIR="$pkgdir/" PREFIX=/usr install
+ install -Dm644 README $pkgdir/usr/share/doc/${pkgname%-*}/README
+ install -Dm644 COPYING $pkgdir/usr/share/licenses/${pkgname%-*}/COPYING
+}
+
diff --git a/pachi-git.install b/pachi-git.install
new file mode 100644
index 000000000000..797be564b1b8
--- /dev/null
+++ b/pachi-git.install
@@ -0,0 +1,23 @@
+post_install() {
+ cat <<END
+
+ The resulting binary program `pachi` is a GTP client; connect to it
+ with your favorite Go program interface (e.g. gogui or qgo), or use
+ kgsGtp to connect it to KGS.
+
+ Pachi can use an opening book in a Fuego-compatible format - you can
+ obtain one at http://gnugo.baduk.org/fuegoob.htm and use it in Pachi
+ with the -f parameter:
+
+ ./pachi -f book.dat ...
+
+ Pachi can also use a pattern database to improve its playing performance.
+ You can get it at http://pachi.or.cz/pat/ - you will also find further
+ instructions there.
+END
+}
+
+post_upgrade() {
+ post_install
+}
+