summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAleix Pol2016-11-22 19:41:56 +0100
committerAleix Pol2016-11-22 19:41:56 +0100
commitf87f7d5dea247124a90e7a8a955bf144ba118bd4 (patch)
tree08fcbdd73470967d15e6c1a43f00368b2a22c6b5
downloadaur-f87f7d5dea247124a90e7a8a955bf144ba118bd4.tar.gz
Initial
Using git, forked from the actual packagekit package
-rw-r--r--.SRCINFO31
-rw-r--r--PKGBUILD49
2 files changed, 80 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4353be6cc153
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,31 @@
+pkgbase = packagekit-git
+ pkgdesc = A system designed to make installation and updates of packages easier
+ pkgver = r4327.f537e89
+ pkgrel = 1
+ url = http://www.packagekit.org/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = gobject-introspection
+ makedepends = gtk-doc
+ makedepends = intltool
+ makedepends = networkmanager
+ makedepends = bash-completion
+ makedepends = vala
+ makedepends = autoconf-archive
+ depends = dbus-glib
+ depends = pacman>=5.0.0
+ depends = polkit
+ depends = shared-mime-info
+ depends = sqlite
+ optdepends = networkmanager: detect connection status
+ optdepends = bash-completion: command completion in bash
+ replaces = packagekit
+ backup = var/lib/PackageKit/transactions.db
+ backup = etc/PackageKit/alpm.d/pacman.conf
+ backup = etc/PackageKit/alpm.d/repos.list
+ source = git+https://github.com/hughsie/PackageKit.git
+ md5sums = SKIP
+
+pkgname = packagekit-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..883193c87b15
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,49 @@
+pkgname='packagekit-git'
+pkgver=r4327.f537e89
+pkgrel=1
+pkgdesc='A system designed to make installation and updates of packages easier'
+arch=('i686' 'x86_64')
+url='http://www.packagekit.org/'
+license=('GPL')
+depends=('dbus-glib' 'pacman>=5.0.0' 'polkit' 'shared-mime-info' 'sqlite')
+makedepends=('gobject-introspection' 'gtk-doc' 'intltool'
+ 'networkmanager' 'bash-completion' 'vala' 'autoconf-archive')
+optdepends=('networkmanager: detect connection status'
+ 'bash-completion: command completion in bash')
+backup=('var/lib/PackageKit/transactions.db'
+ 'etc/PackageKit/alpm.d/pacman.conf'
+ 'etc/PackageKit/alpm.d/repos.list')
+source=("git+https://github.com/hughsie/PackageKit.git")
+replaces=(packagekit)
+md5sums=('SKIP')
+
+build() {
+ cd "${srcdir}/PackageKit"
+
+ ./autogen.sh --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --libexecdir=/usr/lib/PackageKit \
+ --with-dbus-sys=/usr/share/dbus-1/system.d \
+ --disable-static \
+ --disable-gtk-doc \
+ --disable-local \
+ --disable-browser-plugin \
+ --disable-gstreamer-plugin \
+ --disable-gtk-module \
+ --disable-command-not-found \
+ --disable-cron \
+ --disable-dummy \
+ --enable-alpm
+ make
+}
+
+package() {
+ cd "${srcdir}/PackageKit"
+
+ # install directory with root owner, polkit group and
+ # correct permission
+ install -d -o root -g 102 -m 750 "${pkgdir}/usr/share/polkit-1/rules.d"
+
+ make DESTDIR="${pkgdir}" install
+}