summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDasith Gunawardhana2019-05-12 14:30:56 -0700
committerDasith Gunawardhana2019-05-12 14:30:56 -0700
commit1063a101263fd733b8a315455e6f6562e722e77d (patch)
tree79f5dbe417ab4cacc93b5b4481a69dc28c8fa477
parent4102b5bac00e5fa475826d471aa981181ab9474b (diff)
downloadaur-1063a101263fd733b8a315455e6f6562e722e77d.tar.gz
initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD49
2 files changed, 39 insertions, 33 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c500a2485065..8a2523cc11ac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,16 @@
-# Generated by mksrcinfo v8
-# Thu Oct 26 07:09:05 UTC 2017
pkgbase = packer-git
- pkgdesc = Bash wrapper for pacman and aur
- pkgver = 325.400c655
+ pkgdesc = Packer is a tool for creating identical machine images for multiple platforms from a single source configuration.
+ pkgver = v1.3.3_991_g69aec690f
pkgrel = 1
- url = https://github.com/gavinhungry/packer
- arch = any
- license = GPL3
+ url = https://www.packer.io/
+ arch = x86_64
+ license = MPL2
+ makedepends = go
makedepends = git
- depends = bash
- depends = curl
- depends = grep
- depends = pacman
- depends = sed
- depends = jshon
+ depends = glibc
+ provides = packer
conflicts = packer
- source = packer-git::git+https://github.com/gavinhungry/packer.git#branch=master
+ source = git+https://github.com/hashicorp/packer.git
sha256sums = SKIP
pkgname = packer-git
diff --git a/PKGBUILD b/PKGBUILD
index 28492eadb33c..79e5900d83fa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,39 @@
-# Maintainer: Gavin Lloyd <gavinhungry@gmail.com>
-# Contributor: Jan Pacner
-# Contributor: dumblob <dumblob@gmail.com>
+# Maintainer: Dasith Gunawardhana <dasith.gunawardhana@gmail.com>
-pkgname=packer-git
-pkgver=325.400c655
+_pkgname=packer
+pkgname=${_pkgname}-git
+pkgver=v1.3.3_991_g69aec690f
pkgrel=1
-pkgdesc='Bash wrapper for pacman and aur'
-arch=('any')
-url="https://github.com/gavinhungry/packer"
-license=('GPL3')
-depends=('bash' 'curl' 'grep' 'pacman' 'sed' 'jshon')
-makedepends=('git')
-conflicts=('packer')
-source=("${pkgname}::git+${url}.git#branch=master")
+pkgdesc="Packer is a tool for creating identical machine images for multiple platforms from a single source configuration."
+arch=('x86_64')
+url="https://www.packer.io/"
+license=('MPL2')
+depends=('glibc')
+makedepends=('go' 'git')
+conflicts=("${_pkgname}")
+provides=("${_pkgname}")
+source=("git+https://github.com/hashicorp/packer.git")
sha256sums=('SKIP')
pkgver() {
- cd "${srcdir}/${pkgname}"
- echo $(git rev-list --count HEAD).$(git rev-parse --short HEAD)
+ cd ${_pkgname}
+ git describe | sed 's/[- ]/_/g'
}
-package() {
- cd "${pkgname}"
+build() {
+ export GOFLAGS="-gcflags=all=-trimpath=${PWD} -asmflags=all=-trimpath=${PWD} -ldflags=-extldflags=-zrelro -ldflags=-extldflags=-znow"
+
+ cd ${_pkgname}
+ make dev
+}
- install -Dm755 packer "${pkgdir}"/usr/bin/packer
- install -Dm644 packer.8 "${pkgdir}"/usr/share/man/man8/packer.8
+# check() {
+# cd ${_pkgname}
+# make test
+# }
+
+package() {
+ cd ${_pkgname}
+ install -Dm755 bin/packer "$pkgdir"/usr/bin/packer
+ install -m644 -D LICENSE "$pkgdir/usr/share/licenses/${_pkgname}/LICENSE"
}