summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDasith Gunawardhana2019-05-16 23:15:11 -0700
committerDasith Gunawardhana2019-05-16 23:15:11 -0700
commit2bdaf2460edee38053c8e48a862c89534321ed89 (patch)
tree882df386c65137b0ba0b3d5a54e9167324982ed4
parent1063a101263fd733b8a315455e6f6562e722e77d (diff)
downloadaur-2bdaf2460edee38053c8e48a862c89534321ed89.tar.gz
re-add check; set GOPATH
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD18
2 files changed, 15 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8a2523cc11ac..40847de4e8b9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = packer-git
pkgdesc = Packer is a tool for creating identical machine images for multiple platforms from a single source configuration.
- pkgver = v1.3.3_991_g69aec690f
+ pkgver = v1.3.3_1006_g07dbf8195
pkgrel = 1
url = https://www.packer.io/
arch = x86_64
@@ -10,7 +10,7 @@ pkgbase = packer-git
depends = glibc
provides = packer
conflicts = packer
- source = git+https://github.com/hashicorp/packer.git
+ source = git+https://github.com/hashicorp/packer.git#branch=master
sha256sums = SKIP
pkgname = packer-git
diff --git a/PKGBUILD b/PKGBUILD
index 79e5900d83fa..03f2f1ee97bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=packer
pkgname=${_pkgname}-git
-pkgver=v1.3.3_991_g69aec690f
+pkgver=v1.3.3_999_g5504709e1
pkgrel=1
pkgdesc="Packer is a tool for creating identical machine images for multiple platforms from a single source configuration."
arch=('x86_64')
@@ -20,17 +20,25 @@ pkgver() {
git describe | sed 's/[- ]/_/g'
}
+prepare() {
+ mkdir -p gopath
+}
+
build() {
+ export GOPATH="${srcdir}/gopath"
export GOFLAGS="-gcflags=all=-trimpath=${PWD} -asmflags=all=-trimpath=${PWD} -ldflags=-extldflags=-zrelro -ldflags=-extldflags=-znow"
cd ${_pkgname}
make dev
}
-# check() {
-# cd ${_pkgname}
-# make test
-# }
+check() {
+ export GOPATH="${srcdir}/gopath"
+ unset GOFLAGS
+
+ cd ${_pkgname}
+ make test
+}
package() {
cd ${_pkgname}