summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanilo Kuehn2015-06-12 09:39:20 +0200
committerDanilo Kuehn2015-06-12 09:39:20 +0200
commitcdc0e0b5ec61c2ce76e8ac7170fe8f57f6369bfc (patch)
tree7cbf0a1bc391ec8ab604c675999772b6dffeb506
downloadaur-cdc0e0b5ec61c2ce76e8ac7170fe8f57f6369bfc.tar.gz
Initial import
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD40
2 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..705838aa8c1e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = packer-io
+ pkgdesc = Packer is a tool for creating identical machine images for multiple platforms from a single source configuration.
+ pkgver = 0.7.5
+ pkgrel = 1
+ url = http://www.packer.io
+ arch = x86_64
+ arch = i686
+ license = MPL2
+ depends = unzip
+ noextract = packer-0.7.5.zip
+ source = packer-0.7.5.zip::https://dl.bintray.com/mitchellh/packer/packer_0.7.5_linux_amd64.zip
+ sha256sums = 8fab291c8cc988bd0004195677924ab6846aee5800b6c8696d71d33456701ef6
+
+pkgname = packer-io
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..92bd191a3fb9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Danilo Kuehn <dk[at]nogo-software[dot]de>
+
+_name=packer
+pkgname=packer-io
+pkgver=0.7.5
+pkgrel=1
+pkgdesc="Packer is a tool for creating identical machine images for multiple platforms from a single source configuration."
+url="http://www.packer.io"
+arch=('x86_64' 'i686')
+license=('MPL2')
+depends=(unzip)
+optdepends=()
+conflicts=()
+if test "$CARCH" == i686; then
+source=("${_name}-${pkgver}.zip::https://dl.bintray.com/mitchellh/packer/${_name}_${pkgver}_linux_386.zip")
+sha256sums=('6a6ee79d51909f04f734c15a0e12ebcaba3f2cf4d449906f6a186490774262f9')
+else
+source=("${_name}-${pkgver}.zip::https://dl.bintray.com/mitchellh/packer/${_name}_${pkgver}_linux_amd64.zip")
+sha256sums=('8fab291c8cc988bd0004195677924ab6846aee5800b6c8696d71d33456701ef6')
+fi
+noextract=(${source[@]%%::*})
+
+prepare() {
+ if [[ -e ${srcdir}/${_name}-${pkgver} ]]; then rm -rf ${srcdir}/${_name}-${pkgver}; fi
+ mkdir ${srcdir}/${_name}-${pkgver}
+ unzip -o ${_name}-${pkgver}.zip -d ${srcdir}/${_name}-${pkgver}
+}
+
+package() {
+ install -dm755 "${pkgdir}/usr/bin"
+
+ cd "${srcdir}/${_name}-${pkgver}"
+ for file in `ls ${srcdir}/${_name}-${pkgver}`; do
+ if [ "$file" == "packer" ]; then
+ install -Dm755 "$file" "${pkgdir}/usr/bin/${file}-io"
+ else
+ install -Dm755 "$file" "${pkgdir}/usr/bin/${file}"
+ fi
+ done
+}