summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanilo Kühn2016-05-10 17:31:09 +0200
committerDanilo Kühn2016-05-10 17:31:09 +0200
commitd954e517e5457b6c8d3ce5817cac3e2c894a3435 (patch)
tree41201b6c4fc3fc729cd5f148f8b851db36cabcaa
parentd9002dd8f8ab5d5733912d55bc014f587eea8297 (diff)
downloadaur-d954e517e5457b6c8d3ce5817cac3e2c894a3435.tar.gz
update to 0.10.1
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD23
2 files changed, 25 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 12245e222547..eb9ebcd50614 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,18 @@
pkgbase = packer-io
pkgdesc = Packer is a tool for creating identical machine images for multiple platforms from a single source configuration.
- pkgver = 0.10.0
+ pkgver = 0.10.1
pkgrel = 1
url = http://www.packer.io
arch = x86_64
arch = i686
license = MPL2
depends = unzip
- noextract = packer-0.10.0.zip
- source = packer-0.10.0.zip::https://releases.hashicorp.com/packer/0.10.0/packer_0.10.0_linux_amd64.zip
- sha256sums = eadd33bc0f8fa42034059fc1cda5f43ed6f540746e767480f0706ebed49b45e5
+ noextract = packer-0.10.1.zip
+ noextract = https://raw.githubusercontent.com/mitchellh/packer/master/contrib/zsh-completion/_packer
+ source = packer-0.10.1.zip::https://releases.hashicorp.com/packer/0.10.1/packer_0.10.1_linux_amd64.zip
+ source = https://raw.githubusercontent.com/mitchellh/packer/master/contrib/zsh-completion/_packer
+ sha256sums = 7d51fc5db19d02bbf32278a8116830fae33a3f9bd4440a58d23ad7c863e92e28
+ sha256sums = 070675905e14b839420282b280a15a7a72ed34c78ad403532ecd3ed5d9768459
pkgname = packer-io
diff --git a/PKGBUILD b/PKGBUILD
index db8b7b570168..fe67ff499917 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_name=packer
pkgname=packer-io
-pkgver=0.10.0
+pkgver=0.10.1
pkgrel=1
pkgdesc="Packer is a tool for creating identical machine images for multiple platforms from a single source configuration."
url="http://www.packer.io"
@@ -12,11 +12,23 @@ depends=(unzip)
optdepends=()
conflicts=()
if test "$CARCH" == i686; then
-source=("${_name}-${pkgver}.zip::https://releases.hashicorp.com/packer/${pkgver}/packer_${pkgver}_linux_386.zip")
-sha256sums=('0d2460f645e73e070cb203e540b64624027f27d82268f7d939898af1c358abaf')
+source=(
+ "${_name}-${pkgver}.zip::https://releases.hashicorp.com/packer/${pkgver}/packer_${pkgver}_linux_386.zip"
+ 'https://raw.githubusercontent.com/mitchellh/packer/master/contrib/zsh-completion/_packer'
+)
+sha256sums=(
+ '9146b94115684a9725b2c1b5e5fbc412f30caaca136dbad4028423d6d6d3b6e4'
+ '070675905e14b839420282b280a15a7a72ed34c78ad403532ecd3ed5d9768459'
+)
else
-source=("${_name}-${pkgver}.zip::https://releases.hashicorp.com/packer/${pkgver}/packer_${pkgver}_linux_amd64.zip")
-sha256sums=('eadd33bc0f8fa42034059fc1cda5f43ed6f540746e767480f0706ebed49b45e5')
+source=(
+ "${_name}-${pkgver}.zip::https://releases.hashicorp.com/packer/${pkgver}/packer_${pkgver}_linux_amd64.zip"
+ 'https://raw.githubusercontent.com/mitchellh/packer/master/contrib/zsh-completion/_packer'
+)
+sha256sums=(
+ '7d51fc5db19d02bbf32278a8116830fae33a3f9bd4440a58d23ad7c863e92e28'
+ '070675905e14b839420282b280a15a7a72ed34c78ad403532ecd3ed5d9768459'
+)
fi
noextract=(${source[@]%%::*})
@@ -37,4 +49,5 @@ package() {
install -Dm755 "$file" "${pkgdir}/usr/bin/${file}"
fi
done
+ install -Dm644 ${srcdir}/_packer ${pkgdir}/usr/share/site-functions/_packer
}