summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTyler Langlois2017-02-10 23:36:30 -0500
committerTyler Langlois2017-02-10 23:36:30 -0500
commit9114ef660b26228641d2bff5ff35df571c96ca32 (patch)
tree0a8b435938c403d1e71851b3c5f273d5d1542d4d
parentb483ca182244b6e3098e68295bc2f7c1507363c9 (diff)
downloadaur-9114ef660b26228641d2bff5ff35df571c96ca32.tar.gz
Version bump packetbeat-bin to 5.2.0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD39
-rw-r--r--packetbeat.service7
3 files changed, 39 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ba3dd0db872f..2d917c7ef91e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
# Generated by mksrcinfo v8
-# Fri May 20 01:20:23 UTC 2016
+# Sat Feb 11 04:35:59 UTC 2017
pkgbase = packetbeat-bin
pkgdesc = An open source network packet analyzer that ships data to Elasticsearch (precompiled)
- pkgver = 1.2.3
+ pkgver = 5.2.0
pkgrel = 1
url = https://www.elastic.co/products/beats/packetbeat
arch = i686
@@ -14,11 +14,11 @@ pkgbase = packetbeat-bin
options = !strip
backup = etc/packetbeat/packetbeat.yml
source = packetbeat.service
- sha256sums = e45629a37d5c305efa26e2b6a68561528762081681e547e312bb058cbff76125
- source_i686 = https://download.elastic.co/beats/packetbeat/packetbeat-1.2.3-i686.tar.gz
- sha256sums_i686 = 7a3aa400a79265647a1de0363b472fd66f1df81e9910bb5f6946ceb3c4c140df
- source_x86_64 = https://download.elastic.co/beats/packetbeat/packetbeat-1.2.3-x86_64.tar.gz
- sha256sums_x86_64 = db2fcf1934f1bebe9da2ed08703d0a9361c3efa2be873a9b91559df8bd2bb1dd
+ sha256sums = acc6d21a3fe1a2b5f721f0423b4752ffd2c69b37c1c8323edac0d583ae73daaa
+ source_i686 = https://artifacts.elastic.co/downloads/beats/packetbeat/packetbeat-5.2.0-linux-x86.tar.gz
+ sha256sums_i686 = 1edd5d93d30f9ad8169e3a1ca62b02d2f3575e809d4f619b6949eeb64cc35b3a
+ source_x86_64 = https://artifacts.elastic.co/downloads/beats/packetbeat/packetbeat-5.2.0-linux-x86_64.tar.gz
+ sha256sums_x86_64 = 51dc83da0d6904afbfb04c276c48f33e12fa4e7bdd31bc54d2b20b482447f54f
pkgname = packetbeat-bin
diff --git a/PKGBUILD b/PKGBUILD
index 6e55a4b8127e..6063b2586d25 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=packetbeat-bin
_pkgbase=${pkgname%%-bin}
-pkgver=1.2.3
+pkgver=5.2.0
pkgrel=1
pkgdesc='An open source network packet analyzer that ships data to Elasticsearch (precompiled)'
arch=('i686' 'x86_64')
@@ -11,23 +11,38 @@ license=('APACHE')
backup=("etc/$_pkgbase/$_pkgbase.yml")
optdepends=('elasticsearch: for running standalone installation')
options=('!strip')
-provides=('packetbeat')
-conflicts=('packetbeat')
+provides=("$_pkgbase")
+conflicts=("$_pkgbase")
source=("$_pkgbase.service")
-sha256sums=('e45629a37d5c305efa26e2b6a68561528762081681e547e312bb058cbff76125')
+sha256sums=('acc6d21a3fe1a2b5f721f0423b4752ffd2c69b37c1c8323edac0d583ae73daaa')
-source_i686=("https://download.elastic.co/beats/$_pkgbase/$_pkgbase-$pkgver-i686.tar.gz")
-source_x86_64=("https://download.elastic.co/beats/$_pkgbase/$_pkgbase-$pkgver-x86_64.tar.gz")
-sha256sums_i686=('7a3aa400a79265647a1de0363b472fd66f1df81e9910bb5f6946ceb3c4c140df')
-sha256sums_x86_64=('db2fcf1934f1bebe9da2ed08703d0a9361c3efa2be873a9b91559df8bd2bb1dd')
+source_i686=("https://artifacts.elastic.co/downloads/beats/$_pkgbase/$_pkgbase-$pkgver-linux-x86.tar.gz")
+source_x86_64=("https://artifacts.elastic.co/downloads/beats/$_pkgbase/$_pkgbase-$pkgver-linux-x86_64.tar.gz")
+sha256sums_i686=('1edd5d93d30f9ad8169e3a1ca62b02d2f3575e809d4f619b6949eeb64cc35b3a')
+sha256sums_x86_64=('51dc83da0d6904afbfb04c276c48f33e12fa4e7bdd31bc54d2b20b482447f54f')
package() {
- cd "$srcdir/$_pkgbase-$pkgver-$CARCH"
+ if [[ $CARCH == 'i686' ]] ; then
+ beats_arch=x86
+ else
+ beats_arch=$CARCH
+ fi
+
+ cd "$srcdir/$_pkgbase-$pkgver-linux-$beats_arch"
+
+ for d in lib log ; do
+ mkdir -p "$pkgdir/var/$d/$_pkgbase"
+ done
install -D -m755 $_pkgbase "$pkgdir/usr/bin/$_pkgbase"
- install -D -m644 $_pkgbase.yml "$pkgdir/etc/$_pkgbase/$_pkgbase.yml"
- install -D -m644 $_pkgbase.template.json \
- "$pkgdir/etc/$_pkgbase/$_pkgbase.template.json"
+
+ for f in $_pkgbase.{{,full.}yml,template{,-es2x}.json} ; do
+ install -D -m644 $f "$pkgdir/etc/$_pkgbase/$f"
+ done
+
+ for f in NOTICE README.md scripts/* ; do
+ install -D -m644 $f "$pkgdir/usr/share/$_pkgbase/$f"
+ done
install -D -m644 "$srcdir/$_pkgbase.service" \
"$pkgdir/usr/lib/systemd/system/$_pkgbase.service"
diff --git a/packetbeat.service b/packetbeat.service
index 1fbc5468c1f8..aca833ebe105 100644
--- a/packetbeat.service
+++ b/packetbeat.service
@@ -1,10 +1,13 @@
[Unit]
-Description=Open Source Real-Time Packet Analyzer
+Description=packetbeat
Documentation=https://www.elastic.co/guide/en/beats/packetbeat/current
After=network.target
[Service]
-ExecStart=/usr/bin/packetbeat -c /etc/packetbeat/packetbeat.yml
+ExecStart=/usr/bin/packetbeat -path.config /etc/packetbeat \
+ -path.home /usr/share/packetbeat \
+ -path.data /var/lib/packetbeat \
+ -path.logs /var/log/packetbeat
[Install]
WantedBy=multi-user.target