summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNazar Vinnichuk2020-04-03 19:10:39 +0300
committerNazar Vinnichuk2020-04-03 19:10:39 +0300
commita339d50b74bcfbfba821f14897588d024bfe3628 (patch)
treefdb30198bfdc4f12001edb325f74231f2c4f0772
downloadaur-a339d50b74bcfbfba821f14897588d024bfe3628.tar.gz
Initial commit.
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD29
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ca9932da3d21
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = pacwall-git
+ pkgdesc = Dependency graph of installed packages on your wallpaper.
+ pkgver = r79.6c0be4d
+ pkgrel = 1
+ url = http://github.com/Kharacternyk/pacwall
+ arch = any
+ license = GPL-3
+ makedepends = git
+ depends = graphviz
+ depends = pacman-contrib
+ optdepends = feh: wallpaper setting using feh
+ optdepends = hsetroot: wallpaper setting using hsetroot
+ optdepends = imagemagick: DE integration
+ optdepends = xorg-xdpyinfo: DE integration
+ conflicts = pacwall
+ source = pacwall::git+https://github.com/Kharacternyk/pacwall.git#branch=master
+ sha256sums = SKIP
+
+pkgname = pacwall-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..106f1092c961
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Nazar Vinnichuk <nazar.vinnichuk at tutanota dot com>
+pkgname=pacwall-git
+_pkgname=${pkgname%-git}
+pkgver=r79.6c0be4d
+pkgrel=1
+pkgdesc="Dependency graph of installed packages on your wallpaper."
+url="http://github.com/Kharacternyk/${_pkgname}"
+arch=('any')
+license=('GPL-3')
+depends=('graphviz' 'pacman-contrib')
+optdepends=('feh: wallpaper setting using feh'
+ 'hsetroot: wallpaper setting using hsetroot'
+ 'imagemagick: DE integration'
+ 'xorg-xdpyinfo: DE integration')
+makedepends=('git')
+conflicts=("${_pkgname}")
+source=("${_pkgname}::git+https://github.com/Kharacternyk/${_pkgname}.git#branch=master")
+sha256sums=(SKIP)
+
+pkgver() {
+ cd "${srcdir}/${_pkgname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/${_pkgname}"
+ install -Dm755 "${srcdir}/${_pkgname}/pacwall.sh" "${pkgdir}/usr/bin/pacwall"
+ install -Dm644 "${srcdir}/${_pkgname}/README.rst" "${pkgdir}/usr/share/doc/${pkgname}/README.rst"
+}