summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlbert Berger2015-06-13 10:49:16 +0300
committerAlbert Berger2015-06-13 10:49:16 +0300
commit743c159cea2188ccb3fefe90d9f5d1f8f0f49021 (patch)
tree86fa1dfbf5acf9cba90bdd232ecff156984047bd
downloadaur-743c159cea2188ccb3fefe90d9f5d1f8f0f49021.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9519cd7ec558
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = pacliner-git
+ pkgdesc = Archlinux package management helper.
+ pkgver = 0.1.r1
+ pkgrel = 1
+ url = https://github.com/nbdsp/pacliner.git
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = bash,perl
+ provides = pacliner
+ conflicts = pacliner
+ source = pacliner::git+https://github.com/nbdsp/pacliner.git#branch=master
+ md5sums = SKIP
+
+pkgname = pacliner-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..946888535f3e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Albert Berger < nbdspcl at gmail dot com>
+pkgname=pacliner
+pkgver=0.1
+pkgrel=1
+pkgdesc="Archlinux package management helper."
+arch=('any')
+url="https://github.com/nbdsp/pacliner.git"
+license=('GPL')
+groups=()
+depends=('bash','perl')
+makedepends=('git')
+provides=("${pkgname}")
+conflicts=("${pkgname}")
+replaces=()
+backup=()
+options=()
+install=
+source=("${pkgname}::git+$url#tag=v0.1")
+noextract=()
+md5sums=('SKIP')
+
+
+package() {
+ cd "${pkgname}"
+ install -Dm755 "${pkgname}.sh" "$pkgdir/usr/bin/${pkgname}"
+}