summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristian Münch2020-10-12 16:58:36 +0200
committerChristian Münch2020-10-12 16:58:36 +0200
commit70aef34a95fb41a48646a5ef6be57bc6a91d2d01 (patch)
tree9a6e622f1411758d5e3c08bfb13a300f5ed17b3b
parent8e1f364199f252a118cb79641dc68d25f1f0a83c (diff)
downloadaur-70aef34a95fb41a48646a5ef6be57bc6a91d2d01.tar.gz
Disable timer on package remove (see Github issue #3)
-rw-r--r--PKGBUILD6
-rw-r--r--pacman-auto-update.install2
2 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 95413f665d85..43922b5dd7ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
# Maintainer: Christian Münch <christian@muench-worms.de>
pkgname=pacman-auto-update
-pkgver=1.0.0
-pkgrel=2
+pkgver=1.0.1
+pkgrel=1
pkgdesc="Install a systemd service triggered by a timer to run automatic pacman package updates"
-arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
+arch=('any')
url="https://github.com/cmuench/pacman-auto-update.git"
license=('GPL')
install=${pkgname}.install
diff --git a/pacman-auto-update.install b/pacman-auto-update.install
index ad57842cea87..47af5ce81f11 100644
--- a/pacman-auto-update.install
+++ b/pacman-auto-update.install
@@ -9,7 +9,7 @@ post_upgrade() {
pre_remove() {
if [ -d /run/systemd/system ]; then
- systemctl stop pacman-auto-update.timer >/dev/null
+ systemctl disable --now pacman-auto-update.timer >/dev/null
fi
}