summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCookie Engineer2020-12-12 06:14:17 +0100
committerCookie Engineer2020-12-12 06:14:17 +0100
commit1b0601de92c6439cf0bff014058966385785d3e5 (patch)
tree4d28d582886fb5c46064013014908fe5c0302877
downloadaur-1b0601de92c6439cf0bff014058966385785d3e5.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD27
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a6e61461440c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = pacman-backup
+ pkgdesc = Backup tool for off-the-grid updates via portable USB sticks or (mesh) LAN networks.
+ pkgver = r2.c24edb4
+ pkgrel = 1
+ url = https://github.com/cookiengineer/pacman-backup
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ arch = armv7h
+ arch = aarch64
+ license = GPL
+ makedepends = git
+ depends = nodejs
+ provides = pacman-backup
+ source = git+https://github.com/cookiengineer/pacman-backup.git
+ sha256sums = SKIP
+
+pkgname = pacman-backup
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..cecf242facdf
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/pacman-backup
+/pkg
+/src
+/*.pkg.tar.zst
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a1c4c55dfa0f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Cookie Engineer <@cookiengineer>
+
+pkgname=pacman-backup
+pkgver=r2.c24edb4
+pkgrel=1
+pkgdesc='Backup tool for off-the-grid updates via portable USB sticks or (mesh) LAN networks.'
+arch=('i686' 'x86_64' 'armv6h' 'armv7h' 'aarch64')
+makedepends=('git')
+depends=('nodejs')
+url='https://github.com/cookiengineer/pacman-backup'
+license=('GPL')
+provides=('pacman-backup')
+source=('git+https://github.com/cookiengineer/pacman-backup.git')
+sha256sums=('SKIP')
+
+_gitname="pacman-backup"
+
+pkgver() {
+ cd "${srcdir}/${_gitname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+package() {
+ cd "${srcdir}/${_gitname}"
+ install -Dm755 pacman-backup.js "$pkgdir/usr/bin/pacman-backup";
+}
+