aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordtluna2018-12-15 01:08:49 +0300
committerdtluna2018-12-15 01:08:49 +0300
commit6201ec8ce89ccec1250cdf833ad672b5ce223820 (patch)
treeb9811cdb97464edc644e8b403a4f2323e7423110
downloadaur-6201ec8ce89ccec1250cdf833ad672b5ce223820.tar.gz
Version 1.0.0
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD18
3 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e76f49baa8b3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = pacman-backup-hook
+ pkgdesc = A pacman hook that will save the list of your packages to /etc/pkglist.txt on every install and removal
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://git.voluntaryism.club/dtluna/pacman-backup-hook
+ arch = any
+ license = unknown
+ depends = pacman>=5.1
+ source = pacman-backup-hook-1.0.0.tar.gz::https://git.voluntaryism.club/dtluna/pacman-backup-hook/archive/1.0.0.tar.gz
+ sha256sums = 532fcbc1fc4dbb93b8b7e729d53bc5e37c7067eb9f491c31cdafd54b2fa7d56e
+
+pkgname = pacman-backup-hook
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f59ec20aabf5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5d567149172d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: dtluna dtluna@waifu.club
+pkgname=pacman-backup-hook
+pkgver="1.0.0"
+pkgrel=1
+pkgdesc="A pacman hook that will save the list of your packages to /etc/pkglist.txt on every install and removal"
+arch=('any')
+url="https://git.voluntaryism.club/dtluna/pacman-backup-hook"
+license=('unknown')
+depends=(
+ 'pacman>=5.1'
+)
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
+sha256sums=('532fcbc1fc4dbb93b8b7e729d53bc5e37c7067eb9f491c31cdafd54b2fa7d56e')
+
+package() {
+ cd "$srcdir/$pkgname"
+ install -Dm644 pacman-backup.hook $pkgdir/usr/share/libalpm/hooks/pacman-backup.hook
+}