summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQue Quotion2018-06-27 00:31:00 +0900
committerQue Quotion2018-06-27 00:36:07 +0900
commite9416ffe51960802790101cfa588446020e2ec9a (patch)
tree04c89444a64e440b32e77bc959467880332ae284
parent53b75642b06a845c6d1465cbe38c0ab6b11d4609 (diff)
downloadaur-e9416ffe51960802790101cfa588446020e2ec9a.tar.gz
Updates from upstream packaging
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD58
-rw-r--r--makepkg.conf147
-rw-r--r--pacman.conf.arm91
-rw-r--r--pacman.conf.i68691
-rw-r--r--pacman.conf.x86_64100
6 files changed, 486 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 545f78216a30..81cad2eae5c4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Mon Nov 14 17:27:30 UTC 2016
pkgbase = pacman-buildenv_ext-git
pkgdesc = A library-based package manager with dependency support with support for build environment extensions. git version.
- pkgver = 5.0.1.95.gfa06951
+ pkgver = 5.1.0.19.g0d6e82d3
pkgrel = 1
url = http://www.archlinux.org/pacman/
arch = i686
@@ -19,18 +17,27 @@ pkgbase = pacman-buildenv_ext-git
depends = pacman-mirrorlist
optdepends = fakeroot: for makepkg usage as normal user
optdepends = makepkg-optimize2: supplemental build and packaging optimizations
- provides = pacman=5.0.1.95.gfa06951
- provides = pacman-git=5.0.1.95.gfa06951
+ provides = pacman=5.1.0
+ provides = pacman-git=5.1.0
provides = libalpm.so
conflicts = pacman
options = !libtool
options = !strip
backup = etc/pacman.conf
backup = etc/makepkg.conf
+ backup = etc/makepkg-optimize.conf
source = git://git.archlinux.org/pacman.git
+ source = pacman.conf.i686
+ source = pacman.conf.x86_64
+ source = pacman.conf.arm
source = buildenv_ext.patch
+ source = makepkg.conf
sha1sums = SKIP
+ sha1sums = f3b8b360bf4c8775f439ab189e445f455334cccf
+ sha1sums = 0b3ad0e7e28b6b28a611ea6cc4a12515532e1b78
+ sha1sums = 1ac32ed5b20d62d3709fc21c67371a9ec1ce199e
sha1sums = 0f3b272bd2afb83eca7af6595ab763ede2cccfdd
+ sha1sums = 46ae3b64b9c54f06e95ddd7313307942ca45e9b3
pkgname = pacman-buildenv_ext-git
diff --git a/PKGBUILD b/PKGBUILD
index cfc414ca13f4..0b75353cb85d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Andres Perera <aepd87@gmail.com>
pkgname=pacman-buildenv_ext-git
-pkgver=5.0.1.95.gfa06951
+pkgver=5.1.0.19.g0d6e82d3
pkgrel=1
pkgdesc="A library-based package manager with dependency support with support for build environment extensions. git version."
arch=('i686' 'x86_64')
@@ -16,15 +16,21 @@ makedepends=('git' 'asciidoc')
optdepends=('fakeroot: for makepkg usage as normal user'
'makepkg-optimize2: supplemental build and packaging optimizations')
checkdepends=('python2' 'fakechroot')
-provides=(pacman{,-git}=$pkgver 'libalpm.so')
+provides=(pacman{,-git}=${pkgver%.*.*} 'libalpm.so')
conflicts=('pacman')
options=('!libtool' '!strip')
backup=(etc/pacman.conf
- etc/makepkg.conf)
+ etc/makepkg{,-optimize}.conf)
source=(git://git.archlinux.org/pacman.git
- buildenv_ext.patch)
+ pacman.conf.{i686,x86_64,arm}
+ buildenv_ext.patch
+ makepkg.conf)
sha1sums=('SKIP'
- '0f3b272bd2afb83eca7af6595ab763ede2cccfdd')
+ 'f3b8b360bf4c8775f439ab189e445f455334cccf'
+ '0b3ad0e7e28b6b28a611ea6cc4a12515532e1b78'
+ '1ac32ed5b20d62d3709fc21c67371a9ec1ce199e'
+ '0f3b272bd2afb83eca7af6595ab763ede2cccfdd'
+ '46ae3b64b9c54f06e95ddd7313307942ca45e9b3')
pkgver() {
cd pacman
@@ -34,12 +40,12 @@ pkgver() {
prepare() {
cd pacman
patch -Np1 < ../buildenv_ext.patch
+ ./autogen.sh
}
build() {
cd "pacman"
- ./autogen.sh
./configure \
--prefix=/usr \
--sysconfdir=/etc \
@@ -62,6 +68,16 @@ package() {
make DESTDIR="$pkgdir" install
+ # install Arch specific stuff
+ install -dm755 "$pkgdir/etc"
+ if [[ $CARCH =~ arm* || $CARCH = aarch64 ]]; then
+ # $CARCH != uname -m
+ sed -e "s|@CARCH[@]|$CARCH|g" "$srcdir/pacman.conf.arm" \
+ | install -m644 /dev/stdin "$pkgdir/etc/pacman.conf"
+ else
+ install -m644 "$srcdir/pacman.conf.$CARCH" "$pkgdir/etc/pacman.conf"
+ fi
+
# set things correctly in the default conf file
case $CARCH in
i686)
@@ -72,8 +88,31 @@ package() {
mychost="x86_64-unknown-linux-gnu"
myflags="-march=x86-64 "
;;
+ arm)
+ mychost="armv5tel-unknown-linux-gnueabi"
+ myflags="-march=armv5te"
+ ;;
+ armv6h)
+ mychost="armv6l-unknown-linux-gnueabihf"
+ myflags="-march=armv6 -mfloat-abi=hard -mfpu=vfp"
+ ;;
+ armv7h)
+ mychost="armv7l-unknown-linux-gnueabihf"
+ myflags="-march=armv7-a -mfloat-abi=hard -mfpu=vfpv3-d16"
+ ;;
+ aarch64)
+ mychost="aarch64-unknown-linux-gnu"
+ myflags="-march=armv8-a"
+ ;;
esac
+ # set things correctly in the default conf file
+ install -m644 "$srcdir/makepkg.conf" "$pkgdir/etc"
+ sed -i "$pkgdir/etc/makepkg.conf" \
+ -e "s|@CARCH[@]|$CARCH|g" \
+ -e "s|@CHOST[@]|$mychost|g" \
+ -e "s|@CARCHFLAGS[@]|$myflags|g"
+
# install completion files
rm -r "$pkgdir/etc/bash_completion.d"
install -Dm644 scripts/completion/bash_completion "$pkgdir/usr/share/bash-completion/completions/pacman"
@@ -83,13 +122,6 @@ package() {
install -Dm644 scripts/completion/zsh_completion $pkgdir/usr/share/zsh/site-functions/_pacman
- # Do not cruelly overwrite people's config files with useless garbage.
- [[ -f /etc/makepkg.conf ]] && \
- mv $pkgdir/etc/makepkg.conf{,-git} && \
- cp {,$pkgdir}/etc/makepkg.conf
- [[ -f /etc/pacman.conf ]] && \
- mv $pkgdir/etc/pacman.conf{,-git} && \
- cp {,$pkgdir}/etc/pacman.conf
}
# vim: set ts=2 sw=2 et:
diff --git a/makepkg.conf b/makepkg.conf
new file mode 100644
index 000000000000..8fa4fb04d2ed
--- /dev/null
+++ b/makepkg.conf
@@ -0,0 +1,147 @@
+#
+# /etc/makepkg.conf
+#
+
+#########################################################################
+# SOURCE ACQUISITION
+#########################################################################
+#
+#-- The download utilities that makepkg should use to acquire sources
+# Format: 'protocol::agent'
+DLAGENTS=('ftp::/usr/bin/curl -fC - --ftp-pasv --retry 3 --retry-delay 3 -o %o %u'
+ 'http::/usr/bin/curl -fLC - --retry 3 --retry-delay 3 -o %o %u'
+ 'https::/usr/bin/curl -fLC - --retry 3 --retry-delay 3 -o %o %u'
+ 'rsync::/usr/bin/rsync --no-motd -z %u %o'
+ 'scp::/usr/bin/scp -C %u %o')
+
+# Other common tools:
+# /usr/bin/snarf
+# /usr/bin/lftpget -c
+# /usr/bin/wget
+
+#-- The package required by makepkg to download VCS sources
+# Format: 'protocol::package'
+VCSCLIENTS=('bzr::bzr'
+ 'git::git'
+ 'hg::mercurial'
+ 'svn::subversion')
+
+#########################################################################
+# ARCHITECTURE, COMPILE FLAGS
+#########################################################################
+#
+CARCH="@CARCH@"
+CHOST="@CHOST@"
+
+#-- Compiler and Linker Flags
+# -march (or -mcpu) builds exclusively for an architecture
+# -mtune optimizes for an architecture, but builds for whole processor family
+CPPFLAGS="-D_FORTIFY_SOURCE=2"
+CFLAGS="@CARCHFLAGS@ -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt"
+CXXFLAGS="@CARCHFLAGS@ -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt"
+LDFLAGS="-Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now"
+#-- Make Flags: change this for DistCC/SMP systems
+#MAKEFLAGS="-j2"
+#-- Debugging flags
+DEBUG_CFLAGS="-g -fvar-tracking-assignments"
+DEBUG_CXXFLAGS="-g -fvar-tracking-assignments"
+
+#########################################################################
+# BUILD ENVIRONMENT
+#########################################################################
+#
+# Defaults: BUILDENV=(!distcc color !ccache check !sign)
+# A negated environment option will do the opposite of the comments below.
+#
+#-- distcc: Use the Distributed C/C++/ObjC compiler
+#-- color: Colorize output messages
+#-- ccache: Use ccache to cache compilation
+#-- check: Run the check() function if present in the PKGBUILD
+#-- sign: Generate PGP signature file
+#
+BUILDENV=(!distcc color !ccache check !sign)
+#
+#-- If using DistCC, your MAKEFLAGS will also need modification. In addition,
+#-- specify a space-delimited list of hosts running in the DistCC cluster.
+#DISTCC_HOSTS=""
+#
+#-- Specify a directory for package building.
+#BUILDDIR=/tmp/makepkg
+
+#########################################################################
+# GLOBAL PACKAGE OPTIONS
+# These are default values for the options=() settings
+#########################################################################
+#
+# Default: OPTIONS=(strip docs !libtool !staticlibs emptydirs zipman purge !optipng !upx !debug)
+# A negated option will do the opposite of the comments below.
+#
+#-- strip: Strip symbols from binaries/libraries
+#-- docs: Save doc directories specified by DOC_DIRS
+#-- libtool: Leave libtool (.la) files in packages
+#-- staticlibs: Leave static library (.a) files in packages
+#-- emptydirs: Leave empty directories in packages
+#-- zipman: Compress manual (man and info) pages in MAN_DIRS with gzip
+#-- purge: Remove files specified by PURGE_TARGETS
+#-- upx: Compress binary executable files using UPX
+#-- optipng: Optimize PNG images with optipng
+#-- debug: Add debugging flags as specified in DEBUG_* variables
+#
+OPTIONS=(strip docs !libtool !staticlibs emptydirs zipman purge !optipng !upx !debug)
+
+#-- File integrity checks to use. Valid: md5, sha1, sha256, sha384, sha512
+INTEGRITY_CHECK=(md5)
+#-- Options to be used when stripping binaries. See `man strip' for details.
+STRIP_BINARIES="--strip-all"
+#-- Options to be used when stripping shared libraries. See `man strip' for details.
+STRIP_SHARED="--strip-unneeded"
+#-- Options to be used when stripping static libraries. See `man strip' for details.
+STRIP_STATIC="--strip-debug"
+#-- Manual (man and info) directories to compress (if zipman is specified)
+MAN_DIRS=({usr{,/local}{,/share},opt/*}/{man,info})
+#-- Doc directories to remove (if !docs is specified)
+DOC_DIRS=(usr/{,local/}{,share/}{doc,gtk-doc} opt/*/{doc,gtk-doc})
+#-- Files to be removed from all packages (if purge is specified)
+PURGE_TARGETS=(usr/{,share}/info/dir .packlist *.pod)
+
+#########################################################################
+# PACKAGE OUTPUT
+#########################################################################
+#
+# Default: put built package and cached source in build directory
+#
+#-- Destination: specify a fixed directory where all packages will be placed
+#PKGDEST=/home/packages
+#-- Source cache: specify a fixed directory where source files will be cached
+#SRCDEST=/home/sources
+#-- Source packages: specify a fixed directory where all src packages will be placed
+#SRCPKGDEST=/home/srcpackages
+#-- Log files: specify a fixed directory where all log files will be placed
+#LOGDEST=/home/makepkglogs
+#-- Packager: name/email of the person or organization building packages
+#PACKAGER="John Doe <john@doe.com>"
+#-- Specify a key to use for package signing
+#GPGKEY=""
+
+#########################################################################
+# COMPRESSION DEFAULTS
+#########################################################################
+#
+COMPRESSGZ=(gzip -c -f -n)
+COMPRESSBZ2=(bzip2 -c -f)
+COMPRESSXZ=(xz -c -z -)
+COMPRESSLRZ=(lrzip -q)
+COMPRESSLZO=(lzop -q)
+COMPRESSZ=(compress -c -f)
+
+#########################################################################
+# EXTENSION DEFAULTS
+#########################################################################
+#
+# WARNING: Do NOT modify these variables unless you know what you are
+# doing.
+#
+PKGEXT='.pkg.tar.xz'
+SRCEXT='.src.tar.gz'
+
+# vim: set ft=sh ts=2 sw=2 et:
diff --git a/pacman.conf.arm b/pacman.conf.arm
new file mode 100644
index 000000000000..503ef7600dcb
--- /dev/null
+++ b/pacman.conf.arm
@@ -0,0 +1,91 @@
+#
+# /etc/pacman.conf
+#
+# See the pacman.conf(5) manpage for option and repository directives
+
+#
+# GENERAL OPTIONS
+#
+[options]
+# The following paths are commented out with their default values listed.
+# If you wish to use different paths, uncomment and update the paths.
+#RootDir = /
+#DBPath = /var/lib/pacman/
+#CacheDir = /var/cache/pacman/pkg/
+#LogFile = /var/log/pacman.log
+#GPGDir = /etc/pacman.d/gnupg/
+#HookDir = /etc/pacman.d/hooks/
+HoldPkg = pacman-git glibc
+#XferCommand = /usr/bin/curl -C - -f %u > %o
+#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
+#CleanMethod = KeepInstalled
+#UseDelta = 0.7
+Architecture = @CARCH@
+
+# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
+#IgnorePkg =
+#IgnoreGroup =
+
+#NoUpgrade =
+#NoExtract =
+
+# Misc options
+#UseSyslog
+#Color
+#TotalDownload
+CheckSpace
+#VerbosePkgLists
+
+# By default, pacman accepts packages signed by keys that its local keyring
+# trusts (see pacman-key and its man page), as well as unsigned packages.
+SigLevel = Required DatabaseOptional
+LocalFileSigLevel = Optional
+#RemoteFileSigLevel = Required
+
+# NOTE: You must run `pacman-key --init` before first using pacman; the local
+# keyring can then be populated with the keys of all official Arch Linux
+# packagers with `pacman-key --populate archlinux`.
+
+#
+# REPOSITORIES
+# - can be defined here or included from another file
+# - pacman will search repositories in the order defined here
+# - local/custom mirrors can be added here or in separate files
+# - repositories listed first will take precedence when packages
+# have identical names, regardless of version number
+# - URLs will have $repo replaced by the name of the current repo
+# - URLs will have $arch replaced by the name of the architecture
+#
+# Repository entries are of the format:
+# [repo-name]
+# Server = ServerName
+# Include = IncludePath
+#
+# The header [repo-name] is crucial - it must be present and
+# uncommented to enable the repo.
+#
+
+# The testing repositories are disabled by default. To enable, uncomment the
+# repo name header and Include lines. You can add preferred servers immediately
+# after the header, and they will be used before the default mirrors.
+
+[core]
+Include = /etc/pacman.d/mirrorlist
+
+[extra]
+Include = /etc/pacman.d/mirrorlist
+
+[community]
+Include = /etc/pacman.d/mirrorlist
+
+[alarm]
+Include = /etc/pacman.d/mirrorlist
+
+[aur]
+Include = /etc/pacman.d/mirrorlist
+
+# An example of a custom package repository. See the pacman manpage for
+# tips on creating your own repositories.
+#[custom]
+#SigLevel = Optional TrustAll
+#Server = file:///home/custompkgs
diff --git a/pacman.conf.i686 b/pacman.conf.i686
new file mode 100644
index 000000000000..8b2fe248c05b
--- /dev/null
+++ b/pacman.conf.i686
@@ -0,0 +1,91 @@
+#
+# /etc/pacman.conf
+#
+# See the pacman.conf(5) manpage for option and repository directives
+
+#
+# GENERAL OPTIONS
+#
+[options]
+# The following paths are commented out with their default values listed.
+# If you wish to use different paths, uncomment and update the paths.
+#RootDir = /
+#DBPath = /var/lib/pacman/
+#CacheDir = /var/cache/pacman/pkg/
+#LogFile = /var/log/pacman.log
+#GPGDir = /etc/pacman.d/gnupg/
+#HookDir = /etc/pacman.d/hooks/
+HoldPkg = pacman-git glibc
+#XferCommand = /usr/bin/curl -C - -f %u > %o
+#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
+#CleanMethod = KeepInstalled
+#UseDelta = 0.7
+Architecture = auto
+
+# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
+#IgnorePkg =
+#IgnoreGroup =
+
+#NoUpgrade =
+#NoExtract =
+
+# Misc options
+#UseSyslog
+#Color
+#TotalDownload
+CheckSpace
+#VerbosePkgLists
+
+# By default, pacman accepts packages signed by keys that its local keyring
+# trusts (see pacman-key and its man page), as well as unsigned packages.
+SigLevel = Required DatabaseOptional
+LocalFileSigLevel = Optional
+#RemoteFileSigLevel = Required
+
+# NOTE: You must run `pacman-key --init` before first using pacman; the local
+# keyring can then be populated with the keys of all official Arch Linux
+# packagers with `pacman-key --populate archlinux`.
+
+#
+# REPOSITORIES
+# - can be defined here or included from another file
+# - pacman will search repositories in the order defined here
+# - local/custom mirrors can be added here or in separate files
+# - repositories listed first will take precedence when packages
+# have identical names, regardless of version number
+# - URLs will have $repo replaced by the name of the current repo
+# - URLs will have $arch replaced by the name of the architecture
+#
+# Repository entries are of the format:
+# [repo-name]
+# Server = ServerName
+# Include = IncludePath
+#
+# The header [repo-name] is crucial - it must be present and
+# uncommented to enable the repo.
+#
+
+# The testing repositories are disabled by default. To enable, uncomment the
+# repo name header and Include lines. You can add preferred servers immediately
+# after the header, and they will be used before the default mirrors.
+
+#[testing]
+#Include = /etc/pacman.d/mirrorlist
+
+[core]
+Include = /etc/pacman.d/mirrorlist
+
+[extra]
+Include = /etc/pacman.d/mirrorlist
+
+#[community-testing]
+#Include = /etc/pacman.d/mirrorlist
+
+[community]
+Include = /etc/pacman.d/mirrorlist
+
+# An example of a custom package repository. See the pacman manpage for
+# tips on creating your own repositories.
+#[custom]
+#SigLevel = Optional TrustAll
+#Server = file:///home/custompkgs
diff --git a/pacman.conf.x86_64 b/pacman.conf.x86_64
new file mode 100644
index 000000000000..822e9310901d
--- /dev/null
+++ b/pacman.conf.x86_64
@@ -0,0 +1,100 @@
+#
+# /etc/pacman.conf
+#
+# See the pacman.conf(5) manpage for option and repository directives
+
+#
+# GENERAL OPTIONS
+#
+[options]
+# The following paths are commented out with their default values listed.
+# If you wish to use different paths, uncomment and update the paths.
+#RootDir = /
+#DBPath = /var/lib/pacman/
+#CacheDir = /var/cache/pacman/pkg/
+#LogFile = /var/log/pacman.log
+#GPGDir = /etc/pacman.d/gnupg/
+#HookDir = /etc/pacman.d/hooks/
+HoldPkg = pacman-git glibc
+#XferCommand = /usr/bin/curl -C - -f %u > %o
+#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
+#CleanMethod = KeepInstalled
+#UseDelta = 0.7
+Architecture = auto
+
+# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
+#IgnorePkg =
+#IgnoreGroup =
+
+#NoUpgrade =
+#NoExtract =
+
+# Misc options
+#UseSyslog
+#Color
+#TotalDownload
+CheckSpace
+#VerbosePkgLists
+
+# By default, pacman accepts packages signed by keys that its local keyring
+# trusts (see pacman-key and its man page), as well as unsigned packages.
+SigLevel = Required DatabaseOptional
+LocalFileSigLevel = Optional
+#RemoteFileSigLevel = Required
+
+# NOTE: You must run `pacman-key --init` before first using pacman; the local
+# keyring can then be populated with the keys of all official Arch Linux
+# packagers with `pacman-key --populate archlinux`.
+
+#
+# REPOSITORIES
+# - can be defined here or included from another file
+# - pacman will search repositories in the order defined here
+# - local/custom mirrors can be added here or in separate files
+# - repositories listed first will take precedence when packages
+# have identical names, regardless of version number
+# - URLs will have $repo replaced by the name of the current repo
+# - URLs will have $arch replaced by the name of the architecture
+#
+# Repository entries are of the format:
+# [repo-name]
+# Server = ServerName
+# Include = IncludePath
+#
+# The header [repo-name] is crucial - it must be present and
+# uncommented to enable the repo.
+#
+
+# The testing repositories are disabled by default. To enable, uncomment the
+# repo name header and Include lines. You can add preferred servers immediately
+# after the header, and they will be used before the default mirrors.
+
+#[testing]
+#Include = /etc/pacman.d/mirrorlist
+
+[core]
+Include = /etc/pacman.d/mirrorlist
+
+[extra]
+Include = /etc/pacman.d/mirrorlist
+
+#[community-testing]
+#Include = /etc/pacman.d/mirrorlist
+
+[community]
+Include = /etc/pacman.d/mirrorlist
+
+# If you want to run 32 bit applications on your x86_64 system,
+# enable the multilib repositories as required here.
+
+#[multilib-testing]
+#Include = /etc/pacman.d/mirrorlist
+
+#[multilib]
+#Include = /etc/pacman.d/mirrorlist
+
+# An example of a custom package repository. See the pacman manpage for
+# tips on creating your own repositories.
+#[custom]
+#SigLevel = Optional TrustAll
+#Server = file:///home/custompkgs