summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKopfKrieg2018-08-08 17:11:58 +0200
committerKopfKrieg2018-08-08 17:11:58 +0200
commitdb283e53d65afe1d72e61976070faa8fd90c12ac (patch)
tree48e1db500ce9001e9380efd8774600bcb4180826
parent8ea1dd6a76ea5b89ea5b10201f35cd0051b7ef8c (diff)
downloadaur-db283e53d65afe1d72e61976070faa8fd90c12ac.tar.gz
Moved hook from /etc/pacman.d/hooks to /usr/share/libalpm/hooks to allow user overrides
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD8
2 files changed, 5 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4554e478be72..6682642094a8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pacman-cleanup-hook
pkgdesc = Pacman hook to cleanup pacman cache, keeps only the latest cache and the currently installed package. No configuration necessary, just install it.
pkgver = 1.0
- pkgrel = 2
+ pkgrel = 3
arch = any
depends = pacman-contrib
source = cleanup.hook
diff --git a/PKGBUILD b/PKGBUILD
index e9965ef6ab7d..fa338e897467 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=pacman-cleanup-hook
pkgver=1.0
-pkgrel=2
+pkgrel=3
pkgdesc='Pacman hook to cleanup pacman cache, keeps only the latest cache and the currently installed package. No configuration necessary, just install it.'
arch=('any')
depends=('pacman-contrib')
@@ -11,7 +11,7 @@ sha1sums=('8352fc69232b9ae2fea24672c15e103fff80a5d4')
package() {
mkdir -p "${pkgdir}/etc/pacman.d/hooks"
- cp "${srcdir}/cleanup.hook" "${pkgdir}/etc/pacman.d/hooks/cleanup.hook"
- chmod 0644 "${pkgdir}/etc/pacman.d/hooks/cleanup.hook"
- chown root:root "${pkgdir}/etc/pacman.d/hooks/cleanup.hook"
+ cp "${srcdir}/cleanup.hook" "${pkgdir}/usr/share/libalpm/hooks/cleanup.hook"
+ chmod 0644 "${pkgdir}/usr/share/libalpm/hooks/cleanup.hook"
+ chown root:root "${pkgdir}/usr/share/libalpm/hooks/cleanup.hook"
}