summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEli Schwartz2021-04-07 19:36:29 -0400
committerEli Schwartz2021-04-07 20:18:47 -0400
commit8e6f1a30ee70deb70c4971686ffd15892fe0b815 (patch)
treeedcd3386661107a8583a4eb142e974ca8fe0fa22
parent68b487215d1887bc30d078e4b14e54072f1f4981 (diff)
downloadaur-8e6f1a30ee70deb70c4971686ffd15892fe0b815.tar.gz
upgpkg: pacman-git 6.0.0alpha1.r86.gc294b7cb-1
merge makepkg.conf additions from git master
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--makepkg.conf17
3 files changed, 17 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3e5361b8aac0..7c5e93fd3595 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pacman-git
pkgdesc = A library-based package manager with dependency support
- pkgver = 6.0.0alpha1.r23.g95ffdd68
+ pkgver = 6.0.0alpha1.r86.gc294b7cb
pkgrel = 1
url = https://www.archlinux.org/pacman/
arch = i686
@@ -40,6 +40,6 @@ pkgbase = pacman-git
sha256sums = 07b4e78745b9c9ecd93b703649b24b05803941f02ac2142ef62d50e36cb865a7
sha256sums = 4f349704aee808873bef4759a56d92e7985c3f9bffdd7b00bfaa988110124208
sha256sums = 6185dc65b18d1d085f65281c6bd1ce556466a64bf883d1f27c89b7e620570334
- sha256sums = 54b7b886d6b35a35f4edc1829ea398db0d83d334a99cfe80ff4110d722da5c6d
+ sha256sums = 806b40ba78eacedd96d733c1fa1eeae4b1f7398992976e22cf72e22563ab9c7a
pkgname = pacman-git
diff --git a/PKGBUILD b/PKGBUILD
index 221cf07fd658..c1803d02fe24 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Andres Perera <aepd87@gmail.com>
pkgname=pacman-git
-pkgver=6.0.0alpha1.r23.g95ffdd68
+pkgver=6.0.0alpha1.r86.gc294b7cb
pkgrel=1
pkgdesc="A library-based package manager with dependency support"
arch=('i686' 'x86_64' 'arm' 'armv6h' 'armv7h' 'aarch64')
@@ -31,7 +31,7 @@ sha256sums=('SKIP'
'07b4e78745b9c9ecd93b703649b24b05803941f02ac2142ef62d50e36cb865a7'
'4f349704aee808873bef4759a56d92e7985c3f9bffdd7b00bfaa988110124208'
'6185dc65b18d1d085f65281c6bd1ce556466a64bf883d1f27c89b7e620570334'
- '54b7b886d6b35a35f4edc1829ea398db0d83d334a99cfe80ff4110d722da5c6d')
+ '806b40ba78eacedd96d733c1fa1eeae4b1f7398992976e22cf72e22563ab9c7a')
pkgver() {
cd pacman
diff --git a/makepkg.conf b/makepkg.conf
index 0ad85e8fdbb2..93973c770a4a 100644
--- a/makepkg.conf
+++ b/makepkg.conf
@@ -24,6 +24,7 @@ DLAGENTS=('file::/usr/bin/curl -gqC - -o %o %u'
#-- The package required by makepkg to download VCS sources
# Format: 'protocol::package'
VCSCLIENTS=('bzr::bzr'
+ 'fossil::fossil'
'git::git'
'hg::mercurial'
'svn::subversion')
@@ -55,7 +56,7 @@ DEBUG_CXXFLAGS="-g -fvar-tracking-assignments"
# BUILD ENVIRONMENT
#########################################################################
#
-# Defaults: BUILDENV=(!distcc !color !ccache check !sign)
+# Makepkg defaults: BUILDENV=(!distcc !color !ccache check !sign)
# A negated environment option will do the opposite of the comments below.
#
#-- distcc: Use the Distributed C/C++/ObjC compiler
@@ -78,7 +79,7 @@ BUILDENV=(!distcc color !ccache check !sign)
# These are default values for the options=() settings
#########################################################################
#
-# Default: OPTIONS=(!strip docs libtool staticlibs emptydirs !zipman !purge !debug)
+# Makepkg defaults: OPTIONS=(!strip docs libtool staticlibs emptydirs !zipman !purge !debug !lto)
# A negated option will do the opposite of the comments below.
#
#-- strip: Strip symbols from binaries/libraries
@@ -89,10 +90,11 @@ BUILDENV=(!distcc color !ccache check !sign)
#-- zipman: Compress manual (man and info) pages in MAN_DIRS with gzip
#-- purge: Remove files specified by PURGE_TARGETS
#-- debug: Add debugging flags as specified in DEBUG_* variables
+#-- lto: Add compile flags for building with link time optimization
#
-OPTIONS=(strip docs !libtool !staticlibs emptydirs zipman purge !debug)
+OPTIONS=(strip docs !libtool !staticlibs emptydirs zipman purge !debug !lto)
-#-- File integrity checks to use. Valid: md5, sha1, sha224, sha256, sha384, sha512, b2
+#-- File integrity checks to use. Valid: ck, md5, sha1, sha224, sha256, sha384, sha512, b2
INTEGRITY_CHECK=(md5)
#-- Options to be used when stripping binaries. See `man strip' for details.
STRIP_BINARIES="--strip-all"
@@ -148,3 +150,10 @@ COMPRESSLZ=(lzip -c -f)
#
PKGEXT='.pkg.tar.zst'
SRCEXT='.src.tar.gz'
+
+#########################################################################
+# OTHER
+#########################################################################
+#
+#-- Command used to run pacman as root, instead of trying sudo and su
+PACMAN_AUTH=()