summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEli Schwartz2017-12-28 09:49:31 -0500
committerEli Schwartz2017-12-28 09:49:31 -0500
commitcedeae91278fdf02ed30b4399aa141b879f64ab1 (patch)
treeaeead2b40e67e5412e74755a9aa2896e898faac8
parentafdce3eac2c1e5f5a9fc0f8ac6bc7ecf23b1ade2 (diff)
downloadaur-cedeae91278fdf02ed30b4399aa141b879f64ab1.tar.gz
upgpkg: pacman-git 5.0.1.r192.ge4f13e62-1
- Adopt package and update it to not clash with pacman-contrib. - Tweak to provide standard makepkg/pacman .conf - Depend on archlinux-keyring.
-rw-r--r--.SRCINFO23
-rw-r--r--MKPKG3
-rw-r--r--PKGBUILD49
-rw-r--r--makepkg.conf147
-rw-r--r--pacman.conf.i68691
-rw-r--r--pacman.conf.x86_64100
6 files changed, 390 insertions, 23 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5b4a1d37fcbd..e7f902371a69 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pacman-git
pkgdesc = A library-based package manager with dependency support. git version.
- pkgver = 5.0.1.84.gad27aa3
+ pkgver = 5.0.1.r192.ge4f13e62
pkgrel = 1
url = http://www.archlinux.org/pacman/
arch = i686
@@ -10,23 +10,26 @@ pkgbase = pacman-git
checkdepends = fakechroot
makedepends = git
makedepends = asciidoc
+ depends = archlinux-keyring
depends = bash
depends = curl
depends = gpgme
depends = libarchive
depends = pacman-mirrorlist
- optdepends = fakeroot: for makepkg usage as normal user
- provides = pacman=5.0.1.84.gad27aa3
- provides = pacman-contrib
- provides = libalpm.so
+ provides = pacman=5.0.1
conflicts = pacman
- conflicts = pacman-contrib
- options = !libtool
- options = !strip
+ options = strip
+ options = debug
backup = etc/pacman.conf
backup = etc/makepkg.conf
- source = git://git.archlinux.org/pacman.git
- sha1sums = SKIP
+ source = git+https://git.archlinux.org/pacman.git
+ source = pacman.conf.i686
+ source = pacman.conf.x86_64
+ source = makepkg.conf
+ sha256sums = SKIP
+ sha256sums = cb76123c15ca9f2a467ebecb72af611f618fcc8431cf8b437d40fa2e61c23590
+ sha256sums = 95b3b2416402059cf6acf3e046082e7ce261e2b88629231dbf579a4200d8a63b
+ sha256sums = 6066d67d818ee36760bf121c76d5019130f7875b3e5ed179b319b810a3a9685b
pkgname = pacman-git
diff --git a/MKPKG b/MKPKG
new file mode 100644
index 000000000000..aab4ea0a393c
--- /dev/null
+++ b/MKPKG
@@ -0,0 +1,3 @@
+pkgname=(pacman-git pacman-git-debug)
+chroot=(debug)
+check_git pacman
diff --git a/PKGBUILD b/PKGBUILD
index 5d7932a3da6b..cbedecee03d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,33 +4,44 @@
# Contributor: Andres Perera <aepd87@gmail.com>
pkgname=pacman-git
-pkgver=5.0.1.84.gad27aa3
+pkgver=5.0.1.r192.ge4f13e62
pkgrel=1
pkgdesc="A library-based package manager with dependency support. git version."
arch=('i686' 'x86_64')
url="http://www.archlinux.org/pacman/"
license=('GPL')
-depends=('bash' 'curl' 'gpgme' 'libarchive' 'pacman-mirrorlist')
+depends=('archlinux-keyring' 'bash' 'curl' 'gpgme' 'libarchive'
+ 'pacman-mirrorlist')
makedepends=('git' 'asciidoc')
-optdepends=('fakeroot: for makepkg usage as normal user')
checkdepends=('python2' 'fakechroot')
-provides=("pacman=$pkgver" 'pacman-contrib' 'libalpm.so')
-conflicts=('pacman' 'pacman-contrib')
-options=('!libtool' '!strip')
+provides=("pacman=${pkgver%.r*}")
+conflicts=('pacman')
backup=(etc/pacman.conf
etc/makepkg.conf)
-source=(git://git.archlinux.org/pacman.git)
-sha1sums=('SKIP')
+options=('strip' 'debug')
+source=(git+https://git.archlinux.org/pacman.git
+ pacman.conf.i686
+ pacman.conf.x86_64
+ makepkg.conf)
+sha256sums=('SKIP'
+ 'cb76123c15ca9f2a467ebecb72af611f618fcc8431cf8b437d40fa2e61c23590'
+ '95b3b2416402059cf6acf3e046082e7ce261e2b88629231dbf579a4200d8a63b'
+ '6066d67d818ee36760bf121c76d5019130f7875b3e5ed179b319b810a3a9685b')
pkgver() {
cd pacman
- git describe | sed 's/^v//;s/-/./g'
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+prepare() {
+ cd pacman
+
+ ./autogen.sh
}
build() {
cd "pacman"
- ./autogen.sh
./configure \
--prefix=/usr \
--sysconfdir=/etc \
@@ -53,18 +64,30 @@ package() {
make DESTDIR="$pkgdir" install
+ # install Arch specific stuff
+ install -dm755 "$pkgdir/etc"
+ install -m644 "$srcdir/pacman.conf.$CARCH" "$pkgdir/etc/pacman.conf"
+
# set things correctly in the default conf file
case $CARCH in
i686)
mychost="i686-pc-linux-gnu"
- myflags="-march=i686 "
+ myflags="-march=i686"
;;
x86_64)
- mychost="x86_64-unknown-linux-gnu"
- myflags="-march=x86-64 "
+ mychost="x86_64-pc-linux-gnu"
+ myflags="-march=x86-64"
;;
esac
+ # set things correctly in the default conf file
+ install -m644 "$srcdir/makepkg.conf" "$pkgdir/etc"
+ sed -i "$pkgdir/etc/makepkg.conf" \
+ -e "s|@CARCH[@]|$CARCH|g" \
+ -e "s|@CHOST[@]|$mychost|g" \
+ -e "s|@CARCHFLAGS[@]|$myflags|g"
+
+
# install completion files
rm -r "$pkgdir/etc/bash_completion.d"
install -Dm644 scripts/completion/bash_completion "$pkgdir/usr/share/bash-completion/completions/pacman"
diff --git a/makepkg.conf b/makepkg.conf
new file mode 100644
index 000000000000..8fa4fb04d2ed
--- /dev/null
+++ b/makepkg.conf
@@ -0,0 +1,147 @@
+#
+# /etc/makepkg.conf
+#
+
+#########################################################################
+# SOURCE ACQUISITION
+#########################################################################
+#
+#-- The download utilities that makepkg should use to acquire sources
+# Format: 'protocol::agent'
+DLAGENTS=('ftp::/usr/bin/curl -fC - --ftp-pasv --retry 3 --retry-delay 3 -o %o %u'
+ 'http::/usr/bin/curl -fLC - --retry 3 --retry-delay 3 -o %o %u'
+ 'https::/usr/bin/curl -fLC - --retry 3 --retry-delay 3 -o %o %u'
+ 'rsync::/usr/bin/rsync --no-motd -z %u %o'
+ 'scp::/usr/bin/scp -C %u %o')
+
+# Other common tools:
+# /usr/bin/snarf
+# /usr/bin/lftpget -c
+# /usr/bin/wget
+
+#-- The package required by makepkg to download VCS sources
+# Format: 'protocol::package'
+VCSCLIENTS=('bzr::bzr'
+ 'git::git'
+ 'hg::mercurial'
+ 'svn::subversion')
+
+#########################################################################
+# ARCHITECTURE, COMPILE FLAGS
+#########################################################################
+#
+CARCH="@CARCH@"
+CHOST="@CHOST@"
+
+#-- Compiler and Linker Flags
+# -march (or -mcpu) builds exclusively for an architecture
+# -mtune optimizes for an architecture, but builds for whole processor family
+CPPFLAGS="-D_FORTIFY_SOURCE=2"
+CFLAGS="@CARCHFLAGS@ -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt"
+CXXFLAGS="@CARCHFLAGS@ -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt"
+LDFLAGS="-Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now"
+#-- Make Flags: change this for DistCC/SMP systems
+#MAKEFLAGS="-j2"
+#-- Debugging flags
+DEBUG_CFLAGS="-g -fvar-tracking-assignments"
+DEBUG_CXXFLAGS="-g -fvar-tracking-assignments"
+
+#########################################################################
+# BUILD ENVIRONMENT
+#########################################################################
+#
+# Defaults: BUILDENV=(!distcc color !ccache check !sign)
+# A negated environment option will do the opposite of the comments below.
+#
+#-- distcc: Use the Distributed C/C++/ObjC compiler
+#-- color: Colorize output messages
+#-- ccache: Use ccache to cache compilation
+#-- check: Run the check() function if present in the PKGBUILD
+#-- sign: Generate PGP signature file
+#
+BUILDENV=(!distcc color !ccache check !sign)
+#
+#-- If using DistCC, your MAKEFLAGS will also need modification. In addition,
+#-- specify a space-delimited list of hosts running in the DistCC cluster.
+#DISTCC_HOSTS=""
+#
+#-- Specify a directory for package building.
+#BUILDDIR=/tmp/makepkg
+
+#########################################################################
+# GLOBAL PACKAGE OPTIONS
+# These are default values for the options=() settings
+#########################################################################
+#
+# Default: OPTIONS=(strip docs !libtool !staticlibs emptydirs zipman purge !optipng !upx !debug)
+# A negated option will do the opposite of the comments below.
+#
+#-- strip: Strip symbols from binaries/libraries
+#-- docs: Save doc directories specified by DOC_DIRS
+#-- libtool: Leave libtool (.la) files in packages
+#-- staticlibs: Leave static library (.a) files in packages
+#-- emptydirs: Leave empty directories in packages
+#-- zipman: Compress manual (man and info) pages in MAN_DIRS with gzip
+#-- purge: Remove files specified by PURGE_TARGETS
+#-- upx: Compress binary executable files using UPX
+#-- optipng: Optimize PNG images with optipng
+#-- debug: Add debugging flags as specified in DEBUG_* variables
+#
+OPTIONS=(strip docs !libtool !staticlibs emptydirs zipman purge !optipng !upx !debug)
+
+#-- File integrity checks to use. Valid: md5, sha1, sha256, sha384, sha512
+INTEGRITY_CHECK=(md5)
+#-- Options to be used when stripping binaries. See `man strip' for details.
+STRIP_BINARIES="--strip-all"
+#-- Options to be used when stripping shared libraries. See `man strip' for details.
+STRIP_SHARED="--strip-unneeded"
+#-- Options to be used when stripping static libraries. See `man strip' for details.
+STRIP_STATIC="--strip-debug"
+#-- Manual (man and info) directories to compress (if zipman is specified)
+MAN_DIRS=({usr{,/local}{,/share},opt/*}/{man,info})
+#-- Doc directories to remove (if !docs is specified)
+DOC_DIRS=(usr/{,local/}{,share/}{doc,gtk-doc} opt/*/{doc,gtk-doc})
+#-- Files to be removed from all packages (if purge is specified)
+PURGE_TARGETS=(usr/{,share}/info/dir .packlist *.pod)
+
+#########################################################################
+# PACKAGE OUTPUT
+#########################################################################
+#
+# Default: put built package and cached source in build directory
+#
+#-- Destination: specify a fixed directory where all packages will be placed
+#PKGDEST=/home/packages
+#-- Source cache: specify a fixed directory where source files will be cached
+#SRCDEST=/home/sources
+#-- Source packages: specify a fixed directory where all src packages will be placed
+#SRCPKGDEST=/home/srcpackages
+#-- Log files: specify a fixed directory where all log files will be placed
+#LOGDEST=/home/makepkglogs
+#-- Packager: name/email of the person or organization building packages
+#PACKAGER="John Doe <john@doe.com>"
+#-- Specify a key to use for package signing
+#GPGKEY=""
+
+#########################################################################
+# COMPRESSION DEFAULTS
+#########################################################################
+#
+COMPRESSGZ=(gzip -c -f -n)
+COMPRESSBZ2=(bzip2 -c -f)
+COMPRESSXZ=(xz -c -z -)
+COMPRESSLRZ=(lrzip -q)
+COMPRESSLZO=(lzop -q)
+COMPRESSZ=(compress -c -f)
+
+#########################################################################
+# EXTENSION DEFAULTS
+#########################################################################
+#
+# WARNING: Do NOT modify these variables unless you know what you are
+# doing.
+#
+PKGEXT='.pkg.tar.xz'
+SRCEXT='.src.tar.gz'
+
+# vim: set ft=sh ts=2 sw=2 et:
diff --git a/pacman.conf.i686 b/pacman.conf.i686
new file mode 100644
index 000000000000..0ea157018534
--- /dev/null
+++ b/pacman.conf.i686
@@ -0,0 +1,91 @@
+#
+# /etc/pacman.conf
+#
+# See the pacman.conf(5) manpage for option and repository directives
+
+#
+# GENERAL OPTIONS
+#
+[options]
+# The following paths are commented out with their default values listed.
+# If you wish to use different paths, uncomment and update the paths.
+#RootDir = /
+#DBPath = /var/lib/pacman/
+#CacheDir = /var/cache/pacman/pkg/
+#LogFile = /var/log/pacman.log
+#GPGDir = /etc/pacman.d/gnupg/
+#HookDir = /etc/pacman.d/hooks/
+HoldPkg = pacman glibc
+#XferCommand = /usr/bin/curl -C - -f %u > %o
+#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
+#CleanMethod = KeepInstalled
+#UseDelta = 0.7
+Architecture = auto
+
+# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
+#IgnorePkg =
+#IgnoreGroup =
+
+#NoUpgrade =
+#NoExtract =
+
+# Misc options
+#UseSyslog
+#Color
+#TotalDownload
+CheckSpace
+#VerbosePkgLists
+
+# By default, pacman accepts packages signed by keys that its local keyring
+# trusts (see pacman-key and its man page), as well as unsigned packages.
+SigLevel = Required DatabaseOptional
+LocalFileSigLevel = Optional
+#RemoteFileSigLevel = Required
+
+# NOTE: You must run `pacman-key --init` before first using pacman; the local
+# keyring can then be populated with the keys of all official Arch Linux
+# packagers with `pacman-key --populate archlinux`.
+
+#
+# REPOSITORIES
+# - can be defined here or included from another file
+# - pacman will search repositories in the order defined here
+# - local/custom mirrors can be added here or in separate files
+# - repositories listed first will take precedence when packages
+# have identical names, regardless of version number
+# - URLs will have $repo replaced by the name of the current repo
+# - URLs will have $arch replaced by the name of the architecture
+#
+# Repository entries are of the format:
+# [repo-name]
+# Server = ServerName
+# Include = IncludePath
+#
+# The header [repo-name] is crucial - it must be present and
+# uncommented to enable the repo.
+#
+
+# The testing repositories are disabled by default. To enable, uncomment the
+# repo name header and Include lines. You can add preferred servers immediately
+# after the header, and they will be used before the default mirrors.
+
+#[testing]
+#Include = /etc/pacman.d/mirrorlist
+
+[core]
+Include = /etc/pacman.d/mirrorlist
+
+[extra]
+Include = /etc/pacman.d/mirrorlist
+
+#[community-testing]
+#Include = /etc/pacman.d/mirrorlist
+
+[community]
+Include = /etc/pacman.d/mirrorlist
+
+# An example of a custom package repository. See the pacman manpage for
+# tips on creating your own repositories.
+#[custom]
+#SigLevel = Optional TrustAll
+#Server = file:///home/custompkgs
diff --git a/pacman.conf.x86_64 b/pacman.conf.x86_64
new file mode 100644
index 000000000000..8ce691913fef
--- /dev/null
+++ b/pacman.conf.x86_64
@@ -0,0 +1,100 @@
+#
+# /etc/pacman.conf
+#
+# See the pacman.conf(5) manpage for option and repository directives
+
+#
+# GENERAL OPTIONS
+#
+[options]
+# The following paths are commented out with their default values listed.
+# If you wish to use different paths, uncomment and update the paths.
+#RootDir = /
+#DBPath = /var/lib/pacman/
+#CacheDir = /var/cache/pacman/pkg/
+#LogFile = /var/log/pacman.log
+#GPGDir = /etc/pacman.d/gnupg/
+#HookDir = /etc/pacman.d/hooks/
+HoldPkg = pacman glibc
+#XferCommand = /usr/bin/curl -C - -f %u > %o
+#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
+#CleanMethod = KeepInstalled
+#UseDelta = 0.7
+Architecture = auto
+
+# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
+#IgnorePkg =
+#IgnoreGroup =
+
+#NoUpgrade =
+#NoExtract =
+
+# Misc options
+#UseSyslog
+#Color
+#TotalDownload
+CheckSpace
+#VerbosePkgLists
+
+# By default, pacman accepts packages signed by keys that its local keyring
+# trusts (see pacman-key and its man page), as well as unsigned packages.
+SigLevel = Required DatabaseOptional
+LocalFileSigLevel = Optional
+#RemoteFileSigLevel = Required
+
+# NOTE: You must run `pacman-key --init` before first using pacman; the local
+# keyring can then be populated with the keys of all official Arch Linux
+# packagers with `pacman-key --populate archlinux`.
+
+#
+# REPOSITORIES
+# - can be defined here or included from another file
+# - pacman will search repositories in the order defined here
+# - local/custom mirrors can be added here or in separate files
+# - repositories listed first will take precedence when packages
+# have identical names, regardless of version number
+# - URLs will have $repo replaced by the name of the current repo
+# - URLs will have $arch replaced by the name of the architecture
+#
+# Repository entries are of the format:
+# [repo-name]
+# Server = ServerName
+# Include = IncludePath
+#
+# The header [repo-name] is crucial - it must be present and
+# uncommented to enable the repo.
+#
+
+# The testing repositories are disabled by default. To enable, uncomment the
+# repo name header and Include lines. You can add preferred servers immediately
+# after the header, and they will be used before the default mirrors.
+
+#[testing]
+#Include = /etc/pacman.d/mirrorlist
+
+[core]
+Include = /etc/pacman.d/mirrorlist
+
+[extra]
+Include = /etc/pacman.d/mirrorlist
+
+#[community-testing]
+#Include = /etc/pacman.d/mirrorlist
+
+[community]
+Include = /etc/pacman.d/mirrorlist
+
+# If you want to run 32 bit applications on your x86_64 system,
+# enable the multilib repositories as required here.
+
+#[multilib-testing]
+#Include = /etc/pacman.d/mirrorlist
+
+#[multilib]
+#Include = /etc/pacman.d/mirrorlist
+
+# An example of a custom package repository. See the pacman manpage for
+# tips on creating your own repositories.
+#[custom]
+#SigLevel = Optional TrustAll
+#Server = file:///home/custompkgs