summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorphiresky2022-05-31 09:57:23 +0200
committerphiresky2022-05-31 09:57:23 +0200
commit7f77c541a703800a6b729dc72eda23f89d34a102 (patch)
treeb485be243989f5eef1820172f93ddc3436a86935
parentb84f5a4a234ac83fff66e6001b592d7af290977e (diff)
downloadaur-7f77c541a703800a6b729dc72eda23f89d34a102.tar.gz
use -Qtdq not -Qttdq
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
-rw-r--r--log-orphans.hook2
3 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 18acf0f80231..0dd60e25db72 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = pacman-log-orphans-hook
pkgdesc = hook to check whether there are any packages marked as unrequired (orphans) via pacman -Qttdq after every pacman run
- pkgver = 1.0
+ pkgver = 1.1
pkgrel = 1
arch = any
source = log-orphans.hook
diff --git a/PKGBUILD b/PKGBUILD
index 49cea1f38f08..9f6ce692cb3b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=pacman-log-orphans-hook
-pkgver=1.0
+pkgver=1.1
pkgrel=1
pkgdesc='hook to check whether there are any packages marked as unrequired (orphans) via pacman -Qttdq after every pacman run'
arch=(any)
@@ -9,4 +9,4 @@ sha256sums=('49ddc67ad6dbb1e57a13ca0c3c2f0de243fad98b302d4f708b3a746522b56ebb')
package() {
install -Dm0644 -t "$pkgdir/usr/share/libalpm/hooks/" ${source[0]}
-} \ No newline at end of file
+}
diff --git a/log-orphans.hook b/log-orphans.hook
index e34738782f4a..151e1c95dc0c 100644
--- a/log-orphans.hook
+++ b/log-orphans.hook
@@ -8,4 +8,4 @@ Target=*
[Action]
Description=Log Orphan Packages
When=PostTransaction
-Exec=/bin/bash -c 'pkgs="$(pacman -Qttdq)"; if [[ ! -z "$pkgs" ]]; then echo -e "The following packages are installed but not required (anymore):\n$pkgs\nYou can mark them as explicitly installed with '\''pacman -D --asexplicit <pkg>'\'' or remove them all using '\''pacman -Qtdq | pacman -Rns -'\''"; fi' \ No newline at end of file
+Exec=/bin/bash -c 'pkgs="$(pacman -Qtdq)"; if [[ ! -z "$pkgs" ]]; then echo -e "The following packages are installed but not required (anymore):\n$pkgs\nYou can mark them as explicitly installed with '\''pacman -D --asexplicit <pkg>'\'' or remove them all using '\''pacman -Qtdq | pacman -Rns -'\''"; fi'