summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlesto2019-02-23 19:33:03 +0100
committerlesto2019-02-23 19:33:03 +0100
commit70479c77ece1e56248819f9f030dd68c2bcf0a77 (patch)
tree1a6be7beb4f2857956c9b170d4796250897f8190
parent7d83b9f32a99ff9ec162fdcb2f9ff099a93688b2 (diff)
downloadaur-70479c77ece1e56248819f9f030dd68c2bcf0a77.tar.gz
updated to release 3
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD6
-rw-r--r--[-rwxr-xr-x]pp.sh6
3 files changed, 9 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f76b205595a6..89dd836a4930 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = pacman-parallelizer
pkgdesc = A minimal package downloader for pacman, using aria2
- pkgver = 2
- pkgrel = 2
+ pkgver = 3
+ pkgrel = 1
url = https://github.com/lestofante/PacmanParallelizer
arch = any
license = GPL3
depends = aria2
depends = pacman-contrib
source = pp.sh
- md5sums = 8e58bf0fd5702cf10a35917a43752b2b
+ md5sums = 65102e8f4fb043afc6bd15bf3b4db6c0
pkgname = pacman-parallelizer
diff --git a/PKGBUILD b/PKGBUILD
index bb2a610f2dc1..01df39e64d27 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,14 +1,14 @@
# Maintainer: lesto <lestofante88@gmail.com>
pkgname=pacman-parallelizer
-pkgver=2
-pkgrel=2
+pkgver=3
+pkgrel=1
pkgdesc="A minimal package downloader for pacman, using aria2"
arch=(any)
url="https://github.com/lestofante/PacmanParallelizer"
license=('GPL3')
depends=('aria2' 'pacman-contrib')
source=("pp.sh")
-md5sums=('8e58bf0fd5702cf10a35917a43752b2b')
+md5sums=('65102e8f4fb043afc6bd15bf3b4db6c0')
build() {
cd "$srcdir"
diff --git a/pp.sh b/pp.sh
index 3da11aa3c8c3..ea2634d1e7d4 100755..100644
--- a/pp.sh
+++ b/pp.sh
@@ -1,8 +1,8 @@
#!/bin/bash
-maxMirrorForDownload=4
-
arch=$(uname -m)
+maxMirrorForDownload=4
+pacmanCahceDir="$(pacman-conf CacheDir)"
if [[ $UID -ne 0 ]]; then
sudo -p 'Restarting as root, password: ' bash $0 "$@"
@@ -45,7 +45,7 @@ for pkgNameAndVersion in "${packageList[@]}"; do
fi
done
- aria2c -c $downloadList -d /var/cache/pacman/pkg/ &> /dev/null &
+ aria2c -c $downloadList -d "pacmanCahceDir" &> /dev/null &
running=$(jobs |wc -l)
echo ">>> $(date +%T) | Downloading $pkgName, $running/$maxParallelDownload download"