summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrenyuneyun (Rui Zhao)2018-02-22 14:29:39 +0000
committerrenyuneyun (Rui Zhao)2018-02-22 14:30:04 +0000
commit2518d1627edac91af6fdaae1346939a18ad0999c (patch)
tree9f18043929d165b4094dbd159873ce8d5f3b0974
parenteafcb56b1b23587bb79999165dbb2aca4bf86f02 (diff)
downloadaur-2518d1627edac91af6fdaae1346939a18ad0999c.tar.gz
update AUR scripts (removed the complaint of file not existing)
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD4
-rw-r--r--pacman-ps.install2
3 files changed, 4 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bf48f8aa988f..1ccaef2f974f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pacman-pstatus
pkgdesc = Provides a command to identify which running processes have files that have changed on disk. It also provides a pacman hook and pacman-ps to also show which packages own the files that are still open. (forked from samcv's pacman-ps)
pkgver = 0.2.1
- pkgrel = 2
+ pkgrel = 3
url = https://gitlab.com/renyuneyun/pacman-ps
install = pacman-ps.install
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index d467963b3b44..2c6945fba93b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Author and Maintainer: renyuneyun <renyuneyun@gmail.com>
# Original author: Samantha McVey <samantham@posteo.net>
-# Copyright (C) 2017
+# Copyright (C) 2017 - 2018
# This file and project are licensed under the GPLv2 or greater at your choice.
# For more information view the license included or visit:
# https://www.gnu.org/licenses/gpl-2.0.html
pkgname=('pacman-pstatus')
pkgver=0.2.1
-pkgrel=2
+pkgrel=3
arch=('any')
url='https://gitlab.com/renyuneyun/pacman-ps'
license=('GPL')
diff --git a/pacman-ps.install b/pacman-ps.install
index 9b5d17ba48cf..bc28f6f7d0b8 100644
--- a/pacman-ps.install
+++ b/pacman-ps.install
@@ -4,12 +4,12 @@ post_install() {
# If the database exists, just update it and keep existing entries
if [ -f "${DB_DIR}/files.db" ]; then
pacman -Ql | sort -u -k 2,2 - "${DB_DIR}/files.db" > "${DB_DIR}/files-temp.db"
+ rm "${DB_DIR}/files.db"
# Otherwise create it
else
mkdir -p "${DB_DIR}"
pacman -Ql | sort -u -k 2,2 - > ${DB_DIR}/files-temp.db
fi
- rm "${DB_DIR}/files.db"
mv "${DB_DIR}/files-temp.db" "${DB_DIR}/files.db"
printf "Created initial database at %s/files.db\n" "${DB_DIR}"
}