summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBhanupong Petchlert2022-12-03 08:07:17 +0700
committerBhanupong Petchlert2022-12-03 08:07:17 +0700
commitbf21eadde3ce4793a27a0a734d0a8e0e7ee8485e (patch)
tree88e69193fb4958d6989fe5dd4884f69e68012a2c
downloadaur-bf21eadde3ce4793a27a0a734d0a8e0e7ee8485e.tar.gz
pacman-repo-stats v0.3.0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD35
2 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1e8bcc087f51
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = pacman-repo-stats
+ pkgdesc = Show usage statistics of repositories in pacman.conf
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/bpetlert/pacman-repo-stats
+ arch = x86_64
+ license = GPL-3.0-or-later
+ makedepends = cargo
+ depends = pacman
+ provides = pacman-repo-stats
+ conflicts = pacman-repo-stats
+ source = pacman-repo-stats-0.3.0.tar.gz::https://github.com/bpetlert/pacman-repo-stats/archive/0.3.0.tar.gz
+ sha256sums = 7f30bc4cab3082a1ccfb858f50ce5f4ff243da5c3fccec99ec4a301b609a2879
+
+pkgname = pacman-repo-stats
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ecf12e6e7797
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Bhanupong Petchlert <bpetlert@gmail.com>
+pkgname=pacman-repo-stats
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="Show usage statistics of repositories in pacman.conf"
+arch=('x86_64')
+url="https://github.com/bpetlert/pacman-repo-stats"
+license=('GPL-3.0-or-later')
+depends=(pacman)
+makedepends=(cargo)
+provides=("${pkgname}")
+conflicts=("${pkgname}")
+
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/bpetlert/${pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('7f30bc4cab3082a1ccfb858f50ce5f4ff243da5c3fccec99ec4a301b609a2879')
+
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
+build() {
+ cd "${pkgname}-${pkgver}"
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --frozen --release
+}
+
+package() {
+ cd "${pkgname}-${pkgver}"
+ install -Dm755 "target/release/pacman-repo-stats" "$pkgdir/usr/bin/pacman-repo-stats"
+
+ install -Dm644 "README.adoc" "$pkgdir/usr/share/doc/${pkgname}/README.adoc"
+ install -Dm644 "COPYING" "$pkgdir/usr/share/licenses/${pkgname}/COPYING"
+}