summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel R. van Rossum2015-06-18 16:27:37 -0500
committerDaniel R. van Rossum2015-06-18 16:27:37 -0500
commit8b46b4a68f50865f70316e5ef681c38c7f9ca072 (patch)
tree71a81d32a341d9a2408ef74f2bab3be7d9b823df
downloadaur-8b46b4a68f50865f70316e5ef681c38c7f9ca072.tar.gz
initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD29
-rw-r--r--pacman4console24
-rw-r--r--pacman4console.patch107
-rw-r--r--pacman4consoleedit47
5 files changed, 227 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d778af84df85
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = pacman4console
+ pkgdesc = A 9 level ncurses pacman game with editor, patched not to disturb our package manager and to have nice ghosts
+ pkgver = 1.2
+ pkgrel = 1
+ url = http://sites.google.com/site/doctormike/pacman.html
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = ncurses
+ source = http://ftp.debian.org/debian/pool/main/p/pacman4console/pacman4console_1.2.orig.tar.gz
+ source = pacman4console.patch
+ source = pacman4console
+ source = pacman4consoleedit
+ md5sums = 1568960898ad9cb66c77412b85cd7d86
+ md5sums = fdd2bd5b2d7f2a4afa5634146449288c
+ md5sums = b913fb9959f2988a41457c270eb0d3b3
+ md5sums = fc43203fcbc5b27872131ac6dfe85ddc
+
+pkgname = pacman4console
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9c22529e1b79
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+#Maintainer: Erus <erus.iluvatar@gmail.com>
+pkgname=pacman4console
+pkgver=1.2
+pkgrel=1
+pkgdesc="A 9 level ncurses pacman game with editor, patched not to disturb our package manager and to have nice ghosts"
+arch=('i686' 'x86_64')
+url="http://sites.google.com/site/doctormike/pacman.html"
+license=('GPL')
+depends=('ncurses')
+makedepends=()
+source=('http://ftp.debian.org/debian/pool/main/p/pacman4console/pacman4console_1.2.orig.tar.gz' 'pacman4console.patch' 'pacman4console' 'pacman4consoleedit')
+md5sums=('1568960898ad9cb66c77412b85cd7d86'
+ 'fdd2bd5b2d7f2a4afa5634146449288c'
+ 'b913fb9959f2988a41457c270eb0d3b3'
+ 'fc43203fcbc5b27872131ac6dfe85ddc')
+
+build() {
+ cd pacman-$pkgver/
+ patch -i ../$pkgname.patch
+ make
+}
+
+package() {
+ cd pacman-$pkgver/
+ make DESTDIR=$pkgdir install || return 1
+ install -D -m644 COPYING $pkgdir/usr/share/licenses/$pkgname/LICENSE
+ install -D -m644 ../pacman4console $pkgdir/usr/share/man/man6/pacman4console.6
+ install -D -m644 ../pacman4consoleedit $pkgdir/usr/share/man/man1/pacman4consoleedit.1
+}
diff --git a/pacman4console b/pacman4console
new file mode 100644
index 000000000000..f4f52abb5553
--- /dev/null
+++ b/pacman4console
@@ -0,0 +1,24 @@
+.TH PACMAN4CONSOLE 6 "december 8, 2006"
+.SH NAME
+pacman4console \- a console based pacman game
+.SH SYNOPSIS
+.B pacman4console
+.RB [
+.I OPTION
+.RB ]
+.SH DESCRIPTION
+This manual page documents briefly the
+.B pacman4console.
+.PP
+\fBpacman4console\fP is an ASCII character based game. This game haves nine levels.
+.SH OPTION
+.B n
+- Start level n
+.SH SEE ALSO
+pacman4consoleedit(1)
+.SH AUTHOR
+pacman4console was written by Michael Billars (aka Dr. Mike) and is available at http://doctormike.googlepages.com/pacman.html.
+.PP
+.nh
+.ad l
+This manual page was written by Joao Eriberto Mota Filho <eriberto@eriberto.pro.br>, for the Debian project (but may be used by others).
diff --git a/pacman4console.patch b/pacman4console.patch
new file mode 100644
index 000000000000..0889affafc1a
--- /dev/null
+++ b/pacman4console.patch
@@ -0,0 +1,107 @@
+--- Makefile 2009-12-22 13:23:44.086853403 +0100
++++ Makefile.new 2009-12-22 13:26:21.380175264 +0100
+@@ -1,17 +1,17 @@
+ all:
+- gcc -lncurses pacman.c -o pacman
+- gcc -lncurses pacmanedit.c -o pacmanedit
++ gcc -lncurses pacman.c -o pacman4console
++ gcc -lncurses pacmanedit.c -o pacman4consoleedit
+
+ install: all
+- cp pacman /usr/local/bin
+- cp pacmanedit /usr/local/bin
+- mkdir -p /usr/local/share/pacman
+- cp -fR Levels/ /usr/local/share/pacman/
+- chown root:games /usr/local/bin/pacman
+- chown root:games /usr/local/share/pacman -R
+- chmod 750 /usr/local/bin/pacman
+- chmod 750 /usr/local/bin/pacmanedit
+- chmod 750 /usr/local/share/pacman/ -R
++ install -D pacman4console $(DESTDIR)/usr/bin/pacman4console
++ install -D pacman4consoleedit $(DESTDIR)/usr/bin/pacman4consoleedit
++ mkdir -p $(DESTDIR)/usr/share/pacman4console
++ cp -fR Levels/ $(DESTDIR)/usr/share/pacman4console/
++ chown root:games $(DESTDIR)/usr/bin/pacman4console
++ chown root:games $(DESTDIR)/usr/share/pacman4console -R
++ chmod 755 $(DESTDIR)/usr/bin/pacman4console
++ chmod 755 $(DESTDIR)/usr/bin/pacman4consoleedit
++ chmod 755 $(DESTDIR)/usr/share/pacman4console/ -R
+
+ uninstall:
+ rm -f /usr/local/bin/pacman
+--- pacman.c 2009-12-22 13:28:23.423485413 +0100
++++ pacman.c.new 2009-12-22 13:31:01.556844974 +0100
+@@ -196,10 +196,10 @@
+
+ //Display ghosts
+ if(Invincible == 0) {
+- wattron(win, COLOR_PAIR(Ghost1)); mvwaddch(win, Loc[0][0], Loc[0][1], '&');
+- wattron(win, COLOR_PAIR(Ghost2)); mvwaddch(win, Loc[1][0], Loc[1][1], '&');
+- wattron(win, COLOR_PAIR(Ghost3)); mvwaddch(win, Loc[2][0], Loc[2][1], '&');
+- wattron(win, COLOR_PAIR(Ghost4)); mvwaddch(win, Loc[3][0], Loc[3][1], '&');
++ wattron(win, COLOR_PAIR(Ghost1)); mvwaddch(win, Loc[0][0], Loc[0][1], 'A');
++ wattron(win, COLOR_PAIR(Ghost2)); mvwaddch(win, Loc[1][0], Loc[1][1], 'A');
++ wattron(win, COLOR_PAIR(Ghost3)); mvwaddch(win, Loc[2][0], Loc[2][1], 'A');
++ wattron(win, COLOR_PAIR(Ghost4)); mvwaddch(win, Loc[3][0], Loc[3][1], 'A');
+ }
+
+ //OR display vulnerable ghosts
+@@ -323,10 +323,10 @@
+ if(getch()!=ERR) return;
+ wattron(win, COLOR_PAIR(Pellet)); mvwprintw(win, 13, 23, "*");
+ wattron(win, COLOR_PAIR(Pacman)); mvwprintw(win, 13, a, " C");
+- wattron(win, COLOR_PAIR(Ghost1)); mvwprintw(win, 13, a-3, " &");
+- wattron(win, COLOR_PAIR(Ghost3)); mvwprintw(win, 13, a-5, " &");
+- wattron(win, COLOR_PAIR(Ghost2)); mvwprintw(win, 13, a-7, " &");
+- wattron(win, COLOR_PAIR(Ghost4)); mvwprintw(win, 13, a-9, " &");
++ wattron(win, COLOR_PAIR(Ghost1)); mvwprintw(win, 13, a-3, " A");
++ wattron(win, COLOR_PAIR(Ghost3)); mvwprintw(win, 13, a-5, " A");
++ wattron(win, COLOR_PAIR(Ghost2)); mvwprintw(win, 13, a-7, " A");
++ wattron(win, COLOR_PAIR(Ghost4)); mvwprintw(win, 13, a-9, " A");
+ wrefresh(win);
+ usleep(100000);
+ }
+@@ -341,7 +341,7 @@
+ //Make ghosts half as fast
+ if(a%2) b--;
+
+- wattron(win, COLOR_PAIR(BlueGhost)); mvwprintw(win, 13, b-9, "& & & &");
++ wattron(win, COLOR_PAIR(BlueGhost)); mvwprintw(win, 13, b-9, "A A A A");
+ wattron(win, COLOR_PAIR(Pacman)); mvwprintw(win, 13, b-9+1, " ");
+ wattron(win, COLOR_PAIR(Pacman)); mvwprintw(win, 13, b-9+3, " ");
+ wattron(win, COLOR_PAIR(Pacman)); mvwprintw(win, 13, b-9+5, " ");
+--- pacman.h 2009-12-22 13:28:36.600151049 +0100
++++ pacman.h.new 2009-12-22 13:31:14.193571255 +0100
+@@ -1,5 +1,5 @@
+ // Some variables that you may want to change
+-char LevelFile[50] = "/usr/local/share/pacman/Levels/level__.dat"; //Locations of default levels
++char LevelFile[50] = "/usr/share/pacman4console/Levels/level__.dat"; //Locations of default levels
+ int FreeLife = 1000; //Starting points for free life
+ int Points = 0; //Initial points
+ int Lives = 3; //Number of lives you start with
+--- pacmanedit.c 2009-12-22 13:28:46.550158906 +0100
++++ pacmanedit.c.new 2009-12-22 13:33:44.830134771 +0100
+@@ -89,10 +89,10 @@
+ case 2: chr = '.'; attr = A_NORMAL; wattron(win, COLOR_PAIR(Pellet)); break;
+ case 3: chr = '*'; attr = A_BOLD; wattron(win, COLOR_PAIR(PowerUp)); break;
+ case 4: chr = ' '; attr = A_NORMAL; wattron(win, COLOR_PAIR(GhostWall)); break;
+- case 5: chr = '&'; attr = A_NORMAL; wattron(win, COLOR_PAIR(Ghost1)); break;
+- case 6: chr = '&'; attr = A_NORMAL; wattron(win, COLOR_PAIR(Ghost2)); break;
+- case 7: chr = '&'; attr = A_NORMAL; wattron(win, COLOR_PAIR(Ghost3)); break;
+- case 8: chr = '&'; attr = A_NORMAL; wattron(win, COLOR_PAIR(Ghost4)); break;
++ case 5: chr = 'A'; attr = A_NORMAL; wattron(win, COLOR_PAIR(Ghost1)); break;
++ case 6: chr = 'A'; attr = A_NORMAL; wattron(win, COLOR_PAIR(Ghost2)); break;
++ case 7: chr = 'A'; attr = A_NORMAL; wattron(win, COLOR_PAIR(Ghost3)); break;
++ case 8: chr = 'A'; attr = A_NORMAL; wattron(win, COLOR_PAIR(Ghost4)); break;
+ case 9: chr = 'C'; attr = A_NORMAL; wattron(win, COLOR_PAIR(Pacman)); break;
+ }
+ mvwaddch(win, a, b, chr | attr);
+@@ -113,7 +113,7 @@
+ wattron(status, COLOR_PAIR(Pellet)); mvwaddch(status, 1, 19, '.');
+ wattron(status, COLOR_PAIR(PowerUp)); mvwaddch(status, 1, 26 , '*' | A_BOLD);
+ wattron(status, COLOR_PAIR(GhostWall)); mvwaddch(status, 2, 3, ' ');
+- wattron(status, COLOR_PAIR(Ghost1)); mvwaddch(status, 2, 12, '&');
++ wattron(status, COLOR_PAIR(Ghost1)); mvwaddch(status, 2, 12, 'A');
+ wattron(status, COLOR_PAIR(Pacman)); mvwaddch(status, 2, 19, 'C');
+
+ wrefresh(status);
diff --git a/pacman4consoleedit b/pacman4consoleedit
new file mode 100644
index 000000000000..33d95ad6be35
--- /dev/null
+++ b/pacman4consoleedit
@@ -0,0 +1,47 @@
+.TH PACMAN4CONSOLEEDIT 1 "january 4, 2007"
+.SH NAME
+pacman4consoleedit \- an editor to make pacman4console mazes
+.SH SYNOPSIS
+.B pacman4consoleedit
+file
+.SH DESCRIPTION
+This manual page documents briefly the
+.B pacman4consoleedit.
+.PP
+\fBpacman4consoleedit\fP is an editor used to make new pacman4console mazes.
+.SH KEYS
+0 Insert space (way)
+.br
+1 Insert wall
+.br
+2 Insert pill
+.br
+3 Insert vitamin
+.br
+4 Insert an exit for fantasms
+.br
+5 Change position of the red fantasm
+.br
+6 Change position of the cyan fantasm
+.br
+7 Change position of the magenta fantasm
+.br
+8 Change position of the orange fantasm
+.br
+9 Change position of the Pacman
+.br
+f Change all spaces to pills
+.br
+c Change all pills to spaces
+.br
+q Save and exit
+.SH MAZE FILE LOCATION
+The maze files are localized at /usr/share/pacman4console/Levels.
+.SH SEE ALSO
+pacman4console(6)
+.SH AUTHOR
+pacman4console was written by Michael Billars (aka Dr. Mike) and is available at http://doctormike.googlepages.com/pacman.html.
+.PP
+.nh
+.ad l
+This manual page was written by Joao Eriberto Mota Filho <eriberto@eriberto.pro.br>, for the Debian project (but may be used by others).