summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakob Gruber2015-06-21 23:22:51 +0200
committerJakob Gruber2015-06-21 23:25:09 +0200
commit41730e99cbed305e6e4c53f923092d26814ccb24 (patch)
tree587887b30ee4d8a9ffa8e5492faf48a2e9b95e77
downloadaur-pacman_sdl.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD26
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..60ad90285a74
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = pacman_sdl
+ pkgdesc = Pacman clone using SDL. Guide Pacman through a maze and collect pac-dots while avoiding ghosts.
+ pkgver = 0.1.1
+ pkgrel = 2
+ url = http://github.com/schuay/pacman/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = boost
+ depends = sdl_ttf
+ depends = sdl_gfx
+ depends = sdl_mixer
+ depends = sdl_image
+ source = https://github.com/downloads/schuay/pacman/pacman-0.1.1.tar.bz2
+ md5sums = 8cc780d3995579c329f297455899fff5
+
+pkgname = pacman_sdl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..876654aa04bb
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: schuay <jakob.gruber@gmail.com>
+
+pkgname=pacman_sdl
+pkgver=0.1.1
+pkgdesc="Pacman clone using SDL. Guide Pacman through a maze and collect pac-dots while avoiding ghosts."
+pkgrel=2
+arch=('i686' 'x86_64')
+url="http://github.com/schuay/pacman/"
+license=('GPL')
+source=("https://github.com/downloads/schuay/pacman/pacman-$pkgver.tar.bz2")
+md5sums=('8cc780d3995579c329f297455899fff5')
+depends=('sdl_ttf' 'sdl_gfx' 'sdl_mixer' 'sdl_image')
+makedepends=('boost')
+
+build() {
+ cd ${srcdir}/src/
+
+ autoconf
+ ./configure
+ make
+}
+package() {
+ cd ${srcdir}/src/
+
+ make DESTDIR=${pkgdir} install
+}