summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorΝικόλαος Κυριάκος Φυτίλης2017-10-05 12:51:29 +0300
committerΝικόλαος Κυριάκος Φυτίλης2017-10-05 12:51:29 +0300
commit986b2b11137ee0d81f86ecd523c036a652995971 (patch)
tree1831d628812f7886c96891099f3a4768d289f54b
downloadaur-986b2b11137ee0d81f86ecd523c036a652995971.tar.gz
innit
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD36
-rw-r--r--extra_life.patch33
4 files changed, 94 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..72543e777158
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = pacman_sdl-ebuc99-git
+ pkgdesc = Pacman clone using SDL. Guide Pacman through a maze and collect pac-dots while avoiding ghosts. (ebuc99 fork)
+ pkgver = v0.5.r201.g6ca0147
+ pkgrel = 1
+ url = http://github.com/ebuc99/pacman/
+ arch = i686
+ arch = x86_64
+ license = GPLv2
+ makedepends = boost
+ makedepends = sed
+ depends = sdl_ttf
+ depends = sdl_gfx
+ depends = sdl_mixer
+ depends = sdl_image
+ source = git+https://github.com/ebuc99/pacman.git
+ source = extra_life.patch
+ md5sums = SKIP
+ md5sums = a788d57a73cc7a82ac2a9161bc96ae3b
+
+pkgname = pacman_sdl-ebuc99-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..858ddd9e491e
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pacman
+src
+pkg
+*tar*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dd60e1ffe094
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: schuay <jakob.gruber@gmail.com>
+
+pkgname=pacman_sdl-ebuc99-git
+_pkgbase=pacman
+pkgver=v0.5.r201.g6ca0147
+pkgdesc="Pacman clone using SDL. Guide Pacman through a maze and collect pac-dots while
+avoiding ghosts. (ebuc99 fork)"
+pkgrel=1
+arch=('i686' 'x86_64')
+url="http://github.com/ebuc99/pacman/"
+license=('GPLv2')
+source=("git+https://github.com/ebuc99/pacman.git"
+ 'extra_life.patch')
+md5sums=('SKIP'
+ 'a788d57a73cc7a82ac2a9161bc96ae3b')
+depends=('sdl_ttf' 'sdl_gfx' 'sdl_mixer' 'sdl_image')
+makedepends=('boost' 'sed')
+
+pkgver() {
+ cd "$_pkgbase"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/$_pkgbase"
+ patch -p1 -i "${srcdir}/extra_life.patch"
+ ./configure
+ make
+}
+package() {
+ cd "${srcdir}/$_pkgbase"
+ make DESTDIR="${pkgdir}" install
+ mv "${pkgdir}/usr/local/bin/"pacman{,_sdl}
+ sed -e 's/Exec=pacman/Exec=pacman_sdl/g' \
+ -i "${pkgdir}/usr/local/share/applications/pacman.desktop"
+}
diff --git a/extra_life.patch b/extra_life.patch
new file mode 100644
index 000000000000..7d7df5ddc070
--- /dev/null
+++ b/extra_life.patch
@@ -0,0 +1,33 @@
+From d2d6b21ae50a9e50fe5cb7fe1f1bf2e73cee7e1e Mon Sep 17 00:00:00 2001
+From: borgified <borgified@gmail.com>
+Date: Sat, 16 Sep 2017 13:29:58 -0700
+Subject: [PATCH] extra pacman life at every 10000 pts
+
+---
+ src/game.cpp | 10 +++++++++-
+ 1 file changed, 9 insertions(+), 1 deletion(-)
+
+diff --git a/src/game.cpp b/src/game.cpp
+index c8c7567..caf4b7b 100644
+--- a/src/game.cpp
++++ b/src/game.cpp
+@@ -325,9 +325,17 @@ bool Game::checkLastPillEaten() {
+ void Game::checkScoreForExtraLife() {
+ int lastScore = currentScore;
+ currentScore = Labyrinth::getInstance()->getScore();
+- if ((lastScore<10000 && currentScore>=10000) || (lastScore<30000 && currentScore>=30000)) {
++
++ int target = ( currentScore / 10000 ) * 10000;
++
++ if (lastScore<10000 && currentScore>=10000){
+ Pacman::getInstance()->addLives(1);
+ Sounds::getInstance()->playSingleSound(Sounds::EXTRA_MAN);
++ }else{
++ if (lastScore<target && currentScore>=target){
++ Pacman::getInstance()->addLives(1);
++ Sounds::getInstance()->playSingleSound(Sounds::EXTRA_MAN);
++ }
+ }
+ }
+
+