summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoan Figueras2016-08-04 21:43:19 +0200
committerJoan Figueras2016-08-04 21:43:19 +0200
commitf66d27eb5f00b6f7134febc6bb4302027d50ba0e (patch)
treedd891b00a9d31b745213eacab9d526252e9737f5
parent432e302656391ceeb367307f20927019c9afc9cc (diff)
downloadaur-f66d27eb5f00b6f7134febc6bb4302027d50ba0e.tar.gz
Added new bugfix
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
-rw-r--r--bugfix_ctrl-tab_in_last-focused_mode.patch75
3 files changed, 89 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0b13691f83cd..3f380fff89d0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Thu Aug 4 17:26:59 UTC 2016
+# Thu Aug 4 19:42:56 UTC 2016
pkgbase = pacmanager-git
pkgdesc = Perl Auto Connector PAC Manager. GIT version with fixed FreeRDP interface.
pkgver = 4.5.5.8
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/perseo22/pacmanager
arch = any
license = GPL3
@@ -29,10 +29,12 @@ pkgbase = pacmanager-git
source = 0001-xfreerdp-new-interface.patch
source = 0002-xfreerdp-new-interface.patch
source = 0003-xfreerdp-new-interface.patch
+ source = bugfix_ctrl-tab_in_last-focused_mode.patch
md5sums = SKIP
md5sums = d7350164daad682396c3278d6c40bb9d
md5sums = cc4b26825efcf1d6c2aeea2b92531c40
md5sums = ac48e3d9ee6b0694a42c123498b06c64
+ md5sums = 731a8fb19105f0e0b05446ff8cabd311
pkgname = pacmanager-git
diff --git a/PKGBUILD b/PKGBUILD
index 23e571898aeb..a5b567e65017 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=pacmanager-git
_pkgname=${pkgname%-git}
pkgver=4.5.5.8
-pkgrel=2
+pkgrel=3
arch=('any')
license=('GPL3')
pkgdesc="Perl Auto Connector PAC Manager. GIT version with fixed FreeRDP interface."
@@ -15,19 +15,25 @@ conflicts=(pacmanager-bin)
source=("git+https://github.com/perseo22/pacmanager.git"
"0001-xfreerdp-new-interface.patch"
"0002-xfreerdp-new-interface.patch"
- "0003-xfreerdp-new-interface.patch")
+ "0003-xfreerdp-new-interface.patch"
+ "bugfix_ctrl-tab_in_last-focused_mode.patch")
md5sums=('SKIP'
'd7350164daad682396c3278d6c40bb9d'
'cc4b26825efcf1d6c2aeea2b92531c40'
- 'ac48e3d9ee6b0694a42c123498b06c64')
+ 'ac48e3d9ee6b0694a42c123498b06c64'
+ '731a8fb19105f0e0b05446ff8cabd311')
prepare() {
cd ${srcdir}/${_pkgname}
- # Apply patches for new FreeRDP interface
+
+ # Apply patches for new FreeRDP interface (thanks to hador / https://github.com/hador/pacmanager )
patch -Np1 -i $srcdir/0001-xfreerdp-new-interface.patch
patch -Np1 -i $srcdir/0002-xfreerdp-new-interface.patch
# The third patch is done by me
patch -Np1 -i $srcdir/0003-xfreerdp-new-interface.patch
+
+ # Patch to fix ctrl-tab in last-focused mode (thanks to merikz / https://github.com/merikz/pacmanager/commit/ec861a8ba1f35070ea70496dd9d18976cfa6cca3 )
+ patch -Np1 -i $srcdir/bugfix_ctrl-tab_in_last-focused_mode.patch
}
build() {
diff --git a/bugfix_ctrl-tab_in_last-focused_mode.patch b/bugfix_ctrl-tab_in_last-focused_mode.patch
new file mode 100644
index 000000000000..72ff8238c155
--- /dev/null
+++ b/bugfix_ctrl-tab_in_last-focused_mode.patch
@@ -0,0 +1,75 @@
+From ec861a8ba1f35070ea70496dd9d18976cfa6cca3 Mon Sep 17 00:00:00 2001
+From: Merikz <merikz.code@gmail.com>
+Date: Sun, 20 Mar 2016 19:55:47 +0100
+Subject: [PATCH] bugfix: ctrl-tab in last-focused mode
+
+When active tab was changed by mouse, ctrl-tab did not go to correct tab.
+The mouse click did not update the meaning of "previous" tab.
+
+Fixes: #1
+---
+ lib/PACMain.pm | 9 ++-------
+ 1 file changed, 2 insertions(+), 7 deletions(-)
+
+diff --git a/lib/PACMain.pm b/lib/PACMain.pm
+index d8dbe87..29b4eef 100644
+--- a/lib/PACMain.pm
++++ b/lib/PACMain.pm
+@@ -1810,7 +1810,6 @@ sub _setupCallbacks {
+
+ if ( $$self{_CFG}{defaults}{'ctrl tab'} eq 'last' ) {
+ $$self{_GUI}{nb} -> set_current_page( $$self{_PREVTAB} );
+- $$self{_PREVTAB} = $curr_page;
+ } else {
+ if ( $curr_page == 0 ) { $$self{_GUI}{nb} -> set_current_page( $$self{_GUI}{nb} -> get_n_pages - 1 ); }
+ else { $$self{_GUI}{nb} -> prev_page; }
+@@ -1821,26 +1820,22 @@ sub _setupCallbacks {
+ elsif ( $ctrl && ( ! $$self{_CFG}{'defaults'}{'disable CTRL key bindings'} ) ) {
+ # Capture <Ctrl>PgUp/Left --> select previous tab
+ if ( $keyval eq 'Page_Up' && ! $$self{_CFG}{'defaults'}{'how to switch tabs'} ) {
+- $$self{_PREVTAB} = $curr_page;
+ if ( $curr_page == 0 ) { $$self{_GUI}{nb} -> set_current_page( -1 ); }
+ else { $$self{_GUI}{nb} -> prev_page; }
+ }
+ # Capture <Ctrl>PgDwn/Right --> select next tab
+ elsif ( $keyval eq 'Page_Down' && ! $$self{_CFG}{'defaults'}{'how to switch tabs'} ) {
+- $$self{_PREVTAB} = $curr_page;
+ if ( $curr_page == $$self{_GUI}{nb} -> get_n_pages - 1 ) { $$self{_GUI}{nb} -> set_current_page( 0 ); }
+ else { $$self{_GUI}{nb} -> next_page; }
+ }
+ # Capture <Ctrl>number --> select number tab
+ elsif ( $keyval =~ /^\d$/go ) {
+- $$self{_PREVTAB} = $curr_page;
+ $$self{_GUI}{nb} -> set_current_page( $keyval - ( $$self{_CFG}{'defaults'}{'tabs in main window'} ? 0 : 1 ) );
+ }
+ # Capture <Ctrl>TAB --> switch between tabs
+ elsif ( $keyval eq 'Tab' ) {
+ if ( $$self{_CFG}{defaults}{'ctrl tab'} eq 'last' ) {
+ $$self{_GUI}{nb} -> set_current_page( $$self{_PREVTAB} );
+- $$self{_PREVTAB} = $curr_page;
+ } else {
+ if ( $curr_page == $$self{_GUI}{nb} -> get_n_pages - 1 ) { $$self{_GUI}{nb} -> set_current_page( 0 ); }
+ else { $$self{_GUI}{nb} -> next_page; }
+@@ -1852,13 +1847,11 @@ sub _setupCallbacks {
+ } elsif ( $alt && ( ! $$self{_CFG}{'defaults'}{'disable ALT key bindings'} ) && $$self{_CFG}{'defaults'}{'how to switch tabs'} ) {
+ # Capture <Alt>PgUp/Left --> select previous tab
+ if ( $keyval eq 'Left' ) {
+- $$self{_PREVTAB} = $curr_page;
+ if ( $curr_page == 0 ) { $$self{_GUI}{nb} -> set_current_page( -1 ); }
+ else { $$self{_GUI}{nb} -> prev_page; }
+ }
+ # Capture <Alt>PgDwn/Right --> select next tab
+ elsif ( $keyval eq 'Right' ) {
+- $$self{_PREVTAB} = $curr_page;
+ if ( $curr_page == $$self{_GUI}{nb} -> get_n_pages - 1 ) { $$self{_GUI}{nb} -> set_current_page( 0 ); }
+ else { $$self{_GUI}{nb} -> next_page; }
+ } else { return 0; }
+@@ -1904,6 +1897,8 @@ sub _setupCallbacks {
+ #if ( $pnum == 0 && $$self{_CFG}{defaults}{'tabs in main window'} && $$self{'_CFG'}{'defaults'}{'auto hide connections list'} ) { $$self{_GUI}{showConnBtn} -> set_active( 1 ); }
+ #elsif ( $$self{_CFG}{defaults}{'tabs in main window'} && $$self{'_CFG'}{'defaults'}{'auto hide connections list'} ) { $$self{_GUI}{showConnBtn} -> set_active( 0 ); }
+
++ $$self{_PREVTAB}=$nb->get_current_page;
++
+ my $tab_page = $nb -> get_nth_page( $pnum );
+
+ $$self{_HAS_FOCUS} = '';