summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorThe-Repo-Club2022-10-23 14:16:36 +0100
committerThe-Repo-Club2022-10-23 14:16:36 +0100
commit5a509282906ee000cdac727b9930a099e2dca762 (patch)
tree304aa5eb9967965525bcddf66de10f6dbe851939
parentc9b7a6e8e05b8bca3d316b3272991f3dbc2f2c58 (diff)
downloadaur-5a509282906ee000cdac727b9930a099e2dca762.tar.gz
Bump Version
Signed-off-by: The-Repo-Club <wayne6324@gmail.com>
-rw-r--r--.SRCINFO25
-rw-r--r--PKGBUILD42
-rw-r--r--pacmanity.install49
3 files changed, 84 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7c0cadab80d8..7ead6a4a22a7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = pacmanity
+ pkgdesc = Keeps a list of installed packages in a Gist at your GitHub account
+ pkgver = 2021.11.14
+ pkgrel = 1
+ url = https://github.com/The-Repo-Club/pacmanity
+ install = pacmanity.install
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = pacman>=6.0
+ depends = gist>=4.5.0
+ source = pacmanity-2021.11.14.tar.gz::https://github.com/The-Repo-Club/pacmanity/archive/2021.11.14.tar.gz
+ sha256sums = 64c874b208126a0cf6e28b81b15912dae87010cd48b01c09b20564cd1646e1c5
+
pkgname = pacmanity
-pkgdesc = Keeps a list of installed packages in a Gist at your GitHub account
-pkgver = 3.0
-pkgrel = 1
-url = https://github.com/DerekTBrown/pacmanity
-arch = x86_64
-arch = i686
-license = GPL
-makedepends = git
-depends = pacman>=5.0
-depends = gist>=4.5.0
-source = pacmanity::git+https://github.com/DerekTBrown/pacmanity.git
-md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 9809e8b6644d..7a7dbef048dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,33 @@
+# Maintainer: The-Repo-Club <The-Repo-Club@github.com>
+# Contributor: The-Repo-Club <The-Repo-Club@github.com>
+# shellcheck disable=all
+
pkgname=pacmanity
-pkgver=3.0
+pkgver=2021.11.14
pkgrel=1
pkgdesc="Keeps a list of installed packages in a Gist at your GitHub account"
-url="https://github.com/DerekTBrown/$pkgname"
-arch=('x86_64' 'i686')
+arch=('x86_64')
+url="https://github.com/The-Repo-Club/$pkgname"
license=('GPL')
makedepends=('git')
-depends=('pacman>=5.0' 'gist>=4.5.0')
-source=("$pkgname::git+https://github.com/DerekTBrown/$pkgname.git")
-md5sums=('SKIP')
+depends=('pacman>=6.0' 'gist>=4.5.0')
+source=("${pkgname}-$pkgver.tar.gz::${url}/archive/$pkgver.tar.gz")
+sha256sums=('64c874b208126a0cf6e28b81b15912dae87010cd48b01c09b20564cd1646e1c5')
+install=${pkgname}.install
package() {
+ cd "$pkgname-$pkgver"
+ # Install script
+ mkdir -p $pkgdir/usr/lib/pacmanity
+ install -Dm755 pacmanity_update $pkgdir/usr/lib/pacmanity/pacmanity_update
+ chmod +x $pkgdir/usr/lib/pacmanity/pacmanity_update
- # Install and save file
- mkdir -p $pkgdir/etc/
- touch $pkgdir/etc/pacmanity
-
- # Install script
- mkdir -p $pkgdir/usr/lib/pacmanity
- cp $srcdir/pacmanity/src/pacmanity.sh $pkgdir/usr/lib/pacmanity/pacmanity.sh
- chmod +x $pkgdir/usr/lib/pacmanity/pacmanity.sh
-
- # Install Hook
- mkdir -p $pkgdir/usr/share/libalpm/hooks
- cp $srcdir/pacmanity/src/pacmanity.hook $pkgdir/usr/share/libalpm/hooks/zzz-pacmanity.hook
+ install -Dm755 pacmanity_install $pkgdir/usr/bin/pacmanity_install
+ chmod +x $pkgdir/usr/bin/pacmanity_install
- source $pkgdir/usr/lib/pacmanity/pacmanity.sh
- pacmanity_install
+ # Install Hook
+ mkdir -p $pkgdir/usr/share/libalpm/hooks
+ install -Dm755 pacmanity.hook $pkgdir/usr/share/libalpm/hooks/99-pacmanity.hook
+ install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.md"
}
diff --git a/pacmanity.install b/pacmanity.install
new file mode 100644
index 000000000000..892c47537af7
--- /dev/null
+++ b/pacmanity.install
@@ -0,0 +1,49 @@
+## Set Colors (copied from makepkg)
+if tput setaf 0 >/dev/null; then
+ ALL_OFF="$(tput sgr0)"
+ BOLD=$(tput bold)
+ RED="$(tput setaf 1)"
+ GREEN="$(tput setaf 2)"
+ YELLOW="$(tput setaf 3)"
+ BLUE="$(tput setaf 4)"
+ PURPLE="$(tput setaf 5)"
+ CYAN="$(tput setaf 6)"
+else
+ ALL_OFF="\e[1;0m"
+ BOLD="\[1;1m"
+ RED="\e[1;31m"
+ GREEN="\e[1;32m"
+ YELLOW="\e[1;33m"
+ BLUE="\e[1;34m"
+ PURPLE="\e[1:35m"
+ CYAN="\e[1:36m"
+fi
+COLS="$(tput cols)"
+
+readonly ALL_OFF BOLD RED GREEN YELLOW BLUE PURPLE CYAN COLS
+
+repeat(){
+ printf "%.0s$1" $(seq "45") && echo
+}
+
+post_install() {
+ if [[ -f /usr/bin/tbsm ]]; then
+ printf "${RED}
+ _ _
+ (_)| |
+ _ __ __ _ ___ _ __ ___ __ _ _ __ _ | |_ _ _
+| '_ \ / _' | / __|| '_ ' _ \ / _' || '_ \ | || __|| | | |
+| |_) || (_| || (__ | | | | | || (_| || | | || || |_ | |_| |
+| .__/ \__,_| \___||_| |_| |_| \__,_||_| |_||_| \__| \__, |
+| | __/ |
+|_| |___/ ${ALL_OFF}\n"
+ repeat '-'
+ printf "BEFORE FRIST INSTALL PLEASE READ\n"
+ printf "run '${GREEN}pacmanity_install${ALL_OFF}' to link to gists\n"
+ repeat '-'
+ fi
+}
+
+post_upgrade() {
+ post_install
+}