summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordszryan2020-10-07 17:04:00 +1100
committerdszryan2020-10-07 17:04:00 +1100
commit10e80d423c56582b13bef7b3fc8932cbbd8c7484 (patch)
treec743281227b09c78e80954ec1ded756dc74f2a74
parentfe8dddc3a2ec412f11ccc59bd35b0ac5c88f9ea7 (diff)
downloadaur-10e80d423c56582b13bef7b3fc8932cbbd8c7484.tar.gz
simplified build
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD13
2 files changed, 5 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 124fa67c301b..0e5e0f757313 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = pacmanity-git
pkgdesc = Keeps a list of installed packages in a Gist at your GitHub account
pkgver = 3.0.1
- pkgrel = 4
+ pkgrel = 5
epoch = 1
url = https://github.com/DerekTBrown/pacmanity
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index 8f4dd7b11b30..10712f1f2971 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: dszryan
pkgname=pacmanity-git
pkgver=3.0.1
-pkgrel=4
+pkgrel=5
epoch=1
pkgdesc="Keeps a list of installed packages in a Gist at your GitHub account"
arch=('x86_64' 'i686')
@@ -24,17 +24,12 @@ package() {
mkdir -p "$pkgdir/etc" "$pkgdir/usr/lib/pacmanity" "$pkgdir/usr/share/libalpm/hooks"
install -m774 "$srcdir/${pkgname/-git/}/src/pacmanity.sh" "$pkgdir/usr/lib/pacmanity/pacmanity.sh"
install -m664 "$srcdir/${pkgname/-git/}/src/pacmanity.hook" "$pkgdir/usr/share/libalpm/hooks/zzz-pacmanity.hook"
- if [ -f "/etc/pacmanity" ]; then # if file is present, assume it is maanged externally (via a build system)
- GIST_ID=$(cat "/etc/pacmanity" | sed "s|GIST_ID=||g")
- else
- touch "$pkgdir/etc/pacmanity"
- fi
# run
. $pkgdir/usr/lib/pacmanity/pacmanity.sh
- if [[ -z "$GIST_ID" ]]; then
- pacmanity_install
+ if [[ -f "/etc/pacmanity" ]]; then # if file is present, assume it is maanged externally (via a build system)
+ GIST_ID=$(sed "s|GIST_ID=||g" /etc/pacmanity) pacmanity_update
else
- pacmanity_update
+ pacmanity_install
fi
}