summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordszryan2020-10-07 14:11:07 +1100
committerdszryan2020-10-07 14:11:07 +1100
commitc08d16bf5f8e43b1496daf9e278cb10711a8c94d (patch)
treeca1bde5754f4f744b1835f7e2f619eac35e0c688
parent71f445dfc9929ee67711154468cc35d70344d26d (diff)
downloadaur-c08d16bf5f8e43b1496daf9e278cb10711a8c94d.tar.gz
added SKIP_FIRST_RUN to support unattended builds
-rw-r--r--PKGBUILD2
1 files changed, 2 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 26873de23556..32491b9fd93a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -27,5 +27,7 @@ package() {
install -m664 "$srcdir/$pkgname/src/pacmanity.hook" "$pkgdir/usr/share/libalpm/hooks/zzz-pacmanity.hook"
# run
+ if [[ -z "$SKIP_FIRST_RUN" ]]; then
. $pkgdir/usr/lib/pacmanity/pacmanity.sh && pacmanity_install
+ fi
}