summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoralexiobash2015-06-24 19:15:01 +0200
committeralexiobash2015-06-24 19:15:01 +0200
commitf6e48b688a1618e8c1ad0f04e4a3a51a48be18bf (patch)
treefbada4efc61d624fad82afa8b02caafde263dd4c
downloadaur-f6e48b688a1618e8c1ad0f04e4a3a51a48be18bf.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD23
-rw-r--r--pacmind.install7
3 files changed, 50 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9190167d7c34
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = pacmind
+ pkgdesc = A gtkdialog frontend gui for the package manager, inspired to yaourt-gui
+ pkgver = 2.5
+ pkgrel = 1
+ url = http://www.xfce-italia.it/index.php?topic=636.0
+ install = pacmind.install
+ arch = any
+ license = GPL
+ depends = gtkdialog
+ depends = zenity
+ depends = yaourt
+ depends = xterm
+ depends = sudo
+ optdepends = aurvote: Tool to vote for favorite AUR packages
+ optdepends = yaourt-gui: A bash GUI for yaourt
+ source = pacmind::git+http://git.alexiobash.com/git/pacmind
+ md5sums = SKIP
+
+pkgname = pacmind
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9057eb72f926
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: alexiobash < me (at) alexiobash (dot) com >
+
+pkgname=pacmind
+pkgver=2.5
+pkgrel=1
+pkgdesc="A gtkdialog frontend gui for the package manager, inspired to yaourt-gui"
+arch=('any')
+url="http://www.xfce-italia.it/index.php?topic=636.0"
+license=('GPL')
+depends=('gtkdialog' 'zenity' 'yaourt' 'xterm' 'sudo')
+optdepends=(
+ 'aurvote: Tool to vote for favorite AUR packages'
+ 'yaourt-gui: A bash GUI for yaourt'
+)
+source=("$pkgname::git+http://git.alexiobash.com/git/$pkgname")
+install="${pkgname}.install"
+md5sums=('SKIP')
+
+
+package() {
+ cd $srcdir/$pkgname
+ make DESTDIR=${pkgdir} install
+}
diff --git a/pacmind.install b/pacmind.install
new file mode 100644
index 000000000000..3a8edece3966
--- /dev/null
+++ b/pacmind.install
@@ -0,0 +1,7 @@
+pkgname="yaourt-gui"
+
+post_install() {
+ echo
+ echo "==> PACMIND and YAOURT-GUI will soon be a single package "
+ echo
+}