summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlo Teubner2017-03-18 13:47:32 +0000
committerCarlo Teubner2017-03-18 13:47:32 +0000
commit0c137890a9a933894174015c9ad685ee3a030ab4 (patch)
tree495b63fbeae68f5e1c006317bcfaa40c59f52dbf
downloadaur-0c137890a9a933894174015c9ad685ee3a030ab4.tar.gz
Initial release
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD19
2 files changed, 35 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..01dcca65b246
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = pacmods
+ pkgdesc = Tool to show changes to system config files
+ pkgver = 0.1.0
+ pkgrel = 1
+ url = https://github.com/c4rlo/pacmods
+ arch = any
+ license = MIT
+ depends = python
+ depends = python-setuptools
+ depends = pyalpm
+ options = !emptydirs
+ source = https://github.com/c4rlo/pacmods/archive/0.1.0.tar.gz
+ sha256sums = b413c09cb03a075acfec88b5366b3d7681e96220f1a8cc79c15d58e1ae7667fc
+
+pkgname = pacmods
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6d63dcaa531b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Carlo Teubner <carlo.teubner@gmail.com>
+pkgname=pacmods
+pkgver=0.1.0
+pkgrel=1
+pkgdesc="Tool to show changes to system config files"
+arch=('any')
+url="https://github.com/c4rlo/pacmods"
+license=('MIT')
+depends=('python' 'python-setuptools' 'pyalpm')
+options=(!emptydirs)
+source=("https://github.com/c4rlo/${pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('b413c09cb03a075acfec88b5366b3d7681e96220f1a8cc79c15d58e1ae7667fc')
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: