summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlessio Biancalana2016-08-24 20:16:12 +0200
committerAlessio Biancalana2016-08-24 20:16:12 +0200
commit022ab7182837a75f2ae75e55b3217c77380a5368 (patch)
treed19771a0d0d4cbf31d45766c0383d21ff3951782
downloadaur-022ab7182837a75f2ae75e55b3217c77380a5368.tar.gz
first submission
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD30
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aea7fca8b45f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = pacnews
+ pkgdesc = Read Arch News from your CLI
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://github.com/dottorblaster/pacnews
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = go
+ makedepends = git
+ source = https://github.com/dottorblaster/pacnews/archive/v1.0.0.tar.gz
+ md5sums = 3a78d8da47d5552b00966c330d16d08b
+
+pkgname = pacnews
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a5655880fcab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Alessio Biancalana <dottorblaster@gmail.com>
+pkgname=pacnews
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Read Arch News from your CLI"
+arch=('i686' 'x86_64')
+license=('MIT')
+url="https://github.com/dottorblaster/pacnews"
+makedepends=('go' 'git')
+source=("https://github.com/dottorblaster/$pkgname/archive/v${pkgver}.tar.gz")
+md5sums=('3a78d8da47d5552b00966c330d16d08b')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ rm -rf "$srcdir/.go/src"
+ mkdir -p "$srcdir/.go/src"
+ export GOPATH="$srcdir/.go"
+
+ go get github.com/fatih/color
+ go get github.com/SlyMarbo/rss
+ go get github.com/kennygrant/sanitize
+
+ go build pacnews.go
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ install -DT "pacnews" "$pkgdir/usr/bin/pacnews"
+}