summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjonarnold2017-04-08 19:42:14 -0400
committerjonarnold2017-04-08 19:42:14 -0400
commit078637ac71dcca4d566f3ce9c23db0911880869e (patch)
treea0b8265ea957d82e17fb77d6caf34f54d0128de1
downloadaur-078637ac71dcca4d566f3ce9c23db0911880869e.tar.gz
initial pacpl upload
-rw-r--r--.SRCINFO29
-rw-r--r--PKGBUILD48
-rw-r--r--pacpl.install59
3 files changed, 136 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..577e35544c59
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = pacpl
+ pkgdesc = Convert multiple audio types from one format to another.
+ pkgver = 5.1.0
+ pkgrel = 1
+ url = http://pacpl.sourceforge.net/
+ install = pacpl.install
+ arch = any
+ license = GPL
+ depends = perl
+ depends = perl-parse-recdescent
+ depends = perl-inline
+ depends = libogg
+ depends = flac
+ depends = perl-ogg-vorbis-header
+ depends = perl-mp3-info
+ depends = perl-mp4-info
+ depends = perl-mp3-tag
+ depends = perl-audio-flac-header
+ depends = perl-audio-musepack
+ depends = cddb_get
+ depends = vorbis-tools
+ depends = perl-switch
+ depends = perl-parallel-forkmanager
+ depends = perl-cddb
+ source = git://git.code.sf.net/p/pacpl/code
+ md5sums = SKIP
+
+pkgname = pacpl
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c7722d061a50
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,48 @@
+# Maintainer: Jon Arnold <jonarnoldsemail at gmail dot com>
+# Contributor: Xiao-Long Chen
+pkgname=pacpl
+pkgver=5.1.0
+pkgrel=1
+pkgdesc="Convert multiple audio types from one format to another."
+arch=('any')
+url="http://pacpl.sourceforge.net/"
+license=('GPL')
+depends=(
+ 'perl'
+ 'perl-parse-recdescent'
+ 'perl-inline'
+ 'libogg'
+ 'flac'
+ 'perl-ogg-vorbis-header'
+ 'perl-mp3-info'
+ 'perl-mp4-info'
+ 'perl-mp3-tag'
+ 'perl-audio-flac-header'
+ 'perl-audio-musepack'
+ 'cddb_get'
+ 'vorbis-tools'
+ 'perl-switch'
+ 'perl-parallel-forkmanager'
+ 'perl-cddb'
+)
+install=${pkgname}.install
+source=(git://git.code.sf.net/p/pacpl/code)
+makedeps=(
+ 'autoconf'
+)
+md5sums=('SKIP')
+
+
+build() {
+ cd "${srcdir}/code"
+ autoconf
+ ./configure
+ make
+}
+
+package() {
+ cd "${srcdir}/code"
+ make DESTDIR="${pkgdir}" install
+ rm -rvf ${pkgdir}/usr/share/apps
+}
+# vim:syntax=sh
diff --git a/pacpl.install b/pacpl.install
new file mode 100644
index 000000000000..e03710f4a7ac
--- /dev/null
+++ b/pacpl.install
@@ -0,0 +1,59 @@
+post_install() {
+ echo "You must have the appropriate codecs installed to convert."
+ echo ""
+ echo "The following programs are required for full functionality."
+ echo "Note that some are in AUR, and some don't have packages (yet)."
+ echo "==> lame"
+ echo "==> flac"
+ echo "==> shorten"
+ echo "==> faac"
+ echo "==> faad2"
+ echo "==> cdparanoia"
+ echo "==> vorbis-tools"
+ echo "==> mplayer"
+ echo "==> musepack-tools"
+ echo "==> wavpack"
+ echo "==> ofr/ofs (OPTIMfrog)"
+ echo "==> ttaenc"
+ echo "==> lpac"
+ echo "==> speex"
+ echo "==> ffmpeg"
+ echo "==> la"
+ echo "==> bonk"
+ echo "==> sox"
+ echo ""
+ echo "Preferences are located in /etc/pacpl/pacpl.conf"
+}
+
+# arg 1: the new package version
+# arg 2: the old package version
+post_upgrade() {
+ echo "You must have the appropriate codecs installed to convert."
+ echo ""
+ echo "The following programs are required for full functionality."
+ echo "Note that some are in AUR, and some don't have packages (yet)."
+ echo "==> lame"
+ echo "==> flac"
+ echo "==> shorten"
+ echo "==> faac"
+ echo "==> faad2"
+ echo "==> cdparanoia"
+ echo "==> vorbis-tools"
+ echo "==> mplayer"
+ echo "==> musepack-tools"
+ echo "==> wavpack"
+ echo "==> ofr/ofs (OPTIMfrog)"
+ echo "==> ttaenc"
+ echo "==> lpac"
+ echo "==> speex"
+ echo "==> ffmpeg"
+ echo "==> la"
+ echo "==> bonk"
+ echo "==> sox"
+ echo ""
+ echo "Preferences are located in /etc/pacpl/pacpl.conf"
+}
+
+op=$1
+shift
+$op $*